BehavePlus fire modeling system
Frequently Asked Questions (FAQS)

This compilation of frequently asked questions (FAQs) provides answers

to common questions about the BehavePlus fire modeling system. Please check these FAQs
and the Known Bugs page for answers to your questions before contacting the Fire
Applications Help Desk (see FAQ 1.6).

Contents
1. BeRAVEPIUS STATUS. ...ttt ettt ettt et e et e e e 2
1.1. What is the latest version of BehavePIus? ....... ..o 2
1.2.  What are the BehavePlus system requirements? ............cooviiiiiiiiiiiiiiineaannnn.. 2
1.3. How do | make sure | have the most recent version of BehavePlus?................... 2
1.4. Who developed and maintains BehavePlus? ..........cooovviiiiiiiiii e 2
1.5.  Are there any supporting doCUMENTS?......cooiiiiiiiii e eeeeeeeeeaaannn 3
1.6. Whodolcontact for help? ... ..o e 3
1.7.  Are there any training materials available? ..................... . 4
1.8. What are the BehavePlus license requirements? .........cooviiiiiiiiiiiiiiiiinneeennnn.. 4
1.9. How does BehavePlus differ from previous versions? ...........cccoevvvviviviienennnnn... 4
1.10. What is the relationship between BehavePlus Version 5 and the Fire Characteristics
(03 = g o] o] =0 2 4
1.11. How can | learn about the Fire Characteristics Chart program?........................ 4
1.12. How do | get values calculated in BehavePlus version 5 into the Fire Characteristics
(03 o o A 0T = 02 5
2. Getting and Installing BEhavePIus . ... ... 5
2.1. Wherecanlget BehavePIus? ... ... e 5
2.2.  How do I install BehavePlus for the first time? ..................... ... 5
2.3.  How do | re-install or upgrade BehavePIus? ...... ... 5
2.4. How do | use Runs, Worksheets, Fuel Models, Moisture Scenarios, and Units Sets
developed in Version 4 with Version 57 ... e 5
2.5. How do | know when thereisanupdate?...........coooiiiiiiiiiiii e 6
2.6.  How do I subscribe to the NEWS?.....cooiiiiiiii e eeaeens 6
2.7. Why did the installation program fail/stop/hang before it finished?.................. 6
3. HOW O | s 6
3.1. How do I print the contents of a help browser pane or any dialog box? .............. 6
3.2. Howdo I trim a page that was captured and inserted into a Microsoft Word® (doc)
(0 0T B4 1= 0 6
3.3. How do | add a geographic place name for use in the Calendar Tool? ................ 6
4. Why doesn't Something WOrK? .. .. ...ttt e e e aanns 7
4.1. Why can | enter values into the shaded (gray or blue) input fields?................... 7
4.2.  Why can't | print or save the outputs of the Units Converter tool? .................... 7

4.3. | created and saved a custom fuel model (or moisture scenario) and used it in a run
that | also saved. But when | reopen the run file, | get an Invalid Input error
message saying the custom fuel model is an unknown choice.......................... 7

4.4.  Why do results of my run disappear after | save it and then later reopen it?........ 8

Page 1 of 8 Last Updated: 14 December 2016


http://www.frames.gov/documents/behaveplus/software/BehavePlus_KnownBugs.pdf

Note: The use of trade or firm names in this publication is for reader information and does
not imply endorsement by the U.S. Department of Agriculture of any product or service.

1. BehavePlus Status
1.1. Whatis the latest version of BehavePlus?

The most recent official version is BehavePlus Version 5.0.5, released on August 12, 2011.
The supplemental Fire Characteristics Chart program is version 1.0, released on June 22,
2011. (See FAQ 1.9)

For more information, please see the Change Log.

1.2.  What are the BehavePlus system requirements?

e Windows® 7 or earlier. The program also works in desktop mode in Windows 8.

e Designed for 1024x768 monitors with 16-bit (64K) colors, but 800x600 with 8-bit (256)
colors is adequate.

e 32 Mb memory (8 Mb of available memory).

e 50 Mb of hard drive storage.

e A PDF file viewer, such as Adobe Reader, for browsing help files.

1.3. How do I make sure I have the most recent version of BehavePlus?

To ensure you have the latest version of BehavePlus, compare the build version of your
installation with the build number on the BehavePlus Software page. The build number for
BehavePlus is located in the program under Help > Installation Info in the section entitled
Program Information. The build number for the program is part of the file name. For
example, the installation file for BehavePlus version 5.0.5 official release is bp_307.exe, and
the build number is 307.

1.4. Who developed and maintains BehavePlus?

Development of the BehavePlus fire modeling system and supporting material is possible due
to the support of:

o USDA Forest Service, Rocky Mountain Research Station, Fire, Fuel, and Smoke Science
Program.

o USDA Forest Service, Fire and Aviation Management, and

e Joint Fire Science Program (JFSP),

The BehavePlus program, the Fire Characteristics Chart program, and some of the supporting
materials were developed through contracts with Systems for Environmental Management
(SEM).

Faith Ann Heinsch, physical scientist, USDA Forest Service, Fire Sciences Lab, Missoula, MT,
currently manages BehavePlus, designs and determines updates to its feature set, performs
alpha testing, and creates documentation, including the Help system, features, training, and
system use. She is also responsible for Fire Characteristics Chart system design and
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maintenance, as well as maintaining the web presence for the BehavePlus fire modeling
system.

Pat Andrews, research scientist (retired), USDA Forest Service, Fire Sciences Lab, Missoula,
MT, was the principal investigator and managed the development of BehavePlus, designed and
determined its feature set, performed alpha testing, and assisted with the documentation
(publications and training) from its inception until her retirement. She continues to assist in
development and provides advice when needed.

Collin Bevins, research forester and president, System for Environmental Management (SEM),
Missoula, MT, designs, develops, and tests all the BehavePlus computer code and helps
determine its feature set and behavior.

Luke Schelvan, SEM, is the Fire Characteristics Chart program developer.

Deb Tirmenstein, SEM, conducts program testing and reviews and edits supporting documents
for both BehavePlus and the Fire Characteristics Chart.

The following individuals have worked on components of the BehavePlus project in the past:

e Erin Noonan-Wright, USDA Forest Service, developed training material as an SEM
contractor.

e Matt Jolly, USDA Forest Service, developed training material.

e Bobbie Bartlett, USDA Forest Service (retired), developed training material as an SEM
contractor.

e Joe Scott, Pyrologix and SEM, developed online help and training material.

e Rick Stratton, USDA Forest Service, developed training material as an SEM contractor.

e Rob Seli, U.S. Forest Service, developed supporting material including the User’s
Guide and training material.

e Tobin Kelley, USDA Forest Service, developed supporting material with focus on use of
BehavePlus for prescribed fire planning.

e Don Carlton, Fire Program Solutions and SEM, wrote the version 1 User's Guide and
online help system.

e Dave Custer, USDA Forest Service (retired), edited tutorials for version 1.

1.5. Are there any supporting documents?

The BehavePlus Features paper and Variables paper are part of the Help system and are
available for download in Portable Document Format (PDF). The version 4.0 User’s Guide is
also available and is still applicable to version 5. It can be found in the
INSTALLDIR/DocFolder/ en_US/Html/ UsersGuide.pdf. INSTALLDIR is the BehavePlus

installation directory where you installed the file. The default installation directory is
C:/Behave/BehavePlus5.

The Fire Characteristics Chart program contains help documents for both fire behavior and
fire danger rating. The report for the fire behavior tabs is available on the Publications page.

See the Publications page for additional documents.

1.6. Who do I contact for help?

The first level of technical support is provided through your local support channels.
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Primary user support for BehavePlus installation and use is provided by the U.S. Forest Service
Fire and Aviation Management Fire Applications Help Desk.

Fire Applications Help Desk
e Phone at 866-224-7677 or 616-323-1667,

e E-mail at IIA-Helpdesk@fs.fed.us, or
e Website at https://iia-hd.peckham-enclave.us/

The Fire Applications Help Desk is available for help with software issues only and cannot
answer fire behavior questions.

1.7.  Are there any training materials available?

See the Training page for lessons covering various aspects of BehavePlus.

1.8. What are the BehavePlus license requirements?

BehavePlus is freely available, without any warranty expressed or implied, to anyone who
wants to use it. The License Agreement only requires that you send a postcard depicting your
local area to:

USFS, RMRS, Fire Sciences Laboratory
BehavePlus fire modeling system

5775 US Highway 10 W
Missoula, MT 59808

1.9. How does BehavePlus differ from previous versions?

A comparison of the old BEHAVE program and BehavePlus Versions 1, 2, 3, 4, and 5 is
available for download on the BehavePlus Software page.

1.10. What is the relationship between BehavePlus Version 5 and the Fire
Characteristics Chart program?

While there is a fire characteristics chart output option in the SURFACE module of
BehavePlus5, it is limited and can be used only for calculated surface fire behavior. The Fire
Characteristics Chart program supplements BehavePlus5 and can be used for calculated or
observed surface or crown fire. It offers many options for designing a chart suitable for
presentations and reports.

1.11. How can I learn about the Fire Characteristics Chart program?
The program Help system includes information on using the program. A publication that

describes application, operation, and the mathematics of the fire behavior fire characteristics
chart is available on our Publications page.
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1.12. How do I get values calculated in BehavePlus version 5 into the Fire
Characteristics Chart program?

Values calculated in BehavePlus5 are entered manually into the Fire Characteristics Chart
program. Users can also enter observed fire behavior values or values from other fire behavior
software. If there are a large number of values, the Fire Characteristics Chart help
documentation provides information on exporting values from BehavePlus and importing them
into the program.

2. Getting and Installing BehavePlus
2.1.  Where can I get BehavePlus?

The BehavePlus program is available on the BehavePlus Software page.

2.2. How do I install BehavePlus for the first time?

The BehavePlus file you download is a self-installing executable for all Windows® operating
systems. It has a name like bp_307.exe. While BehavePlus is approved for U.S. Forest Service
use, employees need to right-click on the file and select Install elevated to install this
program. Others simply double-click to execute this file to install or update BehavePlus.

The complete instructions for installing the most recent release of BehavePlus are detailed in
the Release Notice installation instructions. These instructions may vary between releases, so
it is important you follow the appropriate Release Notice.

2.3. How do I re-install or upgrade BehavePlus?

The complete instructions for upgrading or re-installing BehavePlus are detailed in the
Release Notice upgrade instructions. These instructions may vary between releases, so it is
important to follow the appropriate Release Notice.

Important Note: Do not remove or update BehavePlus using any method other than that
described by the Release Notice. In other words, don't delete BehavePlus files or directories
via Windows Explorer® or via a command prompt. These methods do not remove the old
BehavePlus Windows Registry® entries, and can cause subsequent installation problems.

2.4. How do I use Runs, Worksheets, Fuel Models, Moisture Scenarios, and Units
Sets developed in Version 4 with Version 5?

Version 4 data files, including Run, Worksheet, Fuel Model, Moisture Scenario, and Units Set
files, can be read by Version 5. BehavePlus only looks in the directory in which it was installed
(e.g., Version 5 will only look in the folders in the BehavePlus5 directory). To use previously
developed worksheets, you need to copy the file or the entire folder containing relevant files
from the Version 4 directory to the Version 5 directory using Windows® Explorer. For more
information, please read Accessing BehavePlus Version 4 Files from Version 5.
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2.5. How do I know when there is an update?

You can check the BehavePlus Software page or subscribe to receive news items (see FAQ
2.6).

2.6. How do I subscribe to the News?

On the menu at the top of www.firelab.org, navigate to APPS & PRODUCTS > FIRE
BEHAVIOR. On the right-hand side of the page, there is a subscription box to receive email
about all three fire behavior systems (BehavePlus, FlamMap, and FARSITE). Emails are sent
regarding program releases, training updates, and other information, but generally no more
than one / month.

2.7. Why did the installation program fail/stop/hang before it finished?

On the occasions that this has been reported, it has been due to an incomplete or corrupted
installation program file. Since this is a fairly large file, it can sometimes get corrupted during
the download process. Check the downloaded file size against that published in the table in
the Release Notice or download the file again. If this problem continues, please contact the
U.S. Forest Service Fire and Aviation Management Fire Applications Help Desk (see FAQ 1.6).

3. HowdolI...?

3.1. How do I print the contents of a help browser pane or any dialog box?

Right-click just inside the outer border of the dialog box; this brings up a menu that includes
a Print option.

3.2. Howdo I trim a page that was captured and inserted into a Microsoft Word®
(doc) document?

A page can be captured from BehavePlus (using File > Save as an image) and inserted into a
Word® document using its Insert > Picture menu button. Excess blank space can be trimmed
by clicking on the image and using Crop from the Picture Tools toolbar.

An alternative to using the BehavePlus capture feature eliminates the step of saving an image
in a file. Use Alt-Print Screen to capture the BehavePlus window. It can be directly inserted
into a Word document using Paste or Ctrl-v. The Crop feature available on the Picture Tools
toolbar can then be used to trim excess space.

3.3. How doIadd a geographic place name for use in the Calendar Tool?

This requires some hands-on editing. First locate and read
INSTALLDIR/DocFolder/GeoFolder/GeoPlaceNames-FAQ, where INSTALLDIR is the
BehavePlus installation directory. This file tells you how to add a new place name. The
default installation directory is C:/Behave/BehavePlus5. The GeoPlaceNames-FAQ text file
tells you how to add a new place name.
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We recommend you create a copy of the Special.geo file and name it something such as
MyPlaces.geo. It must have a .geo extension. Then edit MyPlaces.geo using a text editor
(e.g., Notepad or Wordpad to add your new locations. Since MyPlaces.geo is not part of the
BehavePlus installation, it will not be removed or overwritten by new installations, so any
new place names you add will not disappear with new BehavePlus updates.

4. Why doesn't something work?

4.1. Why can I enter values into the shaded (gray or blue) input fields?

The shading on input fields is merely a visual advisory that the field is not currently required
given the other input values. If a fuel model with no live fuel load is selected (such as Fuel
Model 1 or TL3), for example, it is not necessary to enter live fuel moisture. But the moment
you select a fuel model with live fuel load (such as Fuel Model 7 or GS2), the live fuel
moisture is required and its shading is removed.

When developing custom fuel models, it should not be necessary to enter live fuel heat
content if there is no live fuel load. But the moment you enter a non-zero live fuel load, live
fuel heat content is required and its shading is removed. However, the program requires all
fields in a fuel model to be completed, whether or not they are shaded. Therefore, simply
enter a typical live heat content value (such as 8000 Btu/Ib) when the box is shaded. If the
box is shaded, this information will not be used in the surface fire spread model. The same
concept applies to the live fuel surface area-to-volume ratios.

You may enter values into input fields while they are shaded. If you do, it is tested for
validity just like any other input field.

4.2. Why can't ] print or save the outputs of the Units Converter tool?

The hidden trick here is to right-click just inside the outer border of the dialog box; this
brings up a menu that includes a Print option (see also FAQ 3.1).

4.3. Icreated and saved a custom fuel model (or moisture scenario) and used it in
arun thatI also saved. But when I reopen the run file, I get an Invalid Input
error message saying the custom fuel model is an unknown choice.

Custom fuel models and moisture scenarios must be attached to the BehavePlus session
before they can be used in calculations. That is, you must tell BehavePlus where to find it
since

e you could have saved it any of the fuel model subdirectories, and

e there could be several custom fuel models with the same name stored in different
directories (e.g., there are probably hundreds of versions of fuel model 14 floating
around out there).

BehavePlus has no way of knowing which one to use until you attach the folder where you
saved it.

To attach the fuel model (or moisture scenario), select Configure > Fuel model set selection
(or Configure > Moisture scenario set selection) from the main menu. Highlight the FOLDER
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in which the custom models reside and press Ok. This attaches all the custom models in that
folder to the BehavePlus run.

NOTE: Any folders that are not highlighted will not have their fuel models attached!

4.4, Why do results of my run disappear after I save it and then later reopen it?

BehavePlus does not save run results, just the run inputs and configuration (such as module
selection, input options, output variables, units of measure). Saving results would
significantly increase the size and complexity of saved run files. Results are always easily
regenerated by pressing the Calculate button after reloading the run.
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