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Change Log 
Summary of changes from the old BEHAVE through each version of BehavePlus 
The BEHAVE fire behavior prediction and fuel modeling system was first available to the field in 1984. JFSP 
funded a much-needed redesign and update to the BehavePlus fire modeling system version 1.0, which was released 
in 2002. Version 2.0 was released in 2003, Version 3.0 in 2005, Version 4.0 in 2008, and Version 5.0 in 2009. Each 
version update has offered additional features and fire modeling capabilities. The current version of the program is 
Version 6.0.0 Beta (Build 624), released in January 2018. The most significant changes are provided here. 

 

BehavePlus version 6 updates 
• The website for BehavePlus has changed. You can view information at http://www.frames.gov/behaveplus. 
• The Help system has been completely updated. 
• Publications are being updated, 

o The Features Paper will be updated and will include content to replace the User’s Guide.  
o The Variables Paper will be updated as time allows. 

• Lessons are being updated or created 
o Lessons describing the changes to the SURFACE module have been developed. 
o All existing lessons are being updated to reflect changes in BehavePlus v6.  

 
• Program Changes by Module 

o BehavePlus Tools 
 Change RH tool to add a Calculate button, ensuring consistency with other tools. 

o SURFACE Module 
 Directions – Calculate true flanking fire behavior when selecting the FLANKING Only option. 
 Entry of Fuel Model Number as well as code (e.g., enter 122 or gs2; 181 or tl1) 
 Moisture can be entered by individual size class; dead and live; dead, live herb and live woody; or 

moisture scenario 
 Ensure Surface ROS ≤ Effective WS when surface ROS > 0. 
 Added Special Case Fuel Model – Chaparral (Rothermel and Philpot as modified by Cohen) 

o CROWN Module 
 Use same moisture options in CROWN as in SURFACE when using CROWN in stand-alone mode 

(e.g., set moisture options to dead/live in SURFACE) 
 Scott and Reinhardt crown fire model as implemented in NEXUS 

o CONTAIN Module 
 The logic in the CONTAIN Module has been updated to allow resources on site to construct line 

without waiting for incoming resources. Previous versions did not allow line construction until all 
resources were available. 

o SAFETY Module 
 The SAFETY module has been deleted from BehavePlus as improved methods are forthcoming that 

will be available in a separate app created by the developers. 
o SPOT Module 

 Add trigger for open canopy (to calculate, rather than remember to divide downwind canopy height by 
2 for open canopies) 

 Change species codes to match FOFEM6 (and 2014 NRCS-PLANTS database) 
 Add spotting from active crown fire (Albini, Alexander, and Cruz) 

http://www.frames.gov/behaveplus
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o MORTALITY Module 
 Change species codes and equation numbers to match FOFEM6 (and 2014 NRCS-PLANTS database) 
 Add longleaf pine mortality model as in FOFEM6 

 

BehavePlus version 5 updates 
• The User’s Guide was not updated for version 5.0. The updates did not affect operation of the program. The 

version 4.0 User’s Guide is still applicable. 
• The Variables paper was updated for version 5.0. There are new and changed variables. Updates are also 

reflected in the Help windows. 
• Additional lessons have been developed. All lessons are now labeled version 5.0. There is a statement on the 

first page of each lesson indicating the extent of the changes from the version 4.0 lesson. In some cases the only 
change was the headers and footers. Many of the screen captures were not redone and are still labeled version 
4.0.0. 

• Additional models have been added to the CROWN module. The previous values are on the ‘Spread Outputs’ 
tab. The new output variables are on the ‘Intensity Outputs’ tab. A new flow diagram is in the help window. 
New variables include crown fireline intensity and flame length, power of the fire and of the wind, and wind-
driven or plume-dominated fire. 

• The tree mortality models have been updated in the MORTALITY module to match those in FOFEM. Ten new 
mortality equations are available. In some cases the results are very different from the old equations. The help 
system gives the equations and a table of the inputs used for each. The option of directly entering bark thickness 
was removed because the new equations don’t use that variable. The ‘Mortality equation’ variable added in 
version 4 was removed. The flow diagram was removed from the help system because it is not applicable to the 
new equations. 

• Changes were made to several overstory variables. This fixes a fatal crash situation in version 4.0. The change 
resolves potential inconsistencies in the relationship among Canopy Height, Canopy Base Height, and Crown 
Ratio. The variable Tree Height was changed to Torching Tree Height and is used only in SPOT to calculate 
spotting distance from torching trees. Canopy Height is now used as input to MORTALITY rather than Tree 
Height. 

• A new variable, Downwind Canopy Height, was added to the SPOT module and is used in the calculation of 
spotting distance. This value can different from Canopy Height at the site of the fire. 

• A new variable, Live Fuel Load Portion’, was added to the SURFACE Fuels Outputs tab. 
• The SUFRACE Basic Outputs tab variables list was getting too long. So two additional tabs were added: Wind 

Outputs and Slope Outputs. 
• Help > Installation Info now includes the path name of the startup worksheet file. 
• The Workspace notation at the bottom of the worksheet is now updated as soon as the workspace is changed, 

created, or cloned. 
• The maximum allowed value for wind speed was changed. Previous values were unreasonably high. 
• Surface Spread Distance is now correctly calculated for directions other than the direction of maximum spread 

(a bug in version 4). 
• The description of the Southern California (SoCalifornia) folder for Chaparral custom fuel models was changed 

from a defunct web site to a reference that is available on the BehavePlus Publications page. 
• The dead fuel moisture of extinction for fuel model SCAL15 was changed to the correct value, changed from 

15% to 13%. (v5.0.3) 
• The SCORCH module now uses the selected SURFACE module Wind Speed input option even when 

SURFACE is not active. 
• A two fuel model bug was fixed to produce the correct fireline intensity and flame length results. Other two-fuel 

bugs were fixed. 
• The name of the 0Startup.bpw file was changed to 0Default.bpw to avoid confusion. The 0Default.bpw 

worksheet file includes all of the selections for input options and output variables, appearance options, etc. and 
can be used as a starting place for defining a new worksheet. The startup worksheet, on the other hand, is the 
worksheet that opens when the program starts. The user can change the startup worksheet on the File menu (an 
option added in version 4). 
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• The decimal display set under Configure > Custom Units preferences is no longer applied to input variables. 
The decimal precision entered by the user onto the worksheet (or via the Guide dialog) is maintained on the 
worksheet, used in the calculations, and displayed in output tables. This resolves previous problems with 
rounding. The value displayed on the worksheet is used in the calculations, not a stored value with more 
precision. 

• When the units set is changed, six decimal places are given for input values (trailing zeros are suppressed). This 
helps the problem of rounding and changed values with unit conversions. 

• The Example Worksheets, FuelModeling.bpw and FuelModelingMetric.bpw, set six decimal places for fuel 
load variables when you select Initialize from a Fuel Model. 

• When a change to units or decimals is made using Configure > Custom units preferences, the question is 
asked: “Save as Units Set File?” An answer of “No” applies the changes to the current session without a saving 
a Units Set file for future use. 

• The Operation Unit Units and Decimals Lesson was updated to explain current operation. 
• A tool for Slope from map measurements has been added for quick calculations. 
• The Wind Adjustment Factor help file includes an updated diagram and table. An error in the unsheltered WAF 

for fuel model SH4 is corrected (from 0.4 to 0.5). (v5.0.3) 
• The maximum value allowed as input for fuel loading for all classes was increased from 31 to 45 ton/ac (100 

tonne/ha). (v5.0.3) 
• A new publication is available (http://www.treesearch.fs.fed.us/pubs/36989): Heinsch, Faith Ann; 

Andrews, Patricia L. 2010. BehavePlus fire modeling system, version 5.0: Design and Features. 
Gen. Tech. Rep. RMRS-GTR-249. Fort Collins, CO: U.S. Department of Agriculture, Forest Service, 
Rocky Mountain Research Station. 111 p. 

• The Fire Characteristics Chart, a supplement to the BehavePlus fire modeling system has been released. This 
program, a stand-alone version of the chart, provides graphical representation of modeled or observed fire 
behavior for surface and crown fire. It replaces the limited chart created in the SURFACE module of 
BehavePlus. (v1.0) 

• A new publication related to the Fire Characteristics Chart is available 
(http://www.treesearch.fs.fed.us/pubs/37380) Andrews, Patricia L.; Heinsch, Faith Ann; Schelvan, 
Luke. 2011. How to generate and interpret fire characteristics charts for surface and crown fire 
behavior. Gen. Tech. Rep. RMRS-GTR-253. Fort Collins, CO: U.S. Department of Agriculture, 
Forest Service, Rocky Mountain Research Station. 40 p. 

• An error has been corrected in the special case palmetto-gallberry fuel model (not one of the 53 standard fuel 
models). The answer was wrong for live moisture less than 120%. (v5.0.5) 

• The SURFACE options window is smaller to fit on small monitors. The Fuel & Moisture tab is now split into 
two tabs. (v5.0.5) 

 

BehavePlus version 4 updates 
• The User's Guide is updated to reflect operational changes.  
• A new Variables paper includes variable descriptions from the help windows and input/output tables (Andrews 

2008). The pdf document is available through the help system and includes many internal linkages to make is a 
useful reference guide. 

• As part of a JFSP funded project, the tutorials were updated, new lessons are available, and a plan for future 
training material development is planned. 

• The BehavePlus program and supporting material has been moved to a new web site: www.firelab.org, for fire 
behavior and fire danger software. Look under the Apps & Products link. The link to www.firemodels.org will 
redirect to the new site for at least a year. 

• Photographs and values for canopy cover, stand height, canopy bulk density, and canopy base height are 
available in help windows. The information is taken from Scott and Reinhardt (2005) ‘Stereo photo guide for 
estimating fuel characteristics in conifer stands.’ 

• The user has the option of identifying a worksheet to open at startup, rather than the BasicStart.bpw worksheet. 
• A tool was added to calculate horizontal map distance from ground map distance and direction with respect to 

upslope. 

http://www.treesearch.fs.fed.us/pubs/36989
http://www.treesearch.fs.fed.us/pubs/37380
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• The option was added to not impose the maximum reliable wind speed limit for the Rothermel surface fire 
spread model. Spread rate increases with increasing wind speed rather than being constant for high wind speeds. 

• The option was added to input curing level (fuel loading load transfer portion) for dynamic fuel models rather 
than calculating curing from live herbaceous fuel moisture. 

• A special case fuel model was added for western aspen (Brown and Simmerman 1986). 
• If bark thickness is a user input for MORTALITY, ‘mortality equation’ (spruce or not-spruce) is an input. This 

clarifies that the 206 species available for Mortality Species is used only to calculate bark thickness. 
• Additional output variables are available for SURFACE. Intermediate output values will aid understanding of 

the Rothermel surface fire spread model. 
• Fuel model names were changed to specifically mention short and long needle litter and to clarify that the fuel 

models are for surface fuel, not for the overstory. 
o 8—‘Closed timber litter’ to ‘Short needle litter’ 
o 9—‘Hardwood litter’ to ‘Long needle or hardwood litter’ 
o 10—‘Timber with litter & understory’ to ‘Timber litter & understory’ 
o TU4—‘Dwarf conifer with understory’ to ‘Dwarf conifer understory’ 

• Output variables were added to help understanding of calculated Wind Adjustment Factor: Crown fill portion 
and WAF calculation (sheltered or unsheltered). 

• Crown fire area and perimeter output variables were added, using the equations in Rothermel (1991). 
• Conditional Crown Fire was added as a Fire Type. In version 3 if Transition to crown fire? was No, then the fire 

type was Surface, whether Active crown fire? was Yes or No. 
• Changes to the main menu are more logical. For example, File > New is now File > Open worksheet. 
• File > saveAs > Results > Spreadsheet or Html is now File > Export results. In version 3, save as 

spreadsheet save the output table without input values as a .txt file. In version 4, only html files are exported. 
These files can be viewed in a browser, or they can be opened with spreadsheet software and then saved in 
spreadsheet format. 

• An ExportFolder has been added as the default location for Export results.  
• For the option Table shading for acceptable fire conditions, the option is added to produce tables with blank 

cells rather than crossed out values. The option is available in Configure > Appearance preferences > Tables 
tab. 

• Values entered in the Fine dead fuel moisture tool are remembered the next time the tool is used for the current 
session. 

• Another option has been added for worksheet header lines, for prescribed fire planning. 
• The range of values allowed for some input variables has been expanded. For example, the minimum value for 

Elapsed Time is now 0.1 hours rather than 0.5 hours. 
• The Language option was eliminated. Portuguese was available in version 3, as an example of how a translated 

version of BehavePlus could be developed. Due to lack of interest, the option has been disabled for now. 
• In version 3.0.2, the program sometimes ran slowly or not at all, particularly when installed in the default 

directory of ‘C:/SEM’. A change to the installation process fixes the problem in version 4.0. 
 

BehavePlus version 3 updates 
• A new CROWN module to calculate transition to crown fire and crown fire spread rate is added.  
• Calculation of wind adjustment factor (WAF) for fuel sheltered by overstory trees is added to SURFACE.  
• Table shading according to user-specified ranges of acceptable conditions for prescribed fire planning is 

available.  
• A CONTAIN option is added for single resource dispatch so tables and graphs can be produced for ranges of 

line construction rate, etc.  
• The ability to export table output to a spreadsheet for further analysis or custom display is available.  
• RH module is replaced by an RH tool.  
• The step function from the calculation of probability of ignition by a firebrand is resolved and removed.  
• Forty new surface fuel models, some with dynamic herbaceous live-to-dead fuel load transfer as a function of 

live fuel moisture are available in SURFACE.  
• A new moisture scenario set (named "FuelModeling") that was used to develop the new fuel models is added.  
• Custom fuel models can be exported in the file format required by FARSITE, FlamMap, and NEXUS.  
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• When the program starts up, a new BasicStart.bpw example worksheet is automatically loaded.  
• Module names are included on the Output Variables and Run Options lists for added clarity.  
• The "Fuel/Vegetation" worksheet section has been split into "Surface/Understory" and "Overstory" sections.  
• The Worksheet Appearance Dialog has a new option "show descriptions only for entered variable codes" as 

well as the "show descriptions for all discrete variable codes". The new option is the default for example 
worksheets.  

• A SurfaceCrown.bpw worksheet has been added to the set of example worksheets.  
• An updated User's Guide reflects operational changes. An index has been added.  
• In-program help screens are updated with variable definitions and explanations.  
• Tutorials 1-4 are updated and reorganized.  
• New tutorials focus on new modeling capabilities. 
 

BehavePlus version 2 updates 
• Safety zone size model is added as a new SAFETY module.  
• Containment model is added as a new CONTAIN module. This is a new model that allows multiple resources to 

make direct or parallel attack.  
• Probability of ignition by lightning model is added to the IGNITE module.  
• Three methods of weighting two fuel models for rate of spread calculations is added to the SURFACE module.  
• Dynamic palmetto-gallberry fuel model (Hough and Albini 1978) is added to the SURFACE module.  
• Size diagram output is added to SIZE.  
• Contain diagram output is in CONTAIN.  
• Direction diagram is added to SURFACE.  
• Fire characteristics chart diagram output is added to SURFACE.  
• Fine dead fuel moisture is added as a new tool.  
• A Run Option section is added to the worksheets for clarification.  
• The contents of the Notes section on example worksheets is blank. The description of the worksheet that was 

there for version 1 is not necessary, especially with the addition of the Run Options section.  
• The standard worksheet folder that was supplied with version 1 of the program is called the 

ExampleWorksheets folder in version 2 to better reflect what it is. The worksheets in that folder are just some 
that the developers put together. The term ‘standard’ gave them significance that they didn’t deserve.  

• The Blank.bpw Worksheet that was in version 1 is called the 0Startup.bpw Worksheet in version 2 to better 
reflect what it is—the worksheet to use as a startup in selecting calculation modules. (The ‘0’ as a first character 
of the file name puts it as the first item on the list for easy selection.)  

• The program now automatically loads the 0Startup.bpw worksheet upon initiation. This saves some steps if the 
worksheet is set up by module selection. If a previously saved worksheet is desired, it is selected and loaded as 
before with File > New.  

• The Fuel model guide button gives you access to the photographs and descriptions in Anderson (1982) “Aids to 
selecting fuel models” and to the selection key in Rothermel (1983) “How to predict the spread and intensity of 
forest and range fires”.  

• The Program Help and the User’s Guide for version 1 have been replaced by a single, new document—a user’s 
guide in PDF format that can be both printed and accessed online for specific help.  

• A Language option has been added. Portuguese is provided as an example.  
• Additional Workspace options aid in file management.  
• Graph y-axes are now user-scalable 

 

BehavePlus version 1 compared to the old BEHAVE 
The old BEHAVE fire behavior prediction and fuel modeling system is a set of five DOS programs, three of which 
were first available in 1984. The whole look and feel of the BehavePlus fire modeling system is different, using 
updated user interface technology.  
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Following are some specific differences that will be of interest to users of the old BEHAVE system: 
• BehavePlus is one program. The old BEHAVE was 5 programs (FIRE1, FIRE2, RXWINDOW, NEWMDL, 

TSTMDL). The separation was due to computer limitations at the time and an extended development period.  
• BehavePlus gives the user control of input options that were fixed on the old BEHAVE. For example, in the old 

BEHAVE:  
o The DIRECT module required direct input of fuel moisture by size class, midflame wind speed, and 

direction of wind and spread with respect to upslope.  
o The SITE module calculated fine fuel moisture and requested input of 20-ft wind speed, exposure to the 

wind, and direction of wind and spread.  
o The DISPATCH module requested dead and live fuel moisture, 20-ft wind speed and wind adjustment 

factor. Calculations were for upslope spread with the wind.  
o In the TSTMDL program, fuel moisture was specified by category.  

• In contrast, the BehavePlus SURFACE module allows users to specify the method of entry for fuel moisture, 
wind speed, and directions.  

• In BEHAVE only continuous variables could be assigned more than one value for a maximum of 7 values. For 
example, wind speed could be assigned a range of values, but fuel model could not. BehavePlus allows multiple 
input values for every variable and there is essentially no limit to the number of values. Table output is carried 
over to multiple pages if necessary.  

• BehavePlus produces graphs and diagrams as well as tables. The primary output of the old BEHAVE was 
tables. Crude graphs were produced using characters.  

• The fuel modeling portion of the old BEHAVE consisted of the NEWMDL and TSTMDL programs. The 
features in NEWMDL are not in BehavePlus. The TSTMDL fuel model testing methods are in BehavePlus.  

• BehavePlus does not include the fine dead fuel moisture model in MOISTURE and SITE modules in the FIRE2 
program of BEHAVE. A better moisture model based on hourly weather data has been developed and is used in 
FARSITE and is being incorporated into the National Fire Danger Rating System (NFDRS) and the FireFamily 
Plus program. Eventually it will be available for fire behavior calculations in BehavePlus. BehavePlus offers the 
fuel moisture tables as a tool.  

• The CONTAIN module of BehavePlus is different from that used in BEHAVE. The old model had a 
mathematical problem that occasionally surfaced. BehavePlus uses a model by Fried and Fried (1996) that 
offers the application of multiple resources with various productivity rates and arrival times, and direct or 
parallel attack at either the fire head or rear. BehavePlus does not offer the option of reverse calculation that was 
in the old BEHAVE (i.e. given a final fire size, what is the required line production rate).  

• The RxWindow program is not and will not be part of BehavePlus. Reverse calculation becomes more difficult 
(essentially impossible) as models are added. The plan is to provide a new method of table shading to aid in 
prescribed fire planning.  

• The equations in the MORTALITY module in BehavePlus have been updated to match those of FOFEM. Many 
new tree species have been added.  

• BehavePlus lists input values by category (Fuel/Vegetation, Weather, …) rather than by module (DIRECT, 
SIZE, …) as was done in the old BEHAVE.  

• In BehavePlus users select the output variables to be displayed. In BEHAVE the output list was fixed.  
• Map distance calculation was a stand-alone feature in BEHAVE. It is integrated into BehavePlus.  
• BEHAVE asked users whether they were using a computer with a screen. The program could be run in either 

WORDY or TERSE mode. BehavePlus assumes that it is being run on a 21st century personal computer.  
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