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Units & Decimals Lesson 

Introduction 
BehavePlus offers a simple switch between English and metric units. The user also has 
the option of changing the units for individual input and output variables and of setting 
the number of decimal places displayed for output variables. The number of decimal 
places for input variables is determined by the entered values. Changed units and 
decimals are included in saved worksheets and runs. Custom units sets can also be saved 
for later use. 
 
Because of issues that can arise due to round-off, some basic changes have been made to 
decimal handling in version 5.0. 
 

Objectives 
1. Switch between English and metric default units. 
2. Set the decimal display of input variables according to input values. 
3. Change units and output variable decimals and save as a custom units set. 
4. Apply changes to the worksheet without saving a custom units set. 
5. Save a worksheet and run with custom units and decimals set. 
6. Use the Units converter Tool to convert individual values. 
7. Understand that the number of decimals displayed changes when the units set 

changes to avoid round-off problems. 
8. Use the FuelModeling.bpw or FuelModelingMetric.bpw worksheet for full 

display of fuel parameter variables. 
 

Where This Lesson Fits In 
This is an optional lesson in the operation unit. The only prerequisites are the four lessons 
in the Introduction Unit. 
 
Lesson Changes: V4.0 to V5.0 
Changes to the BehavePlus program required a major update to this lesson, essentially a 
total rewrite. There are a few screen captures that still have the 4.0.0 heading. 

BehavePlus fire modeling system, version 5.0 

Units & Decimals Lesson Operation Unit 
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Decimal Display of Input Variables 
Prior to version 5.0, decimal display of input variables was determined by the setting in 
the English, Metric, or Custom units set.  Because the program uses the value that shows 
on the worksheet, there were occasional problems with round-off and misinterpretation. 
 
Decimal display of input variables is now determined by the values entered by the user. 
The greatest number of decimal places entered for a variable are displayed in the output 
tables for all values for that variable. 
 
 Open the Example Worksheet, SurfaceSimple.bpw 

 

 
 
 Enter values as follows. 

 

 



BehavePlus Version 5.0  Units & Decimals Lesson 

Oct. 29, 2009  Page 3 of 30 

 
 Calculate the run and look at the first table. 

 

 
 
Because one of the values entered for dead fuel moisture was 9.25%, with two decimal 
places, all of the dead fuel moisture values on the output table.  (This is an example to 
show the way that the program handles decimal display. A moisture value to that 
precision is not meaningful.)  
 
Similarly, a value of 6.5 mi/h was entered for midflame wind speed, so all of the wind 
values are shown on the table to one decimal place. 
 
 Entering another dead moisture with ridiculous value of 11.111111 to see the 

effect on the table.  
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Decimal Display of Output Variables 
The decimal display of output variables can be changed. 
 
 Click on Configure > Custom units preferences. 

 
The Fuel & Vegetation Units tab is opened.  Note that some of the variables don’t have 
a field for Decimal.  Those are variables that are only available as input variables. 
 
 Click on the Fire & Effects Units tab. 
 Change the number of decimals for Surface rate of spread from 1 to 2. 

 

 
 
 Click Ok. 
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You have the option of saving the changes in a custom units set file or of only applying it 
to the current worksheet.  If you save the worksheet or a run that used the worksheet, the 
changed decimal display (as well as changed units) will be saved with it. 
 

 
 
 Click on No to apply the change to the current worksheet. 
 Calculate the run to see the change in the table. 
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Decimal Display of a Variable that can be Either Input or Output 
Some variables can be either input or output, depending on selected options. One of these 
is Crown Ratio.  
 
 Click on Help > Variable Help 
 Click on Crown Ratio in the Alphabetical List of Variables 

 

 
 
The description explains how crown ratio can be either input or output.  We will do 
comparison runs and demonstrate how the decimal display can be changed. 
 

 
 
 Close the Variables PDF document. 
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 Open the SurfaceSimple.bpw worksheet. 
 Open the SURFACE Options… > Wind Speed tab and select Wind speed is 

entered as 20-ft wind and Calculated wind adjustment factor. 
 Select the Basic Outputs tab.  Select only Surface rate of spread. 
 Select the Wind Outputs tab.  Select only Midflame wind speed, Wind 

adjustment factor, and WAF calculation. 
 Click Ok twice. 

 
 The worksheet should look like this. Enter values as shown. 
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 Calculate the run to see this table. 
 

 
 
Crown Ratio is shown to one decimal place because that was the maximum for the three 
input values (.1, .3, .5). 
 
 Now select the CROWN module. 
 Open the CROWN Options… > Spread Outputs tab and select only Transition 

to Crown Fire? as an output variable. 
 Open the SURFACE Options… > Wind Outputs tab and select Crown Ratio as 

an additional output variable. 
 Note that Crown Ratio is not an input variable.  It is determined from Canopy 

Height and Canopy Base Height. 
 Enter values on the worksheet as shown. 
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 Calculate the run to see this table. 

 

 
 
Crown ratio is shown to two decimal places because that is the setting in the Units set. 
 
 Click on Configure > Custom units preferences 
 Click on the Fuel & Vegetation Units tab. 
 Note that the number of decimals is set to 2.  Click Cancel. 
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Default English and Metric Units 
You can quickly change between the default English and metric units sets (or a custom 
units set, which you will develop later in the lesson).   
 
If you enter values on the worksheet and then change units set, six decimal places will be 
displayed for the converted values, although trailing zeros are suppressed. This is a 
change in version 5.0.  It resolves the problem with round-off that occurred in previous 
versions. 
 
 Open the Example Worksheet, SurfaceSimple.bpw 
 Enter values as shown. 

 

 
 
 Calculate the run. 
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 Change the units set with Configure > Units set selection > Metric 

 

 
 
The worksheet is now metric, and all of the values have been converted. 
 

 
 
 Calculate the run. 
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Six decimal places are now given for the midflame wind speed because of the conversion 
from mi/h to ft/min. All of those decimal places are on the output table. Automatic 
rounding can cause problems, so we made the decision to add the decimal places.  You 
can change the values.  And the most common use of the program will be to set the units 
and use it without change. 
 

Saving a Worksheet with Metric Units 
If you would prefer to always use metric rather than English units, you can save 
worksheets with metric units. (You can change your startup worksheet to one of your 
metric worksheets, with File > Set startup worksheet.) 
 
Recall that when you save a worksheet, you save the configuration, not the values 
entered into the input fields. To save the values you have entered, you must save it as a 
run. 
 
It is important to remember that all of the settings, including units and decimals, are 
saved with the worksheet or run, not just those that currently show. 
 
Let’s save the SurfaceSimple.bpw worksheet with metric units. 
 
 Click on File > Save as a worksheet. 

 

 
 
The default Worksheet Folder is MyWorksheets.  If you try to save a worksheet in the 
ExampleWorksheets folder, you will get an error message. These files are distributed 
with the program and are write-protected. 
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We will create a new folder for metric worksheets that are equivalent in all other ways to 
the English worksheets found in the ExampleWorksheets folder. 
 
 In the Worksheet Folder box, change the text to “MetricExampleWorksheets”.  
 Call the Worksheet File “SurfaceSimple”.  
 Change the Worksheet Description. Add “(metric)”  

 

 
 
 Click Ok. 

 
It is perfectly acceptable to use the same file name (SurfaceSimple) in a different folder. 
The program will ask if you want to Create a New Directory? 
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 Click Yes. 

 
The program will prompt you to Enter Worksheet Folder description. 
 
 Type the following in the box, “Metric version of Example Worksheets”.  
 Click Ok. 

 

 
 
BehavePlus will create the new folder and save the worksheet. An FYI box will appear to 
let you know what was done. 
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Open Both English and Metric Worksheets. 
 Close all open worksheets or exit and restart the program.  
 Open the SurfaceSimple.bpw worksheet from the Example Worksheets folder. 
 Open the SurfaceSimple.bpw worksheet from the MetricExampleWorksheets 

folder. 
 

 
 
You can view more than one worksheet at a time by going to the Windows button on the 
main toolbar. Names are assigned only to saved runs, so these worksheets will 
temporarily be named unnamedXX.bpr, where xx is the number. 
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 To view both worksheets simultaneously, click on Windows > Tile. 
 

 
 
The two worksheets will appear side-by-side in the window.  
 

 
 
 Close both open worksheets. 

 

Units Converter Tool 
You may not want to use the units that are in the default English and metric sets. For 
example, you might not want to use chains as the units for rate and distance variables. 
You may, in fact, be one of those users who ask “What is a chain anyway?” 
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Let’s use Tools > Units Converter to see the relationship between chains and feet. 
 

 
 
This opens the Units Conversion Tool, which converts a quantity between arbitrary 
units of measure. The help window provides guidance. 
 
 

 
 
One chain is 66 feet. 
 
 Click Dismiss to exit the Units Conversion Tool. 
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Changing Units 
Continuing with the premise that you prefer not to use “chains” as units in your fire 
modeling efforts, you can build and save a custom units set without “chains”. 
 
 Exit the program and restart. 

 
 Open the SurfaceSimple.bpw worksheet from the Example Worksheets folder. 

 
 Change the output variable selection to only Surface Rate of Spread and Surface 

Spread Distance. Be sure to remove Max Eff Wind Exceeded? from the Wind 
Outputs tab. 

 Click Ok twice to close both the Surface Module Options and the Module 
Selection windows. 

 Look in the Output Variables Section of the worksheet. 
 
The Surface Rate of Spread has units of ch/h (chains per hour and Surface Spread 
Distance has units of chains. 
 
 

 

 

 
Let’s change the units of these two variables so that they are no longer measured in 
chains. 
 
 Click on Configure > Custom units preferences. 
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There are over 180 variables in BehavePlus (described in Variables Help). They are 
divided into groups for the purpose of assigning units and decimal display. The units for 
each group of variables can be defined independently. However, the units for all 
variables in that group will be changed. More information on the variable groups can be 
found in the Help pane. 
 
 Click on the Fire & Effects Units tab. 

 

 
 
Notice that Surface ROS and Crown ROS are listed separately. You may want Surface 
fire Rate of Spread in units of ft/min and Crown fire Rate of Spread in mi/h (miles per 
hour). 
 
To change the units for a group, make a selection from the drop-down list associated with 
each group. 
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 Change the variables that are in chains to other units as shown below. 
 

 
 
Even though Crown ROS and Fire Perimeter are not currently associated with the 
worksheet that is currently displayed, the new units will be saved with the worksheet (or 
run) file. In fact, the entire Custom Units Set is associated with the worksheet. When you 
save the worksheet, you will save all of the changed units and decimals. At a later time 
you might add SIZE to the worksheet and would want Fire Perimeter to be in feet rather 
than chains to obtain consistent results. Therefore, we have changed it now. 
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 Check the other tabs to see if other variable categories use units of chains. 

 
The only other categories with chains are found on the Contain & Safety Units tab. 
 
 Change containment distances to ft. Note that the help window lists the variables 

that fall under that category. 
 

 
 
We will leave Resource Line Production Rate in units of ch/h because those are the units 
found in the Fireline Handbook (March 2004). The tables from the Fireline Handbook 
are available in the Help window by looking in the Variable Index under Resource Line 
Production Rate or in the Table Index under each specific table name. These links are 
found at the bottom of every help page. 
 
 Click Ok to close the Units Editor. 
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You are given the option to save this Custom Units Set. If you are going to use this set of 
units often, you may wish to do that. However, even if you choose not to save the file, the 
units will be saved with the worksheet. 
 

 
 
 Click No for now, and don’t save the Custom Units Set. 
 Save the worksheet in the MyWorksheets folder with the name and description 

as shown below. The unit changes will be saved with it (for all variables, not just 
those that show on the worksheet.). 

 

 
 
 Click Ok. 

 
The units of the Output Variables have changed on the worksheet. 
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Saving a Run with Changed Output Decimal Display 
You can change the decimal display the same way you changed the units. 
 
 In the worksheet you just modified and saved as 

SurfaceSimple_NoChains.bpw, enter values into the worksheet as shown. 
 
 

 

 

 
 Click the Calculate button to obtain the following results. 

 
 

 

 

 
Displaying the results to one decimal place is not necessary for the units of ft/min and ft. 
We want to change them to zero. 
 
 Click on Configure > Custom units preferences and activate the Fire & 

Effects Units tab. 
 Change the decimals for Surface ROS, Spread Distance, and Fire Perimeter to 

zero by using the dial buttons. 
 Click Ok. 
 Click No to not save the Custom Units Set. 
 Calculate the run again. 
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The results make more sense for the chosen units. 
 
 

 

 

 
It may be preferable to show the Spread Distance in miles with one decimal place. You 
will try that in the exercises. 
 
 Save the Run in the MyRuns folder as “UnitsDecimals”. Leave the default 

description, which is the description from the worksheet. 
 

 
 
 Click Ok. 

 

Saving a Custom Units Set 
When you set up units and decimals the way you want them, you can save a Custom 
Units Set for later use. Let’s save the Custom Units Set. 
 
 Open the Units Editor again with Configure > Custom units preferences. 
 Click Ok to close it. This action will prompt you to save the Units Set. 
 Click Yes. 
 Save the file in the MyUnitsSets folder as “NoChains”. In the description box, 

type “except ch/h for line production rate”. 
 

 
 
 Click Ok to save the Units Set. 
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Changing the Units Set Selection 
 
 To convert your worksheet back to default English measurements, click on 

Configure > Units set selection > English 
 
The units for Surface Rate of Spread and Surface Spread Distance are again ch/h and ch, 
respectively. 
 
 

 

 

 
 To change to your Custom Units Set, click on Configure > Units set selection > 

Custom 
 Expand MyUnitsSet and select the Custom Units Set you just built and saved 

(NoChains.bpu). 
 

 
 
 Double click, or click Ok. 

 
The units of output variables have changed back to our custom units. 
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 Select the SIZE and CONTAIN modules. 
 Note the changes to units of the output variables. 
 Go back to the default English units (Configure > Units set selection > 

English) and view the changes to the worksheet. 
 

Decimal Display for Fuel Model Parameters 
Assigning values for fuel parameters is a special case because of the option “Initialize 
from a Fuel Model”.  If you are developing fuel models, it is best to use the worksheets 
from the Example Worksheets folder: FuelModeling.bpw or 
FuelModelingMetric.bpw. Six decimal places are displayed to avoid round-off 
problems. 
 
 Open the worksheet FuelModeling.bpw 
 Click Initialize from a Fuel Model 
 Select fuel model 5 (Brush). 
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Values are entered into the worksheet.  Fuel load values are given to six decimal places.  
The false precision is a result of the fact that the ‘native units’ for fuel load are lb/ft2 and 
a conversion is done to ton/ac for the worksheet. 
 

 
 
 Change the units of fuel load to lb/ft2.   
 Change the decimals for fuel load to 1 to confirm that the decimal change does 

not apply to input variables. (Look at the SURFACE Options… > Fuel Outputs 
tab to see fuel load variables as output.) 
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The FuelModeling worksheets are special cases developed to address the decimal 
display issue. They should be used as the starting point when developing custom fuel 
models. They are different from those available prior to version 5.0.  Decimal display of 
load values is different if you load the FuelModeling worksheets than if you start with 
another worksheet and select Fuel is entered as fuel parameters.  
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Summary 
In this lesson, you have seen that  
• The decimal display of input variables is determined by the values that are entered.  
• You can switch between the default English and metric units using Configure > 

Units set selection > English or Metric.  
• You can change units and the decimal display of output variables using Configure > 

Custom units preferences.  
• You can apply changes to the current worksheet without saving a custom units file. 
• Units and output variable decimal display for all variables is part of the worksheet, 

whether those variables are currently shown or not. 
• When you save a worksheet or a run, the complete units and decimal set is saved with 

it.  
• You can save a Custom Units Set and apply it at any time using Configure > Units 

set selection > Custom. 
• Initialize from a Fuel Model for fuel model parameters is a special case for decimal 

display.  For full decimal display, it is best to use the Example Worksheet 
FuelModeling.bpw or FuelModelingMetric.bpw. 



BehavePlus Version 5.0  Units & Decimals Lesson 

Oct. 29, 2009  Page 30 of 30 

Exercises 
1. Open the run that you saved in the lesson, called “UnitsDecimals”.  
 Change the units for Spread Distance to miles (mi) with one decimal place. 

 
The results should look like this. 
 
 

 

 

 
 Close the worksheet before starting Exercise 2. 

 
2. Open the Example Worksheet SurfaceSimple.bpw. Develop a worksheet that looks 

like this (Crown Ratio ranges from 0.50 to 1.00). 
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