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File Management Lesson 

Introduction 
Understanding BehavePlus file management helps with more effective use of the 
program. BehavePlus Workspaces store all files related to user-defined options in a 
single, portable format. This feature allows users to build a custom configuration for any 
program application and store all the relevant information to recreate analyses performed 
for a specific purpose such as a prescribed fire burn plan or a wildland fire behavior 
assessment. Workspaces are self-contained and can be shared among fire behavior 
analysts on a given incident and given to incoming teams during transition, making them 
ideal for ICS-based fire behavior prediction documentation. Daily fire behavior 
predictions can be run and stored for reference or modification at a later date. 
 

Objectives 
1. Describe the BehavePlus file structure. 
2. Define the components of a workspace. 
3. Create a new workspace. 
4. Open an existing workspace. 
5. Create and save files in a new workspace: worksheet, run, fuel model, and 

moisture scenario. 
6. Use Microsoft Explorer to move files within the BehavePlus fire structure. 

 

Where This Lesson Fits In 
File management and documentation is a key component of any fire behavior prediction 
operation. You can use BehavePlus with only the default Workspace and create 
subfolders to organize your files. Use of Workspaces, however, will help you keep track 
of your work and aid in documentation and sharing results. 
 
This lesson includes the use of operational features covered in other lessons. The required 
Introduction lessons provide information on using Worksheets and calculating Runs. 
Optional modeling lessons cover the use of custom Fuel Models and Moisture Scenarios. 
 
 
Lesson Changes: V4.0 to V5.0 
Changes to the BehavePlus program required some minor changes to this lesson. We 
updated the headers and footers, but did not redo many of the screen captures labeled 
BehavePlus 4.0.0.  

BehavePlus fire modeling system, version 5.0 

File Management Lesson Operation Unit 
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Installation 
The default location for program installation on U.S. Forest Service computers is 
C:/fsapps/fsprod/fam. Otherwise the default location is C:/Behave. 
 
You can install BehavePlus as you choose, however, it is suggested that you not install 
BehavePlus in the Program Files directory because of problems that may arise from 
permissions. When BehavePlus Version 4 is installed, the program creates a folder named 
BehavePlus4. All of the files needed to run the program are in that folder. Files that you 
create using the program are also saved there. 
 

File Structure  
BehavePlus has a prescribed file structure, and all files must be located in specific 
subdirectories. The parent directory of this file structure and all its subdirectories and 
files are known collectively as a Workspace. 
 
We start by looking at the BehavePlus file structure. 
 
 Use Microsoft Explorer to open the BehavePlus4 folder by navigating to 

C:/fsapps/fsprod/fam or C:/Behave. 
 
There are three subfolders in BehavePlus4. 
 

 
 

Folders in BehavePlus 
The folders DocFolder and ImageFolder contain material that the program requires for 
operation. The user need not be concerned with them. The folder called 
DefaultDataFolder easily could have been named “DefaultWorkspace” because that is 
exactly what it is. 
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 Expand the DefaultDataFolder to see the following. 
 

 
 
File storage has been designed to be largely self-explanatory. Details about the various 
folders are included in the table below. 
 
Folder Name Command Function 

CaptureFolder File > Save as an image 

Images of table, graph, and diagram screens 
can all be saved as image files, which are 
stored here. They can be in one of three 
formats: .bmp, .jpg, .png. 

ComposerFolder  This folder contains temporary files. 

ExportFolder File > Export results 

Exporting results creates an HTML file in the 
ExportFolder that be viewed with a web 
browser, used in a web page, or modified in a 
spreadsheet application such as Microsoft 
Excel®. 

FuelModelFolder File > Save as a fuel model > 
BehavePlus format 

Custom Fuel Models are saved to this folder 
or subfolders that you can create. (When Fuel 
Models are saved in FARSITE format they 
can not be used by BehavePlus and, 
therefore, should not be saved in the 
BehavePlus4 folder.) 

MoistureScenarioFolder File > Save as a moisture 
scenario 

Custom Moisture Scenarios are saved in this 
folder, or in subfolders that you create. 
Values must be assigned to each size class, 
even those that are shaded. 

RunFolder File > Save as a run 

Runs can be saved in this folder or in 
subfolders you create. A Run contains both 
the Worksheet and the defined input values. 
All variables must have valid values. 

UnitsSetFolder Configure > Custom units 
preferences 

After creating a custom Units Set, you can 
save it to the UnitsSetFolder for future use. 

WorksheetFolder File > Save as a worksheet 

Worksheet files can be saved in this folder or 
in subfolders you create. The Worksheet 
preferences are saved, but the values entered 
onto the Worksheet are not saved. 
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BehavePlus Extensions  
A list of three letter file extensions used by BehavePlus is shown in the following table. 
  

Extension Description 
.bpf  BehavePlus custom Fuel Model  
.bpm  BehavePlus Moisture Scenario  
.bpw  BehavePlus Worksheet  
.bpr  BehavePlus Run  
.bpu  Behave Plus Units Set  
.png  Portable network graphic image format  
.bmp  Bitmap graphic image format  
.jpg  JPEG graphic image format  

 
These extensions are automatically appended to the files you create in BehavePlus, but 
understanding them can help you with your file naming and management.  
 

The Anatomy of a Workspace 
BehavePlus Workspaces store all user-defined files in a single, portable set of files that 
can be moved from location to location. Workspaces can be used to define a set of 
commonly used input Worksheets or document a model Run for a specific application 
such as a wildland fire behavior assessment or training session, in which each student can 
start from the same point, which may or may not be the default setup. In addition, 
Workspaces store Custom Units Sets, screen captures of graphs and tables, custom Fuel 
Model parameters and Moisture Scenarios.  
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A Workspace stores all the user-defined files in a single directory that can be shared 
between users. The dashed arrow between Worksheets and Runs indicates that Runs store 
both the Worksheet information and the data used for a particular set of conditions. 
 

Cloning an Existing Workspace 
BehavePlus allows you to create a new Workspace from an existing one. This process is 
referred to as “cloning”. Cloning will create an identical version of the existing 
Workspace under a new name. This Workspace will include a complete copy of the 
subdirectory tree containing all required BehavePlus files plus any additional Worksheet, 
Run, Fuel Model, Moisture Scenario, Units Set, or screen capture files you saved in the 
originating Workspace. 
 
 Open BehavePlus. 

 
Even if you didn’t realize it, you have now opened a Workspace. The location of the 
Workspace in which you are working is found at the bottom of the BehavePlus screen. 
For the current screen, it should look similar to the following. 
 

 
 
Now, clone this Workspace. 
 
 Click File > Workspaces > Clone current workspace 
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 Select a BehavePlus Workspace directory. We will save this Workspace to 
C:/Behave, although you may want to set up a different area on your computer to 
save your Workspaces. 

 
*** Note: To avoid problems in the future, always save your new Workspaces in a 
separate folder. *** 
 
 Click on New Folder. 

 

 
 
 When the New Folder appears in the Browse for Folder box, the cursor will 

blink at the end of the words New Folder. Type in the folder name 
‘FileManagementLesson_WorkspaceClone’. 

 Click outside the text box to stop editing the name. 
 Highlight the FileManagementLesson_WorkspaceClone folder, and click Ok. 
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BehavePlus will create the required Workspace directories and files. A Window will 
open called Please Answer Yes or No to make the newly created Workspace the current 
Workspace.  
 
 Click Yes. 

 

 
 
You are now working in the new Workspace. Notice that the Workspace location at the 
bottom of the screen has changed. 
 

 
 

Opening an Existing Workspace 
Now that we have cloned a Workspace, we want to return to the original one. There are 
two ways to do this. If you close BehavePlus and reopen it, you will return to the default 
Workspace. Conversely, you can use a more elegant approach. 
 
To open a Workspace: 
 
 Click on File > Workspaces > Open workspace. 
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 Navigate to and highlight the folder that contains the default Workspace. For U.S. 
Forest Service users, this will probably be C:/fsapps/fsprod/fam/BehavePlus4. 
For others, it will be C:/Behave/BehavePlus4. Highlight the folder called 
DefaultDataFolder. 

 

 
 
 Click Ok. 

 
BehavePlus will inform you that your Workspace has been changed. 
 

 
 
 Click Ok. 
 Notice that the Workspace location at the bottom of the screen has changed again 

to reflect the switch. 
 

 
 
 Close BehavePlus. 
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Note: When you open BehavePlus, the default Workspace will always be the 
DefaultDataFolder Workspace. 
 

Creating a New Workspace 
While you may want to clone a given Workspace that has specific characteristics (e.g., 
custom Fuel Models, custom Units Sets, etc.), you may also want to create a new one. A 
cloned Workspace contains all of the files of the original Workspace, including any 
additional files you have saved along the way. A new Workspace generates a “pristine” 
copy of the default files found in the DefaultDataFolder Workspace. Any custom files 
you have created in the DefaultDataFolder will not be transferred to the new Workspace. 
You may find it useful to create a new Workspace for every BehavePlus project you are 
working on as a way of tracking your projects. 
 
 Start the BehavePlus program. 
 Click File > Open worksheet or click on the Open worksheet button in the upper 

left-hand corner of the program window (  ). 
 Open the BasicStart.bpw Worksheet. 
 
The bottom of the window shows the Workspace. 
 

 
 
To create a new Workspace: 
 
 Click on File > Workspaces > New workspace.  

 

 
 
A file navigation dialog box (Browse For Folder) will appear.  
 
 Navigate to the location that you would like to store the Workspace (C:/Behave). 
 Push the New Folder button. 
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We recommend using a file name that indicates that a particular directory is a BehavePlus 
Workspace. For example, use the name BPWS_<FireName> or some equivalent naming 
scheme, where BPWS denotes that it is a BehavePlus WorkSpace. 
 
Be careful!! Be sure to give the new Workspace a different folder name. Do not create a 
new Workspace in an existing folder that is already in use (has other files in it). 
 
 Type “BPWS_TinpanWFU” as the name of the new folder.  

 

 
 
 Click Ok to create the new Workspace. 

 
As before, BehavePlus prompts you to make the newly created Workspace the current 
Workspace. 
 
 Click Yes. 

 

 
 
 Click Yes to use the new Workspace  
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Look at the bottom of the window to see the current Workspace. 
 

 
 
There is a second way to verify the name of the current Workspace. 
 
 Click on Help > Installation Info. 
 Scroll down to Directories. 

 

 
 
You are now in the New Workspace! 
 

Creating Files in the New Workspace 
We have just created a new Workspace called BPWS_TinpanWFU. We will now look at 
different folders in and create new files for this Workspace. 
 
As a reminder of the folders and their purpose, we are recopying portions of the table 
from the beginning of the lesson with the Folder Names sorted according to the order in 
which we will address them. We will develop files in the new Workspace for a 
Worksheet, a Run, a Fuel Model, and a Moisture Scenario. 
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Folder Name Command Function 

WorksheetFolder File > Save as a worksheet 

Worksheet files can be saved in this folder 
or in subfolders you create. The Worksheet 
preferences are saved, but values entered 
onto the Worksheet are not saved. 

RunFolder File > Save as a run 

Runs can be saved in this folder or in 
subfolders you create. A Run contains both 
the Worksheet and the defined input values. 
All variables must have valid values. 

FuelModelFolder File > Save as a fuel model > 
BehavePlus format 

Custom Fuel Models are saved to this folder 
or subfolders that you can create. (When 
Fuel Models are saved in FARSITE format 
they can not be used by BehavePlus and 
should therefore not be saved in the 
BehavePlus4 folder.) 

MoistureScenarioFolder File > Save as a moisture 
scenario 

Custom Moisture Scenarios are saved in this 
folder, or in subfolders that you create. To 
save a Moisture Scenario, you must make 
sure the SURFACE module is selected and 
the individual size class check box is 
selected. Values must be assigned to each 
size class, even those that are shaded. 

 
*** Note: If you need to close BehavePlus at any point during the 
remainder of this lesson, to continue you must open the Workspace 
called BPWS_TinpanWFU, which contains the correct files. *** 
 

Worksheet Folder  
A Worksheet is based on selected input options and output variables. It does not store the 
input values. Worksheets are stored in the folder called WorksheetFolder in the current 
Workspace. 
 
We will open one of the example Worksheets that come with program, alter it, and save it 
in the new Workspace. The Example Worksheets are available in all Workspaces. 
 
 Click File > Open worksheet or click on the Open worksheet button in the 

upper left-hand corner of the program window (  ). 
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 Click on the  next to ExampleWorksheets. 
 Click on the Select the SurfaceSimple.bpw Worksheet. 

 

 
 
 Click Ok. 

 Click on Configure > Module selection or the Module Selection button (  ). 
 Check the box by the SIZE module. 
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 Click Ok. 
 
 Click File> Save as a worksheet. 

 

 
 
 We will store the Worksheet in the folder marked MyWorksheets. 
 Type ‘SimpleSurfaceSize’ in the Worksheet File box.  
 Enter the description as shown below. 
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 Click Ok to save the Worksheet. 

 
Question: In which Workspace is the Worksheet found? 
Hint: Look in the FYI confirmation box. 
 

 
 
 
 Click Ok to confirm creation of the new Worksheet. 

 
Since you will need a second Worksheet later in this lesson, let’s save a version of this 
Worksheet with metric units. 
 
 Click to Configure > Units set selection > Metric. 

 

 
 
Look at the units in the Worksheet; they are now metric. 
 
 Save this Worksheet as ‘SimpleSurfaceSize_metric’. 
 Type ‘Example SURFACE and SIZE run - metric’ in the Worksheet 

Description. 
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 Close the Worksheet. 
 

Run Folder 
In contrast to the Worksheet, the Run stores both the configuration of the Worksheet and 
the input data used for a particular calculation. Runs are useful when you need to be able 
to quickly reproduce the results of a particular analysis. If you store a completed 
Worksheet as a Run, you simply need to open the Run and click the Calculate button to 
reproduce the results. 
 
 Open the Worksheet entitled SimpleSurfaceSize.bpw. 

 
 Fill in the Worksheet as follows: 

 
 

 

 

 
 Calculate the Run to make sure you have what you want. Recall that the answers 

are not stored when you save a Run. 
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 Click File > Save as a run. 
 

 
 
The default folder for saving Runs is MyRuns, which is where we will store this Run. 
 
 Type “SimpleSurfaceSize” in the Run File box.  
 The Run Description comes from the Description box on the Worksheet. 
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 Click Ok to save the Run. 
 Click Ok to verify the location of the saved Run. 

 
This will store the new Run under your current Workspace (BPWS_TinpanWFU). 
 

Fuel Model Folder  
BehavePlus allows users to store custom Fuel Models in the current Workspace in a 
folder called FuelModelFolder. 
 
We will create a simple custom Fuel Model. 
 
 Open the FuelModeling.bpw Worksheet from the ExampleWorksheet folder. 

 

 
 
This Worksheet is configured to allow the entry to Fuel Model parameters which can be 
saved as a custom Fuel Model.  
 
We will start with one of the standard Fuel Models and change parameters to create a 
custom Fuel Model. 
 
 Click on Initialize from a Fuel Model.  
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 Select Fuel Model “tu2” as shown below: 
 

 
 
 Click Ok. 

 
The fuel parameters are assigned as shown below for Fuel Model tu2: 
 

 

 

 

 
We will enter a 1-h Load and Fuel Bed Depth that are ¾ of the original values. 
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 Change the Fuel Bed Depth from 1.00 to 0.75. 
 Change the 1-h Fuel Load from 0.95 to 0.71.  

 
 

 

 

 
Recall that there is much more to developing a custom Fuel Model than this. This is a 
first step, which would be followed by testing and evaluation. 
 
 Click on File > Save as a fuel model > BehavePlus format. 

 

 
 
By default, the Fuel Model will be saved in MyFuelModels. You can save your Fuel 
Models in whichever folder you prefer, but in this example, we will use the default 
folder. 
 
 Type “three-quarters_tu2” in the Fuel Model File field. 
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 Type “3/4 depth and 1-h load of fuel model tu2” in the Fuel Model Description 
field.  

 

 
 
 Click Ok. 

 
A window will open verifying that the new Fuel Model has been saved. 
 
 Click Ok. 
 Close the Worksheet. 

 
 Reopen the Run entitled SimpleSurfaceSize.bpr. 
 Click on the Guide button (  ) next to Fuel Model. 
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 Scroll to the bottom of the list and click on three-quarters_tu2. 
 

 
 
 Click Ok. 

 
 Type in “200” for Live Fuel Moisture. 
 Click on File > Save as a run. 
 Change the Run File to “SimpleSurfaceSize_Mod”. 
 Click Ok twice. 

 
We will now examine the effects of our changes to the Fuel Model on the calculated fire 
behavior by comparing the original and the adjusted Fuel Model tu2. 
 
 Click on the guide button by Fuel Model. 
 Select (Highlight) both tu2 and three-quarters_tu2 (You can select multiple Fuel 

Models by clicking one time on each model separately. The currently selected 
models will be highlighted in blue.). 

 Click Ok. 
 



BehavePlus Version 5.0  File Management Lesson 

Oct. 23, 2009  Page 23 of 38 

 Calculate the Run. Notice that the table of outputs spans two pages. 
 

 

 

 

   
 

 

 

 
Changing the two Fuel Model parameters (1-h Load and Fuel Bed Depth) made a large 
difference in the calculated Surface Rate of Spread and Fire Perimeter. 
 
Do not close the Worksheet. We will continue using it in the next section of the lesson. 
 
Note: If you have to close BehavePlus prior to continuing this lesson, you will need 
to attach the Fuel Model folder called MyFuelModels before continuing. 
 
To do this: 
 
 Click on Configure > Fuel model set selection. 
 Highlight the folder called MyFuelModels. 
 Click Ok. 

 
This will attach the custom Fuel Models that you have created in this folder of the 
Workspace. 
 

Moisture Scenario Folder 
BehavePlus allows the user to save a set of moisture conditions that can easily be used in 
multiple model Runs. These are called Moisture Scenarios. When using this option, the 
user does not have to enter individual fuel moisture values but rather selects a fuel 
Moisture Scenario from a list that describes the fuel moistures of all fuel classes and 
categories.  
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We will now create and save a Moisture Scenario. 
 
 Open the BasicStart.bpw Worksheet. (leave SimpleSurfaceSize_Mod.bpr 

open) 
 
Notice that the fuel moisture lines are blue because a Fuel Model has not been entered. 
Moisture Scenarios require values for all fuel moisture values, whether or not they are 
used in a given Fuel Model. Therefore, we will fill in all five values. 
 
Enter values for each of the Fuel Moisture variables as follows. It is not necessary to 
enter values for the other input variables. 
 

 

 

 

 
 Go to File > Save as a moisture scenario. 

 

 
 
Save the Moisture Scenario in the folder called MyMoistureScenarios. You can also 
create a new folder if you would like. 
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 Enter inputs as follows: 
 

 
 
It is a good practice to include the values in the name for easy reference. Recall that the 
Moisture Scenario names are listed with the codes on the last page of a Run.  
 
 Click Ok. You will receive confirmation that the Moisture Scenario was created. 

 
Note: It is recommended that you enclose the fuel moisture values in parenthesis that are 
saved in the Moisture Scenario in the Moisture Scenario Description box. For example, 
a typical Moisture Scenario description might end with “(3,4,5,30,60)”. This would 
indicate the fuel moisture values (%) for 1-h, 10-h, 100-h, live herbaceous, and live 
woody fuels respectively.  
 
 Close the BasicStart.bpw Worksheet 

 
The previously used Worksheet should still be available. If it isn’t, reopen 
SimpleSurfaceSize_Mod.bpr before continuing. 
 
 Click on Module Selection > SURFACE Options…. 
 Go to the Fuel & Moisture tab. 
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 Change the radio button for Moisture is entered by to moisture scenario. 
 

 
 
 Click Ok twice. 
 Click on the guide button by Moisture Scenario. 
 Scroll down the list and select the new Spring Moisture Scenario. 

 

 
 
 Click Ok. 
 Calculate the Run. 
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The results should look as follows. 
 

 

 

 

   
 

 

 

 
 Save this Run as SimpleSurfaceSize_Mod2.bpr. 
 Close BehavePlus. 

 

Using the New Workspace 
In this lesson you created custom Fuel Models and Moisture Scenarios. When you want 
to use them in future BehavePlus Runs, you must attach the appropriate folders to the 
current session. These files were saved in a different Workspace than the default, so you 
must migrate to that Workspace. Fortunately, BehavePlus will inform you when these 
files are missing. 
 
 Open BehavePlus. 
 Open the Workspace entitled BPWS_TinpanWFU. 
 Open the Run entitled SimpleSurfaceSize_Mod2.bpr. 
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You should receive a warning window stating that “Fuel model “three-quarters_tu2” is 
not currently attached to this session”. 
 

 
 
 Attach the Fuel Models in the folder MyFuelModels (Configure > Fuel model 

set selection; highlight the correct folder; and click Ok). 
 Calculate the Run. 

 
You should receive an Error window stating that “‘Moisture Scenario’ Input text 
‘Spring’ is an unknown choice.” 
 

 
 
 Click Ok. 
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 Attach the Moisture Scenarios in the folder called MyMoistureScenarios 
(Configure > Moisture scenario set selection; highlight the correct folder; and 
click Ok). 

 Calculate the Run again. 
 Click Ok. 
 The results will be the same as those in the previous section. 
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Copying, Moving and Deleting BehavePlus Files 
In addition to using Workspace commands to create BehavePlus folders, you can move 
and delete BehavePlus files and folders using Windows Explorer. This method does not 
create a description file in the new folder, so no description will appear for the new folder 
in subsequent folder selection dialogs.  
 
 Close BehavePlus. 
 Open Windows Explorer. 
 Navigate to the folder you created entitled BPWS_TinpanWFU. 
 In BPWS_TinpanWFU, highlight WorksheetFolder. 

 

 
 
 Click on File > New > Folder. A highlighted NewFolder folder appears in the 

right pane. 
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 Type “RxWorksheets” to rename NewFolder and press Enter. 
 

 
 
 Repeat to create a folder in the RunFolder called “RxBurnRuns”. 

 

Copying or moving files one at a time 
 In the left-hand pane, select the RunFolder > MyRuns folder to display its 

contents in the right-hand pane. 
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 Right-click on the file marked SimpleSurfaceSize_Mod2.bpr and select the 
Copy command from the shortcut menu. 

 

 
 
 Right-click on the RxBurnRuns folder in the left pane and select the Paste 

command from the shortcut menu. 
 
 Now, in the right-hand pane, right-click on the file marked 

SimpleSurfaceSize.bpr and select the Cut command from the shortcut menu. 
 
 Right-click on the RxBurnRuns folder in the left pane and select the Paste 

command from the shortcut menu. 
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The MyRuns folder should look like the following. 
 

 
 
The RxBurnRuns folder should look like the following. 
 

 
 
Notice the difference in the Copy and Cut commands. Copy duplicates the file 
“SimpleSurfaceSize_Mod2.bpr” while Cut moves a single file “SimpleSurfaceSize.bpr” 
to a new location. You can use the Copy method to backup your work. 
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Copying or moving groups of files 
 
 In the left-hand pane of Windows Explorer, click on WorksheetFolder > 

MyWorksheets folder. 
 
The MyWorksheets folder should look like the following. 
 

 
 
 Click on SimpleSurfaceSize.bpw. 
 Hold down the Ctrl key and click on SurfaceSimple_metric.bpw. 
 Right-click on either file and select the Copy or Cut command. 
 Right-click on the RxWorksheets folder in the left-hand pane and select the 

Paste command. 
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Both files should now be in the RxWorksheets folder. 
 

 
 

Deleting files 
BehavePlus files and folders can be deleted using Windows Explorer®.  
 
 Click the MyRuns folder in the left-hand pane of Windows Explorer to show its 

contents in the right pane. 
 Either right-click on the file SimpleSurfaceSize_Mod2.bpr. 

 
If the file is located on a local hard disk, you have a choice of moving the file to the 
Recycle Bin (the default) or deleting it permanently from your local hard drive. 
 
 Selecting the Delete command from the shortcut menu will move the file to the 

Recycle Bin where you can retrieve it later if needed. 
 Holding down the Shift key while selecting the Delete command removes the file 

permanently from your hard drive. 
 

Summary 
You can effectively use BehavePlus without a complete understanding of its file 
management structure. However, understanding folders, files, and Workspaces will 
increase your options for using the program. BehavePlus Workspaces are an easy way to 
organize and document your fire behavior and fire effects predictions into a single, 
shareable resource. Workspaces allow users to store all Worksheets, Runs, unit 
definitions, custom Fuel Models, Moisture Scenarios, and captured graphics in a single 
location. Workspaces are ideal for organizing documentation for a particular project, such 
as a prescribed fire burn plan or a wildland fire behavior assessment.  
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Exercises 
1. Describe how you might use Workspaces for prescribed fire planning. 

 
2. Describe how you might use Workspaces for training. 
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Exercise Answers 
1. Describe how you might use Workspaces for prescribed fire planning. 
Workspaces can be used to save model calculations performed during both the planning 
and implementation of a prescribed burn. During burn plan development, the Workspace 
can be used to save the Runs used to estimate the prescription windows such as the use of 
the table shading options in BehavePlus. The same Workspace can store a user-defined 
Worksheet that can be used to estimate fire behavior on the day of the burn. Prior to 
implementing the prescribed burn, the user simply needs to open the predefined 
Workspace and subsequent Worksheet, fill in the Worksheet with the expected conditions 
for the day and perform the calculations. These calculations can then be saved in that 
Workspace as a Run and can be included as part of the documentation for the burn. Using 
a single Workspace for the entire lifecycle of a prescribed burn from planning to 
implementation ensures that all of these calculations can easily be recreated if necessary. 
 
Managers can also use the clone Workspace feature to simplify this task. For example, if 
the user already has a Workspace created for a given burn and simply needs to duplicate 
these calculations for another burn, they can open the existing Workspace and use the 
File->Workspaces->Clone current workspace option to create a new Workspace from 
the existing Workspace. All the Workspace components from the current Workspace will 
be copied into a new Workspace and these components, such as Runs, Worksheets and 
custom Units Sets, will be available in the new Workspace. Then the user simply makes 
any necessary changes to the Workspace components and saves those changes. 
 
 
2. Describe how you might use Workspaces for training. 
Workspaces can be used in a training environment to simplify and organize learning and 
evaluation exercises. They allow the instructors to focus on developing an appropriate 
level of understanding of the model rather than the mechanics of the BehavePlus 
modeling system. Instructors can develop a single Workspace for a given instance of 
training and this Workspace can include both Worksheets and Runs. Worksheets are 
useful in a learning environment when the students are required to determine model 
inputs on their own from external resources such as from a spot weather forecast, map 
calculations or look-up tables. The Worksheets can be pre-configured with all the 
necessary modules and options and the students can focus on determining the best input 
choices rather than how to setup the Worksheet appropriately. Runs are useful when the 
emphasis is on learning the dynamics of a particular model not the mechanics the 
modeling system. In this way, the inputs to a particular model can be determined and 
provided beforehand and the students can focus on interpreting the BehavePlus output for 
a given model. This prevents time lost when students are unfamiliar with the modeling 
system and they have trouble finding a particular option or setting. 
 
Similarly, Workspaces can be used in a testing environment to create containers of the 
student’s work that can easily be referred to by an instructor to determine where a student 
might have gone wrong on a given question. Quite often, a student may be asked to 
perform a fire behavior assessment for a given location and a single poor choice in inputs 
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may affect the entire answer. If the students were required to save all of their work as 
Runs in a Workspace and give that Workspace, along with any written work, to the 
instructors, the instructors could refer to the student's Runs to provide more tailored 
feedback. 
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