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Calculations Lesson 
 
Introduction 
In the previous lessons you learned how to set up a Worksheet and to define input values. In this lesson 
you will perform calculations. produce and view tables and graphs, and change some of the units.  
 
Tables and graphs can take several forms, depending on how many input variables are assigned ranges 
(none, 1, or 2) and whether those variables are continuous or discrete. You can personalize the output by 
changing the size of graphs, the orientation of tables, and other features. 
 
Objectives 
By the end of this lesson, you will be able to do the following. 

1. Produce results for single and multiple values of input variables. 
2. Explain differences in tables and graphs for continuous and discrete variables. 
3. Modify table and graph appearances through selection of row, column, and X-Axis variables. 
4. Change graph and table appearance. 
5. Change units for input and output variables. 

 
Where This Lesson Fits In 
This is a lesson in the Introduction Unit, which teaches you basic program operation. These lessons 
should be completed in order.  
 
This is the fourth and final of four lessons that introduce you to the BehavePlus fire modeling system. 

1. Basic Start – simple entry of input to get answers in the form of tables and graphs  
2. Worksheets – how the Worksheet is developed from user selections  
3. Input Methods – various ways of entering input values  
4. Calculations – table and graph output options 

 
This lesson focuses on program operation, not fire behavior modeling. If you finish this lesson and have 
questions about the meaning of variables and modeling results, you are in good company. You will 
hopefully be inspired to continue to use BehavePlus to better understand concepts related to fire behavior 
modeling. 
 
Lessons in other units cover the many features and fire modeling capabilities offered by BehavePlus. 
Those lessons can be done in any order unless otherwise specified in the lesson. 
 
Note: There are questions (in blue) located throughout this lesson. The answers can be found at the end of 
the lesson starting on page 19. 
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Methods for Entering Inputs 
The type and number of variables you select will change the outputs created by BehavePlus. In this 
section, you will explore different input options to become more familiar with the calculations and 
outputs from BehavePlus. Interspersed with these input options are ways to change output appearance. 
 
Single value for each input variable 
We will start with a simple example where a single value is input for each variable. 
 
 Open a BasicStart.bpw Worksheet. 
 Enter the Description: Calculation Lesson, Single value inputs. 
 Click on the Module Selection button (  ) or go to Configure > Module Selection. 
 Deselect the SURFACE module and select IGNITE. 
 Click Ok. 
 Enter values as shown on the Worksheet below. 

 

 
 
 Calculate the Run ( ). 

 
When there is one value for each input variable, the Calculate Results dialog box will not appear since 
there are no output options. 

 
 

1. Change Fuel Shading from the Sun to 65%. What is the Probability of Ignition from a 
Firebrand? 

 
Multiple values for one continuous input variable 
Let’s enter multiple values for an input variable on a different Worksheet. 
 
 Close the current Worksheet (File > Close). 

 Open a new Worksheet (File > Open worksheet or ). 
 Look in the ExampleWorksheets folder. 
 Select the SurfaceSimple.bpw Worksheet. 
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Enter values on the Worksheet using the various techniques from the Input Methods Lesson. 
 
 Enter a Description: Multiple Values for Dead Fuel Moisture. 
 Enter a Fuel Model. Click on the Guide button and select the fuel model for Southern rough. 
 Enter a range of Dead Fuel Moisture From 9 Thru 21 Step 3 using the Guide button. 
 Click on the Live Fuel Moisture Guide button. Use Choices to select the moisture value for 

Mature foliage, new growth complete and comparable to older perennial foliage. 
 Enter Midflame Wind Speed of 5 mi/h. 
 Enter Slope Steepness of 20%. 

 
The Worksheet should look like the following. 
 

 
 
 Calculate the Run. 

 
The following Calculate Results window appears. 
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 Click Ok in the Calculate Results dialog box to accept the default selections. Both table and 
graph results are produced. 

 
When the calculations are complete, the first output page is displayed. On the table, both output variables 
are calculated for each value of Dead Fuel Moisture. 
 

 
 

Click the Next Page ( ) button to view the next page, which is, in this case, a graph of Surface Fire 
Rate of Spread. 

 
 
Look at the Next Page to view the Surface Fire Flame Length graph. The final page shows the discrete 
variable codes related to this Worksheet and calculation. 
 
The tables and graphs all include the header Head Fire to remind us that this Run is for a heading fire 
(burning in the direction of maximum spread) only. 
 

2. Change the following input variables. What is the predicted fire behavior? 
o Dead Fuel Moisture: 12% 
o Midflame Wind Speed: From 2 Thru 10 Step 2. 

 
Multiple values for one continuous input variable 
Next, let’s see how multiple input values for a discrete variable, such as Fuel Model, affect the outputs. 
 

 Return to the First Page ( ). 
 Edit the Description to read Multiple Values for Fuel Model. 
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 Click on the Fuel Model Guide button and select Fuel Models 6, 7, sh3, sh4, sh8, sh9 
(representing humid shrubs). 
Note: You do not have to hold down the control key in BehavePlus to make multiple selections. 
Click on each one to select it; click on it again to deselect it. 

 Click Ok. 
 Change Dead Fuel Moisture to 9%. 
 Midflame Wind Speed is 5 mi/h. 

 
The Worksheet has changed as follows. 
 

 
 
Before calculating the Run, let’s change the appearance of some of the outputs. 
 
 Click on Configure > Appearance Preferences. 
 Select the Graph Size tab. 
 Change Graph Title to Long. 

 

 
 
 Click Ok. 
 Calculate the Run. 
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The table now shows Surface Fire Rate of Spread and Surface Fire Flame Length for the six different Fuel 
Models. 
 

 
 
View the graphs for Surface Fire Rate of Spread and Surface Fire Flame Length. 
 

  
 
Note the change in the graph headings. Additional information (e.g., Surface Fire Flame Length by Fuel 
Model) is displayed because the Graph Title option was changed from Short to Long. 
 
The graphs help you compare fuel models given the same moisture, wind, and slope. The two graphs 
show that the fuel model you select may affect Surface Fire Rate of Spread (ROS) and Surface Fire Flame 
Length (FL) differently. The ROS is used to predict spread distance and fire size. The FL is important 
when you are examining fire effects, calculating required suppression resources, and investigating 
transition to crown fire. 
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Click on the Last Page button ( ) to view the Discrete Variable Codes. 
 

 
3. Change the Fuel Model by selecting the hardwood litter models. What is the effect of these fuel 

models on Surface Fire Rate of Spread and Surface Fire Flame Length? 
 
The graphs produced in the first example for a range of fuel moisture values are lines because it is a 
continuous variable. The graphs from the second example are bars, because fuel model is a discrete 
variable. BehavePlus will automatically select the correct graph to use. 
 
Multiple values for two input variables: One continuous and one discrete 
For this Run, you will include multiple input values for both a continuous variable (Dead Fuel Moisture) 
and a discrete variable (Fuel Model). 
 
 Open a new BasicStart.bpw Worksheet. 
 Using the skills you have gained so far, change the Worksheet and enter the following data. 

o Description: Multiple Values for Dead Fuel Moisture and Fuel Model 
o Fuel Model: 6, 7, sh3, sh4, sh8, sh9 
o Dead Fuel Moisture (%): From 9 Thru 21 Step 3 
o Live Fuel Moisture: 100% 
o Midflame Wind Speed (upslope): 5 mi/h 
o Slope Steepness: 20% 

 
Your inputs should look like the following. 
 

 
 
 Calculate the Run. 

 
The following Calculate Results window appears. You can select which variable you would like to be 
the Table Row Variable. The Help file provides an explanation of the options available to you. 
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 Accept the defaults for now and click Ok. 
 
A two-way table and a graph are produced for each of the selected output variables, Surface Fire Rate of 
Spread and Surface Fire Flame Length. Since we accepted the default values, a Fuel Model is listed on 
each row, and the Dead Fuel Moisture values are shown as columns.  
 

  
 
Since Fuel Model is a discrete variable, it cannot be the X-Axis Variable if there is a continuous variable 
that has multiple values. Therefore, Dead Fuel Moisture is the X-Axis Variable, and each Fuel Model is 
plotted separately on the graph. The text in the upper right-hand corner of the graph lets you know there is 
a curve for, in this case, every Fuel Model. 
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4. Examine the graphs for Surface Fire Rate of Spread and Surface Fire Flame Length.  
What can you say about the fire behavior for SH3 and SH4 under these conditions? 

 
 Return to the Worksheet and change the Dead Fuel Moisture (%) to From 9 Thru 27 Step 3. 
 Calculate the Run, accepting the defaults in the Calculate Results window. 

 

  
 
In this case, the table is too wide to fit on one page. The box in the upper right-hand corner of the page 
shows how many pages there are in the table (number of boxes) and which page you are currently 
viewing (highlighted in red and marked with a black “X”). The arrows to the right side of the first table 
indicate that the graph continues on the next page. The arrows to the left of the 2nd table indicate that there 
are pages before it. There are no arrows to the right of this page, indicating that it is the last page for the 
table. 
 
 Click on the Next Page button until you reach the Surface Fire Flame Length output graph. 

 
This graph is on page 7 of the Run as shown in the upper right-hand corner.  
 

 
 
There are eight pages in the Run as shown at the bottom of the window. 
 

 
 
You can quickly navigate through the Run using the Pages tab on the main menu. When you click on it, a 

list of pages appears. It lets you know if the page is a Worksheet ( ), a table ( ), a graph ( ), or 

a list of discrete codes ( ). Click on any page to view it. 
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Let’s change one more thing before we move on. 
 
 Calculate the Run again (don’t change any inputs). 

Hint: You do not need to be on the first page (Worksheet) to calculate a Run. 
 In the Calculate Results window, change the Table Row Variable to Dead Fuel Moisture and 

click Ok. 

 
 
All of the tables fit on a single page now as shown for Surface Fire Rate of Spread below. You can use 
this option to format your tables for printing or saving.  
 

 
 
Hint: Remember from the Input Methods Lesson that you can reverse the order of the Dead Fuel 
Moisture input values so that the table reads from minimum (upper left) to maximum (lower right) 
Surface Fire Rate of Spread and Surface Fire Flame Length. 
 

5. What is the maximum Surface Fire Rate of Spread for these fuel models when the Dead Fuel 
Moisture is 15%? What is the range of Surface Fire Flame Length values for a Fuel Model SH3? 

 
Multiple values for two input variables: both continuous 
In this example, you will examine the effect of changes in both live and dead fuel moisture on the outputs. 
 
 Open a new SurfaceSimple.bpw Worksheet. 
 Change your Worksheet to look like the following. 
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 Calculate the Run. 
 In the Calculate Results window, make sure the Display table results box is unchecked. The 

Display graph results box should be checked, so that only graphs will be displayed. 
 

 
 
 Click Ok. 

 

 
 
Running a range of values allows you to explore the sensitivity of the fire behavior models to inputs. This 
example shows the effect of Live Fuel Moisture on Surface Fire Rate of Spread. Notice the distinct 
difference between the lower values for Live Fuel Moisture (50-100%) and the higher ones (200-300%). 
When the Live Fuel Moisture is low, it contributes to the rate of fire spread. When the Live Fuel Moisture 
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reaches the critical value of Live Fuel Moisture of Extinction, it acts as a heat sink, lowering the Surface 
Fire Rate of Spread. There is no input for Live Fuel Moisture of Extinction. It is a function of the Dead 
Fuel Moisture of Extinction, which is a Fuel Model parameter. 
 
 Calculate the Run again, putting Live Fuel Moisture on the X-Axis. 

 

 

 
 
Now, the lines represent the Dead Fuel Moisture. Changing the X-Axis variable may help you better 
interpret the predicted fire behavior and examine model sensitivity. 
 
Graph Appearance 
BehavePlus allows you to change the appearance of graphs to meet your needs. In this section, you will 
explore some of those options. We will continue using the Run from the previous section. 
 
Changing the graph appearance 
 Select the Configure > Appearance preferences command from the menu bar. 
 Select the Graph Elements tab. 
 Choose Gray from the drop-down list for Background. 
 Choose Black from the drop-down list for Curve Color. 
 Choose White from the drop-down list for Gridline Color. 
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 Click the Ok button to close the Appearance Options dialog box. 
 Calculate the Run. 

The graph now looks like the following. 
 

 
 
Changing the X-Axis minimum value 
 Using the previous instructions, change the following Graph Elements. 

o Background to White 
o Rainbow Colors to 10 
o Curve Color to Rainbow Colors 
o Gridline Color to Gray 

 
 Click on the Graph Size tab and change the following elements. 

o Graph Size to 75% 
o X Axis Origin to Min Value 
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 Click Ok 
 Change the Dead Fuel Moisture to From 2 Thru 16 Step 2. 
 Calculate the Run. 

 

 
 
The graph takes up more of the page, which means it may be easier to see. Graphing the X-Axis by 
starting with the minimum value expands graph output, reduces white space and enables you to better see 
results. 
 
Each of the elements in the Appearance Options window are described in the associated Help files. 
 

6. How can you eliminate the black border around the output? 
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Any changes made in the Appearance Options > Application tab are program-wide. They will carry 
over from one session to the next. You can turn off the Picture shown with all of the Guide windows 
using this option. While you can also turn off the Help, we strongly suggest you retain it. 
 
All other Appearance Options changes will be retained with the current Worksheet or Run once you 
save it. They will not carry over to new Worksheets. Remember, if there is a Worksheet that you use 
often, save it and consider making it your startup Worksheet. You can specify many options including: 

• Module Selection, 
• Input options, 
• Output variables, 
• Appearance preferences, and 
• Default units and precision (number of decimal places). 

 
Changing the Y-Axis maximum value 
Let's look at one final graph option. Sometimes you want to compare results from two different graphs. In 
this case, it is helpful to use the same range on the Y-Axis to facilitate comparison. 
 
 Open a BasicStart.bpw Worksheet. 
 Outputs are Surface Fire Rate of Spread and Surface Fire Flame Length. 
 Modify a Worksheet to use the following inputs.  

o Description: Setting the Y-Axis values 
o Fuel Model: 5 
o Dead Fuel Moisture: 2-18%, Step 1. 
o Live Fuel Moisture: 300, 200, 100, 50% 
o Midflame Wind Speed: 5 mi/h 
o Slope Steepness: 20% 

 Calculate the Run. 
 In the Calculate Results dialog box, deselect Display table results and click Ok. 

 
7. What is the maximum value on the Y-Axis? 

 

 
 
 Return to the Worksheet (First Page). 
 Change the Live Fuel Moisture to 300%. 
 Calculate the Run. 
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8. What is the maximum value on the Y-Axis in this Run? 

 
The scale of the graph changes automatically to reflect the maximum Y-Axis value for the current 
calculation. If we want to compare this graph to the previous one, we need to change the Y-Axis values. 
 
 Calculate the Run again. 
 Check the box next to Specify graph Y axis limits and click Ok. 

 

 
 
A new window pops up allowing you to change the Y-Axis variables for all of the output variables, in this 
case Surface Fire Rate of Spread and Surface Fire Flame Length. The current range of variables for each 
variable is also displayed. 
 
 Change the Y Axis Maximum to 60 and click Ok. 
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Now you can more easily compare the two graphs as shown below with the original Run on the left and 
the revised Run for Live Fuel Moisture of 300% on the right. 
 

  
 

Changing Units 
The default units on the Worksheet are simply those that are used often. Sometimes, however, you may 
need to report outputs differently. Let’s examine a fast-moving crown fire and see how the units might be 
changed. 
 
 Open a new BasicStart.bpw Worksheet. 
 Select both the SURFACE and CROWN modules. 
 Include the following outputs. 

o SURFACE module: no outputs 
o CROWN module: Active Crown Fire Rate of Spread, Active Crown Fire Flame Length, 

Crown Fire Type, and Active Crown Fire Spread Distance 
 
You must select the SURFACE module if you want to calculate crown fire from calculated surface fire 
parameters. You do not have to show any outputs from the SURFACE module if you only want to use the 
calculations in the CROWN module. First, let’s look at the outputs. Active Crown Fire Rate of Spread is 
output in ch/h, and Flame Length values are in ft. Active Crown Fire Spread Distance is in chains. Since 
this is a fast-moving crown fire, it may be more useful to output the Active Crown Fire Spread Distance 
in miles. 
 
 Click on Configure > Custom units preferences. 
 Go to the Fire & Effects Units tab. 
 Change the Spread Distance from ch to mi. 
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 Click Ok. 
 When it asks if you would like to Save as Units Set File? Click No. 

Note: If you select Yes, you will be prompted to save the file in your BehavePlus Workspace. You 
can use it later by going to Configure > Units set selection > Custom and navigating to the 
saved Units Set File. 

 
Next, look at the inputs. The Canopy Bulk Density is often obtained from the academic literature and 
reported in metric units (kg/m3). Let’s change these units as well. 
 
 Return to Custom units preferences. 
 Go to the Fuel & Vegetation Units tab. 
 Change the Canopy Bulk Density to kg/m3. 

 

 
 Click Ok and do not save the Units Set File. 

 
You are now ready to enter the data.  
Hint: Determine your outputs, and then set up the input options before entering any data. 
 
 Fill out the Worksheet as follows. 

o Description: Changing Units, Crown Fire 
o Fuel Model: tu5 
o Canopy Height: 45 

 
 Click on the Guide button next to Canopy Base Height. 
 Scroll down in the Help file. We have included published descriptions for fire in Interior West 

conifer stands with varying treatment levels. 
 Click on Douglas-fir / Lodgepole pine. 

o Canopy Base Height: Select the value for 75% of Initial Basal Area (in feet) 
Hint: You can enter the appropriate value in the From box and click Ok. 

o Canopy Bulk Density: Select the value for 75% of Initial Basal Area (in kg/m3) 
o Dead Fuel Moisture: 5-10%, Step 1 
o Live Fuel Moisture: 100% 
o Foliar Moisture: 100% 
o 20-ft Wind Speed: 5-25 mi/h, Step 5 
o Wind Adjustment Factor: In the Help file, select the appropriate value for a partially 

sheltered TU5. 
o Slope Steepness: 23% 
o Elapsed Time: 2 hours 
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 Calculate the Run. 
 

9. Which 20-ft Wind Speed predicts crowning across all Dead Fuel Moisture values? What is the 
range of Active Crown Fire Spread Distance when the model predicts crowning? 

 
This is only a brief introduction to changing variable units. Please see the Operation Unit Units and 
Decimals Lesson for more information. 
 
Summary 
In this lesson, you have produced results for single and multiple values of input variables while modifying 
the appearance of tables and graphs. You also learned the basics of changing variable units 
 
This is the last of four lessons in the Introduction Unit which provide the basics of program operation. 
The remaining BehavePlus lessons may be done in any order you wish. Subsequent lessons cover the 
many features and fire modeling capabilities offered by BehavePlus. 
 
There are exercises associated with this lesson. They start on page 24, after the answers to the questions in 
the lesson. 
 
You have completed the final lesson in the Introduction Unit.  

1. Basic Start – simple entry of input to get answers in the form of tables and graphs  
2. Worksheets – how the Worksheet is developed from user selections  
3. Input Methods – various ways of entering input values  
4. Calculations – table and graph output options 

 
Answers to questions in the lesson 
1. Change Fuel Shading from the Sun to 65%. What is the Probability of Ignition from a Firebrand? 

The Probability of Ignition from a Firebrand is now 62%. 
 

 

 
 

2. Change the following input variables. What is the predicted fire behavior? 
o Dead Fuel Moisture: 12% 
o Midflame Wind Speed: From 2 Thru 10 Step 2. 
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The Surface Fire Rate of Spread varies from 8.7 ch/h to 56.5 ch/h, while the Surface Fire Flame 
Length varies from 3.2 to 7.6 ft. 

 

  
 
3. Change the Fuel Model by selecting the hardwood litter models. What is the effect of these fuel 

models on Surface Fire Rate of Spread and Surface Fire Flame Length? 
The Fuel Models that may represent hardwood litter are 9, tl2, tl6, and tl9. Note, however, that you 
should always choose the Fuel Model that best represents the fire behavior for the area. Don’t simply 
rely on a name, description, or picture of the fuel. Look at fuel model parameters and outputs as well. 
 
Fire behavior for these Fuel Models is low, with Surface Fire Rate of Spread ranging from 1.5 to 
almost 10 ch/h and Surface Fire Flame Lengths that are 5 ft or less. Fuel Model TL2 (182) has the 
least fire behavior with both low ROS and FL. Fuel Models 9 and TL9 have similar rates of spread, 
but slightly different flame lengths. 
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4. Examine the graphs for Surface Fire Rate of Spread and Surface Fire Flame Length. What can you 
say about the fire behavior for SH3 and SH4 under these conditions? 
SH3 and SH4 predict the lowest fire behavior. Their fire behavior does not change much across the 
range of Dead Fuel Moisture values (10-20%). SH4 has a higher ROS than SH3 but very similar FL. 

 

  
 
5. What is the maximum Surface Fire Rate of Spread for these fuel models when the Dead Fuel Moisture 

is 15%? What is the range of Surface Fire Flame Length values for a Fuel Model SH3? 
When the Dead Fuel Moisture is 15%, the maximum Surface Fire Rate of Spread is 29.6 ch/h for fuel 
model SH9. The Surface Fire Flame Length ranges from 2.7 to 3.5 ft for an SH3. 
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6. How can you eliminate the black border around the output? 

In the Configure > Appearance preferences > Appearance Options window, open the 
Application tab and change Border Width to 0 (see the Help file). This eliminates the border for all 
current and future BehavePlus Worksheets and Runs. This change is saved with the application, not 
the Worksheet or Run. 
 

 
 

7. What is the maximum value on the Y-Axis? 
The maximum Y-Axis value is 60 ch/h. 
 

8. What is the maximum value on the Y-Axis in this Run?  
The maximum Y-Axis value is 6 ch/h. 

 
9. Which 20-ft Wind Speed predicts crowning across all Dead Fuel Moisture values? What is the range 

of Active Crown Fire Spread Distance when the model predicts crowning? 
A 20-ft Wind Speed of 20 mi/h generates crown fire for all Dead Fuel Moisture values. Active Crown 
Fire Spread Distance for the 2-hour period ranges from 1.2 to 1.9 miles. 
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Exercises 
1. Develop a new Worksheet that looks like the following and answer the questions. 

Hint: Go to SURFACE Module Options… > Input Options > Slope and select Slope Steepness is 
calculated from map measurements. 

 

 
 

a. If the Map Representative Fraction is 24000, how many inches on the map represent a mile on the 
ground? 

b. What is Slope Steepness in percent? 
c. What is Slope Steepness in degrees? Hint: Look in the SURFACE Module Input Options. 

 
2. Calculate maximum spotting distance from a single 40-ft tall torching subalpine fir with a D.B.H. of 

12 in. Trees downwind are 50 ft high, and Downwind Canopy Cover is open. The terrain is flat. 
Consider 20-ft wind speeds of 5, 10, 15, 20, and 25 mi/h. 

 
3. Using the following information, create a table for Surface Fire Rate of Spread and Surface Fire 

Flame Length that ranges from lowest value in the upper left-hand corner to highest value in the 
lower right-hand corner. Create tables and graphs that looks like the following. 

 
• Description: Exercise 3, Surface Fire Rate of Spread 
• Fuel Model: TU5 

Hint: You can also enter 165, the Fuel Model Number associated with Fuel Model Code TU5. 
• 1-h Fuel Moisture: 5-15%, Step 2 
• 10-h Fuel Moisture: 7% 
• 100-h Fuel Moisture: 9% 
• Live Herbaceous Fuel Moisture: 90% 
• Live Woody Fuel Moisture: 110% 
• Midflame Wind Speed: 2-12 mi/h, Step 2 
• Slope Steepness: 15% 
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4. Produce a table and graph as shown below. All of the information you need can be obtained by 

reading the Description and looking at the variables in the table. 
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Answers to these exercises can be found in the accompanying PDF file. 
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