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Abstract 
Andrews, Patricia L.; Bevins, Collin D.; Seli, Robert C. 2003. BehavePlus fire modeling system, version2.0: 
User’s Guide. Gen. Tech. Rep. RMRS-GTR-106WWW. Ogden, UT: Department of Agriculture, Forest 
Service, Rocky Mountain Research Station. 132p. 

The BehavePlus fire modeling system is a program for personal computers that is a collection of mathematical 
models that describe fire and the fire environment. It is a flexible system that produces tables, graphs, and 
simple diagrams. It can be used for a multitude of fire management applications including projecting the 
behavior of an ongoing fire, planning prescribed fire, and training. BehavePlus is the successor to the BEHAVE 
fire behavior prediction and fuel modeling system. Primary modeling capabilities include surface fire spread and 
intensity, safety zone size, size of point source fire, fire containment, spotting distance, crown scorch height, 
tree mortality, and probability of ignition. The User’s Guide describes operation of the program. Other papers 
describe the models and application of the system. 
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Preface 
This User’s Guide explains how to use the BehavePlus fire modeling system software. Other papers will 
describe the models incorporated into the system and application of the predictions. 

This is an RMRS online publication.  It can be downloaded from the Rocky Mountain Research Station 
publications web page, http://www.fs.fed.us/rm/main/pubs/electronic.html
You can download this User’s Guide and the BehavePlus program and provide comments through the 
BehavePlus web site, http://fire.org
This User’s Guide is also an integral part of the BehavePlus system, serving as online help. 

This publication will be updated as features and modeling capabilities are added to the program. 

The BehavePlus system is supported by  
USDA Forest Service 
National Fire and Aviation Management Information Systems Team 
3833 S. Development Avenue 
Boise, ID 83705 
(800) 253-5559 

fire_help@dms.nwcg.gov

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The use of trade or firm names in this publication is for reader information and does not 
imply endorsement by the U.S. Department of Agriculture of any product or service. 
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1. Introduction 
 

The BehavePlus fire modeling system is a PC-based program that is a collection of models that describe fire 
and the fire environment. It is a flexible system that produces tables and graphs and can be used for a 
multitude of fire management applications. BehavePlus is the successor to the BEHAVE fire behavior 
prediction and fuel modeling system (Andrews 1986, Andrews and Chase 1989, Burgan and Rothermel 1984, 
Andrews and Bradshaw 1990). It is called the BehavePlus fire modeling system to reflect its expanded scope 
(Andrews and Bevins 1999).   

This document describes operation of the BehavePlus program. The fire models and their application are 
described elsewhere. 
Many of the fire models in BehavePlus are the same as those in the FARSITE fire area simulator (Finney 1998) 
and the FlamMap fire behavior mapping and analysis system. Each system meets a different need. The same 
surface fire spread model (Rothermel 1972) was used in each case. These three programs and supporting 
documentation are available through www.fire.org. Shown below are example outputs from each system. 

Sample table, graph, and diagram output from BehavePlus: 
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Sample fire perimeter output from FARSITE: 

 

 
 

Sample landscape fire potential output from FlamMap: 
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Version 1.0 of BehavePlus was based primarily on the same fire models that composed the old BEHAVE 
system. Development focus was initially on a new look and feel for the program. This paper describes version 
2.0, which provides additional models and features. A summary of changes from version 1.0 to version 2.0 is 
given in Appendix A.  

The primary modeling capabilities of BehavePlus, version 2.0, include  

• Surface fire spread and intensity 
• Safety zone size 
• Size of a point source fire 
• Fire containment 
• Spotting distance 
• Crown scorch height 
• Tree mortality 
• Probability of ignition from fire brands or from lightning 

Other modeling capabilities include 

• Tables for fine dead fuel moisture  
• Tables for relative humidity or dew point 
• Standard and custom fuel models 
• Dynamic palmetto-gallberry fuel 
• Three methods for weighting two fuel models: two-dimensional expected spread, harmonic mean, 

area weighted  
• Sunrise, sunset, dawn, and dusk at any location or date 

Key features include 

• Diagrams for point source fire shape, shape of a contained fire, fire characteristics chart, wind / slope 
/ fire directions 

• Photographs and a key for the standard 13 fuel models 
• Distances in map units 
• User control of input options and output variables 
• Description of each input and output variable 
• User control of units and number decimal places displayed 
• Multiple values can be entered for almost any input variable 
• User interface language can be changed (currently English and Portuguese) 
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The help system is an important part of the BehavePlus system. This User’s Guide is available with the 
program for help on operation of the program. In addition, a help browser is available in the dialog boxes 
providing immediate information on specific operations and definition of input and output variables as shown 
below.  
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2. Operation 

2.1. Overview 
This User’s Guide addresses only operation of the program. The fire models, associated variables, and 
application are described elsewhere.  

Organization of material on Operation of the BehavePlus program is different from the organization of the 
program itself. It is designed to help you find the answer to a question. Most users are comfortable with 
looking at menus and dialog boxes and associated information in the program without use of a User’s Guide.  

This is not a step-by-step operation manual, but a reference guide. The tutorials provide step-by-step 
instructions. 

In describing operation of the program, we use the following font and/or conventions in describing menus, 
commands, buttons, tabs, and checkboxes: 

Configure > Module selection > SURFACE > Options… > Fuel & Moisture > fuel models 
option button. 

For example the sequence of menus, commands, check boxes, buttons, and tabs shown above refers to the 
following actions in BehavePlus: 

 
Each of the above elements would be described in this User’s Guide as 

1. Configure menu 

2. Module selection command 

3. SURFACE check box 

4. Options... button 

5. Fuel & Moisture tab 

6. fuel models option button 
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Other elements used in BehavePlus include 

7. Spin box – select the value using the  buttons or enter a value from the keyboard, 

8. Text box – click inside the box to enter values from the keyboard. 

9. Drop-down list – Choose the value from the list displayed with the  button. 

In the interest of saving space and improving readability, we include screen captures of only the portion of 
concern. The Tutorials include more complete screen captures. 

2.2. Design 

2.2.1. Page Oriented 
BehavePlus is meant to be more than just a fire modeling tool. It is meant to be a lesson book with a built-in 
training manual, and a planning tool whose results may be incorporated into management reports. It is meant 
to be a fire behavior assessment aid whose tables and graphs can be shared with others in briefings and in 
written documentation. BehavePlus is meant to be run over and over for multiple purposes, so it is meant to 
be self-documenting. 

Because of these expectations, the BehavePlus user interface is designed around the concept of the standard 
8.5 x 11 printed page. 

Given input information BehavePlus can generate documentation, diagrams, tables, and graphs. Fortunately, 
they all fit on a standard printer page; merely press the Print button and file the copy. Six months later when 
you need to review the work, the What, How, and Why of each Run is considerably less obscure than it 
would have been otherwise. 
The page on which you enter input information appears first (page 1) and is called the Worksheet. A complex 
Worksheet may span several pages. Once the Calculate button is pressed, BehavePlus generates additional 
pages containing output tables, graphs, and diagrams. These too are deigned to fit neatly on the printed page. 
Navigation buttons on the Tool Bar let you move to the first page, last page, next page, or previous page. The 
Pages menu lets you jump directly to any diagram, table, or graph. The Print dialog lets you print selected 
pages. 
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2.2.2. Highly Configurable 
BehavePlus is meant to be the repository of many current and future models related to fire behavior and 
effects. These models may have alternate input sets and can produce many output variables. Individual models 
may be linked together so that outputs from one module automatically become inputs for another module. 
Input and output variables may have user-specified units of measure. Outputs may be in the form of diagrams, 
tables, and/or graphs. The language displayed on Worksheets and output pages may be changed. 

BehavePlus may be used for fire behavior training, for fire planning, or for real-time fire behavior assessment. 
It may be used to assess just fire behavior, or just fire effects, or the link between them. It may be used to 
build custom fuel models, to determine astronomical events, or as a units conversion utility. 

2.2.3. Self Documenting 
The brooding step-brother of configurability is complexity. Because BehavePlus is so highly configurable and 
may be used by people in various roles for various purposes, it strives to be self-documenting in an attempt to 
thwart entropy. The input Worksheet automatically documents all Modules in use, all input variables and units 
of measure, all output variables and units of measure, and pertinent notes on the current configuration. The 
Worksheet also allows you to enter a Run description (and possibly additional training or fire incident 
information) and contains a notes field for free-field entry of expository text. 

2.2.4. User Manual and Help 
BehavePlus tries to provide pertinent information to you when you need it the most. The Guide Button  
next to each entry field opens a dialog containing a help browser pane with suggested or valid inputs. The help 
browser pane describes input and output variables and program operation. The browser provides tables, 
photographs, and figures to help you select inputs. 

In addition, this manual is available as part of BehavePlus through Help > Program help.  

2.2.5. Not Boring 
Finally, every attempt has been made to keep BehavePlus from becoming yet another boring program with a 
gray personality. Just in case all the complexity, configurability, widgets, dialogs, models, diagrams, tables, 
graphs, browsers, and quirky behavior aren’t enough to hold your attention, here and there we’ve inserted 
some paintings we rather enjoy to ease our weary eyes. 

If you, however, prefer the gray approach, you can eliminate the pictures for the entire session by clearing the 
Show picture pane check box on the Configure > Appearance > Application tab 
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You can also choose to show the picture or not in individual windows by selecting or clearing the Picture 
check box 

 

2.3. Features 

2.3.1. Fire Models 
BehavePlus contains models to estimate 

• surface fire spread, intensity, flame length, scorch height, and direction of maximum spread 
• surface fire spread rate, intensity, flame length, and scorch height in any compass direction 
• fire shape, area, and perimeter 
• spotting distance from a burning pile, from torching trees, or from a wind-driven surface fire 
• success or failure of suppression resources to build line around a fire 
• recommended fire safety zone radius, separation distance, and zone size 
• fire-induced tree mortality 
• probability of fire ignition from firebrands 
• probability of fire ignition from lightning strikes 
• relative humidity or dew point temperature 
• midflame wind speed 
• fine dead fuel moisture content 
• sun-rise, sun-set, dawn, and dusk at any location or date 
• palmetto-gallberry dynamic fuels 
• custom fuel models 
• custom moisture scenarios 
• weighted fire behavior within a two fuel model complex 
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2.3.2. Operation 
BehavePlus has the following operational features: 

• BehavePlus is cross-platform and works identically on all versions of Windows and Linux. 
• Multiple Worksheets may be open at one time. 
• Worksheets may be overlaid, tiled, cascaded, and resized. 
• Modules (collections of related fire models) may be individually toggled on/off. 
• Modules may have alternate input options available through the Configure > Module > Options > 

Input Options dialog box. 
• Module output variables can be toggled on/off via the Configure > Modules > Options > 

Output Variables dialog box. 
• Modules may be linked so the outputs from one module are automatically input into another module. 
• All distance outputs may be scaled to map units. 
• All input and output units of measure may be modified by the user. 
• Custom Worksheet configurations may be saved and re-used. 
• Custom sets of units of measure may be saved and re-used. 
• The Guide Button next to each Worksheet entry field displays a help browser pane with context-

specific text and either a list of valid choices (for discrete variables) or fields for generating a range of 
input values. 

• Zero, one, or two input variables may have multiple entry values, producing either a simple result list, 
a single one-way table, or a multipage two-way table, respectively. 

• If one input variable has multiple entry values, a separate graph can be generated for each output 
variable. If two input variables have multiple entry values each output variable graph contains a family 
of curves. 

• The SURFACE, SIZE, and CONTAIN Modules can produce diagrams of their results. 
• Help > Program Help makes this manual and all associated documentation available in PDF format 

for reading, web browsing, and printing. 
• The user interface language may be dynamically changed via Configure > Language. Currently 

English (U.S.) and Portuguese (Portugal) are supported. (Contact cbevins@montana.com if you’d like 
to volunteer to add support for another language). 

• Completed Runs may be saved and re-used. 

2.4. Installation 

2.4.1.  Download 
BehavePlus is available for download from www.fire.org. Simply follow the BehavePlus links to the download 
page and select either the Windows or Linux installation package. 

You should check the downloaded file size against the original to ensure you received the entire package. To 
be absolutely certain the package arrived intact, use the md5sum program from a command line prompt: 

 
 md5sum bp_2_0_0.exe 

 
If the resulting 32-digit hexadecimal number is not identical to the one published on the BehavePlus download 
page, your download copy is corrupt. 
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2.4.2. System Requirements 
BehavePlus has modest system requirements met by the most inexpensive computers available on the market: 

• Linux or Windows 95, 98, ME, NT, 2000, or XP 
• Minimum 800 x 600 video resolution with 256 (8-bit) colors (recommend 1024 x 768 video 

resolution with 64K (16-bit) colors) 
• 16 megabytes of available RAM 
• 20 megabytes of disk storage 

2.4.3. Windows Installation 
BehavePlus for Windows is packaged using the Wise Installation System. Simply type the name of the package 
(e.g., bp_2_0_0.exe) at a command prompt (or click on its name in Windows Explorer) and the installation 
wizard will guide you through the process. This mostly consists of pressing the OK button. 

2.4.4. Linux Installation 
BehavePlus for Linux is packaged as a tarball using tar and gzip. Move the downloaded file (bp-2.0.0.tar.gz) 
into the parent directory where you wish it to be installed, and enter 

 
 tar xvzf bp-2.0.0.tar.gz 

 
This creates the bp-2.0.0 subdirectory and unpacks the BehavePlus binary executable, supporting library files, 
and data subdirectory structure within it. 

2.4.5. File Structure 
BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The 
parent directory of this file structure and all its subdirectories and files are collectively known as a Workspace. 
When BehavePlus is first installed it has a single Workspace called “DefaultDataFolder” as shown below.  

 

 
This is the default current Workspace every time BehavePlus is started.  
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We recommend that you use Workspaces to aid file management as you apply BehavePlus to several projects. 
See the section 18.1 Workspaces for more information. 

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 
automatically attached to the files you create in BehavePlus. 

File extension File type Folder 

.bpf Custom fuel models FuelModelFolder 

.bpm Moisture scenarios MoistureScenarioFolder 

.bpr Runs RunFolder 

.bpu Custom Units Sets UnitsSetFolder 

.bpw Worksheets WorksheetFolder 

2.5. Definitions 
A Worksheet is the first page or two containing the input Entry Fields. The content of a Worksheet depends 
upon the specific BehavePlus configuration including module selections, input options, output variables, units of 
measure, and diagram/table/graph options. Thus there are a large number of possible Worksheets. Some 
Example Worksheets are supplied with the BehavePlus distribution and are included in every Workspace. You 
may reconfigure BehavePlus as needed for any purpose, then save its Worksheet for later reuse. Functionally, 
a Worksheet is a BehavePlus configuration that does not have any input values associated with it. 

A Run is a Worksheet that has a complete set of valid inputs, but no ouputs are saved in a Run. You must 
calculate a saved Run to obtain outputs. Any given Worksheet may have an infinite number of Runs, each 
determined by its input values. Runs may be saved for later use and review. The BehavePlus installation 
includes Example Runs. 

A Model is a set of equations that estimate one or more output variables from one or more input variables. 
While BehavePlus contains many models, you will more commonly see references to Modules, which are 
collections of models. 

A Fuel Model is a set of numbers describing a fuel bed used by the surface fire spread model. 

A Module is a collection of one or more Models that can be activated/deactivated by the user during 
Worksheet configuration. Selecting the IGNITE Module, for example, includes both the firebrand ignition 
model and the lightning strike ignition model. 
A Continuous Variable is an input or output variable that has a continuous range of values. Continuous 
variables have a minimum and maximum valid value. Examples include fuel moisture content, and wind speed. 

A Discrete Variable has a finite set of valid values. Examples include Fuel Model, Spotting Source Location, and 
Tree Species. 

A Guide Button is the button with the arrow icon next to each Worksheet entry field. Pressing the Guide 
Button activates an Input Guide dialog box containing a help browser pane and input assistance. For 
continuous variables, the dialog facilitates entry of a large number of inputs by specifying the minimum input 
value, maximum input value, and increment value. For discrete variables the dialog contains a list of all valid 
inputs from which the user may select zero or more values. 

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional 
Worksheet, Run, Fuel Model, Moisture Scenario, Units Set, or capture files saved by the user. A Workspace 
corresponds to a single BehavePlus project, and each BehavePlus project should have its own Workspace. 
Workspaces are created by the File > Workspaces > New workspace and the Files > Workspaces 
> Clone current workspace commands. 
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2.6. Menus and Toolbar 
All BehavePlus operations are available from the menu bar. 

 
The more common operations, such as Module Selection or Calculate, may also be invoked from Toolbar 
buttons. Toolbar buttons and their equivalent Menu commands are shown below: 

Toolbar 

Buttons 
Definition Equivalent menu operation 

 Open a new Worksheet File > New

 Open a saved Run  File > Open run

 Print this Run File > Print

 Module selection Configure > Module selection

 Calculate this Run  File > Calculate

 Display first page Page > then select page #

 Display last page Page > then select page #

 Display previous page Page > then select page #

 Display next page  Page > then select page #

 Access User’s Guide  Help > Program help
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3. Worksheets 
 

A Worksheet is a form on which you enter input. Worksheets vary in appearance and content in response to 
the current module configuration: a SURFACE module configuration requires different inputs than a SPOT 
module configuration. 

Module selection, input options, and output variable selections determine BehavePlus configuration, which in 
turn defines the Worksheet appearance and content. 

A number of predefined example Worksheets are included in the BehavePlus installation. You may use these 
Worksheets as provided, or use them as starting points for your own configuration. Simply open an example 
Worksheet and proceed to change your Module selection, input options, and/or output variables. Once 
BehavePlus is configured the way you want, you may name and save it as a new Worksheet. During 
subsequent BehavePlus sessions you may load your custom Worksheet and BehavePlus is configured as 
expected. 

3.1. Worksheet layout 
A BehavePlus Worksheet is more than just an input form; it is the primary source of documentation about the 
Run. Worksheets include the following sections: 

Header – The Worksheet header shows the BehavePlus version number, useful for reporting bugs and 
determining if you have the most recent update. The header also includes the date and time of the last 
calculation and the page number, which lets you collate the correct pages after printing and spreading them 
out for further study. 

Border – The line surrounding the Worksheet body may be modified with the Configure > Appearance > 
Worksheet tab. 

Tabs – Zero, one, or more page tabs with labels along the right-hand margin of the Worksheet may be 
activated with the Configure > Appearance > Page Tabs tab. 

Documentation – This section lists all the currently selected modules and contains an entry field for the Run 
description. Additional documentation entry fields for training applications or for fire projection applications 
are optionally activated through Configure > Appearance > Worksheet tab. 

Input – This section contains the required input data entry fields identified by a short phrase and their units of 
measure. Each entry text box also has a Guide  button that may be pressed for input assistance. Entry text 
boxes are grouped under headings such as “Fuel/Vegetation”, “Fuel Moisture”, “Weather”, and “Terrain”. 

Run Options – This section documents some of the configuration settings that are selected for the 
Worksheet. 

Output Variables – This section lists all the selected output variables and their units of measure. This section 
may be toggled on/off in the Configure > Appearance > Worksheet tab. 

Notes – This section permits the user to enter free-field expository text. The user has control of the size of 
this section or whether it is displayed using the Configure > Appearance > Worksheet tab. 

Following is an example Worksheet: 
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3.1.1. Page Header 
The header of each page includes the version number of the BehavePlus program, the date and time of the 
calculation, and the page number. 

The date and time and page number can be used to correctly collate printed documents. 

 

3.1.2. Documentation 
Documentation is the header information on the Worksheet. The calculation modules that have been selected 
are listed. Documentation always includes a Description field. 
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Additional documentation lines can be added by selecting the Fire 
projection documentation and/or Training documentation 
check boxes from the Configure > Appearance > Worksheet tab. 

 
 

Selecting the Fire projection documentation check box adds the following input fields to the Worksheet:  

 
 
Selecting the Training documentation check box adds the following input fields to the Worksheet:  

 
Both options can be checked. 

3.1.3. Input section 
The required input variables and their units are displayed next to their entry fields. Fuel moisture variables 
that are not required have the text box shaded. In the example below, only 1-h fuel moisture is required for 
fuel model 1, because the other fuel categories are not included in the fuel model. 

The Guide  button for each input variable provides access to definitions and input assistance. Input variables 
are organized by logical association (rather than by calculation module). A table of all possible input variables 
by category is given in Appendix B. 
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3.1.4. Input codes 
The definition of valid input codes can be displayed on the 
Worksheet by selecting the Show input codes for all 
discrete variables check box on the Configure > 
Appearance > Worksheet tab. 

For example, with this option selected, fuel models names are given.  

 

 

3.1.5. Run options 
For clarification, Run options are given after the input variables. The user does not have the option of 
suppressing this information. 

 

3.1.6. Output variables 
Selected output variables and their units can be displayed at the end of 
the input Worksheet using the Configure > Appearance > 
Worksheet tab. 
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For example: 

 

3.1.7. Notes 
The Notes section of the Worksheet allows the user to enter a 
large amount of text associated with a Run. The user has the 
option of changing the number of lines provided for notes or 
even eliminating the notes section on the Configure > 
Appearance > Worksheet tab with the Show notes 
section check box and the Notes Lines spin box. 

3.1.8. Borders 
The border color and thickness on the Worksheet and output 
pages can be changed on the Configure > Appearance > 
Application tab using the Border Color drop-down list and 
the Border Width spin box. The border can be eliminated by 
entering a Border Width of 0. 
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3.1.9. Page Tabs 
Page tabs can be displayed along the right margin of the page. This is useful, for example, to identify Runs for a 
particular fire or training session that are subsequently bound in a three-ring binder or stored in filing folders. 
Page tabs can be added and defined with the Configure > Appearance > Page Tabs tab. 

 
 
Tabs per page -- The size of the tab depends upon the value selected in this spin box. Only one tab is actually 
displayed per page. If tabs per page is 4, the displayed tab occupies one-fourth the page height. If it is 10, the 
displayed tab occupies one-tenth the page height. As this number increases, the displayed tab size decreases. 

Tab position -- Determines the position of the displayed tab. Tab position 1 is always at the upper edge of the 
right margin. 

Tab text -- The text to appear on the tab. The text is centered within the tab and will therefore be truncated 
at both ends if it is too long. 

Tab text color -- A color is selected from the drop-down list. 

Tab font size -- Font point size is selected using this spin box. 

The above settings create the tab on the Worksheet below: 
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3.2. Loading a previously saved Worksheet 
A previously saved Worksheet can be loaded using 

• the File > New command, 

• or the  toolbar button. 

To see the Worksheets in the folder click on the  button to the left of the folder. 

To select a Worksheet either 

• double click on it,  
• or select and click the OK button. 

A set of Worksheets is supplied with the program in the “ExampleWorksheets” folder. A short description is 
given for each. See Appendix E for further description of the “ExampleWorksheets”. 
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3.3. The startup Worksheet 
The 0Startup.bpw Worksheet automatically loads whenever you start Behave Plus v2.0. This Worksheet is a 
special case. It is used as the starting place for selecting calculation modules. It shows no input or output 
variables, but it sets defaults for all Run settings as described in Appendix  D. The 0Startup.bpw Worksheet 
was used to initialize all of the example Worksheets. 

A Worksheet can be designed to meet specific needs by starting with the 0Startup.bpw Worksheet, selecting 
the desired modules, and changing options as needed. The startup Worksheet is named 0Startup.bpw to 
assure that it is the first selection of the Example Worksheets folder. 

3.4. Changing a Worksheet 
A Worksheet can be changed at any time by changing the selected modules and associated options. The 
changes are in effect only for the current session unless the revised Worksheet is saved. If a Worksheet that 
came with the program in the ExampleWorksheets folder is changed, the revised version must be saved in 
another Worksheet folder. 

3.5. Saving a Worksheet or a Run 
A Worksheet can be saved for later use with the File > save As > Worksheet command. The values 
entered onto the Worksheet are not saved.  

Save the Run, which is just a Worksheet with the defined input values, with the File > save As > Run 
command. 

See the Section 18.4, Save As, for more specific information.

22                         USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2003 



 

4. Modules 
 

Modules define a set of fire models for a Worksheet. Selection can be made with the Configure > Module 
command. 

The output variables that can be calculated by each module are given in the output variable table in Appendix 
B. 

 
 
Indentation indicates that the modules can be linked, which means that output from one module is used as 
input to the other. For example, if both SURFACE and SAFETY are selected, the modules are linked. Output 
from SURFACE is used as input to SAFETY. If only SAFETY is selected, all required input is entered by the 
user. A table of input variables and associated modules is given in Appendix B. 

Selection of modules, options, and output variables determines the required input variables. 

The Options… button is used to configure a modules input options or change the output variables it 
calculates. 

4.1. Input options 
Some modules offer options on alternate ways of specifying input. Others do not. For example, clicking the 
MORTALITY Options… button displays the “Mortality Module Options” dialog box with the Bark 
thickness is input option: 

 
The choice affects the input variables included on the Worksheet. If Bark thickness is specified on the 
worksheet is selected, the resulting Worksheet is as follows:  
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If Bark thickness is estimated from species and d.b.h. is selected, the resulting Worksheet is as 
follows: 

 
 
The SURFACE module has many input options. For readability, they are available on several tabs: 
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4.2. Output options 
The desired output variables are selected through the Options… button associated with each module.The 
selected output determines the input requirements. For example, input variables for the SPOT Module are 
different for each spotting source. 

 
Pause the mouse over the name of an 
output variable to see its description in 
the browser pane. For example, a pause 
over Spotting Distance from a Wind 
Driven Surface Fire in the SPOT 
Output Variables tab results in this 
browser pane. 
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This page is blank on purpose. 
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5. Entering input 
 

There are several ways to supply input to the BehavePlus program. Values can be typed directly into the input 
field, a choice can be made from a list of valid input values, a range of values can be specified, and for some 
variables, a selection can be made from a list of common choices. 

5.1. Shaded text boxes 
In some cases, input variables depend on values entered elsewhere on the Worksheet. When an input variable 
is not required, its text box is shaded. If a value is entered for a shaded text box, it is not used. 

5.2. Direct entry 
Values can be typed directly into the entry fields. Using the ‘Enter’ or ‘Tab’ keys move the cursor to the next 
field. The cursor can be moved to any field by a mouse click. 

Valid input values can be viewed by using the guide  button. 

5.3. Range of values 
More than one value can be entered for an input variable. Multiple values are separated by space or comma 
delimiters. 

  
For continuous variables the Guide button allows definition of a range of values by a 
constant increment. For example, midflame wind speed from 0 to 20 mi/h in steps of 
5 enters 0, 5, 10, 15, 20 on the Worksheet below. 

 

 

 

 

 
You do not need to always specify equal steps. You can enter several independent values separated by 
commas directly in the text box.  

5.4. Discrete variables 
When the Guide button is clicked for a discrete variable, the allowed selections are given in the center pane.  

Clicking the values selects them; you can select several values. This example shows the fuel model “Input 
Guide” dialog box. The Ok button enters them on the Worksheet. 
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5.5. Choices 
Although any value in the valid range can be entered for a continuous variable, in some cases common values 
can be entered with the Choices button. 

 
Clicking the Choices button displays commonly used values. 
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Selected values in the Slope Steepness choices. 
Clicking the Ok button enters them on the 
Worksheet.  

Selected values in the Slope Steepness choices. 
Clicking the Ok button enters them on the 
Worksheet.  

  

  

  

  

  

  

  

  

  

  

5.6. Linked input variables 5.6. Linked input variables 
In some cases input variables are directly associated with each other (an exception to the general rule). For 
example, in CONTAIN a line production rate, arrival time, and duration are assigned to each resource. In the 
following example, although multiple values are assigned to several input variables, those variables are linked 
together, so only a single calculation is done. 

In some cases input variables are directly associated with each other (an exception to the general rule). For 
example, in CONTAIN a line production rate, arrival time, and duration are assigned to each resource. In the 
following example, although multiple values are assigned to several input variables, those variables are linked 
together, so only a single calculation is done. 
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6. Table output 
 

When more than one value is assigned to one or two input variables, table output is produced. Tables are 
produced by selecting the Display table results checkbox in the “Calculate Results” dialog box that 
displays after selecting a File > Calculate command. 

 

6.1. Single value calculation 
When each variable is assigned only one value, a simple list of output is given. No table or graph is possible. 
For example: 
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6.2. Table output 
When more than one value is assigned to a variable, table output is produced. Each output variable is a 
specified column. For example, these Rate of Spread inputs produce the page 2 table below: 

 
 

 

6.3. Two way tables 
When more than one value is assigned to two variables, a two way table is produced. A table is produced for 
each selected output variable. Either variable can be specified as the row variable in the “Calculate Results” 
dialog box.  
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For example, with the above inputs this dialog box appears when you 
Calculate the Run.  
For example, with the above inputs this dialog box appears when you 
Calculate the Run.  

  
After selecting the Rate of Spread (maximum) option button and clicking 
the Ok button, the following tables are produced: 
After selecting the Rate of Spread (maximum) option button and clicking 
the Ok button, the following tables are produced: 

  

  

  

  

  

  

 

 
 
 

Changing the Table Row Variable to the Elapsed Time option button 
swaps the table columns and rows produces the following tables: 
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6.4. Table appearance 
Table shading can be changed with the Configure > Appearance > Tables tab. 

 
Selecting the Shade alternate table rows check box causes all output 
tables to have alternating rows shaded with a background color. This 
may improve the readability of wide tables. If the check box is cleared, 
tables are displayed without any row background color. 
The table row background color is selected from the Shade drop-down list. 

 

 

 

 

 

6.5. Multiple pages 
There is essentially no limit on the number of values that can be assigned to a variable. But the resulting table 
might not fit on a single page. For example, if rate of spread is calculated for values from 2 to 30 in steps of 2, 
and elapsed time is specified as the row variable, the table overlaps onto 3 pages.  
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The > or < symbols lined to the right and/or left of the table heading indicates that there are additional results 
for those variables in the indicated direction. 
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The box diagram at the upper left of the pages shows the relative position of the currently viewed page in the 
multipage table. 

In this example, however, it would make more sense to specify rate of spread as the row variable since it 
produces a table that fits on a single page as shown below: 

 



 

7. Graph output 
 

When more than one value is entered for one or two input variables, graphs can be produced. Graphs are 
viewed by selecting the Display Graph Results check box in the “Calculate Results” dialog box that 
displays after Calculate is requested. The form of the graph depends on whether the variables are continuous 
or discrete. The program automatically takes care of the differences for the user.  

 

7.1. Single variable graph 
When a range of values is entered for a single continuous variable, a graph is produced by calculating a fixed 
number of points (which can be changed in the Configure > Appearance > Graph Elements tab) over 
the entered range. Intermediate values entered on the Worksheet are ignored. For example, rate of spread 
entry of 5, 7, 9, 11, 13, 15 produces the same graph as rate of spread entry of 5, 15: 
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When a range of values is assigned to a discrete variable, a single calculation is performed for each value and a 
bar graph is produced. For example, the following is a comparison of surface fire spread rates for the standard 
13 fire behavior fuel models: 

 
 
 



BehavePlus v2.0 User’s Guide                                    Graph output 

 

7.2. Two variable graph 
When a range of values is assigned to two variables, a graph is produced. If both variables are continuous, the 
variable used for the X-axis can be selected from the “Calculate Results” dialog box. For example: 

 
 
In the “Calculate Results” dialog box clear the Display table results check box and accept the defaults in 
the Display graph results section: 
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Changing the X-Axis Variable to the Midflame Wind Speed (upslope) in the “Calculate Results” dialog 
box produces a very different graph: 
 

 
 
If a range is assigned to two variables, one of which is continuous and one discrete, the continuous variable is 
always on the X-axis. For example: 
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Now you no longer have the option of changing the X-Axis Variable 
in the “Calculate Results” dialog box.  

 
 
 
 
 
 
 

 

  
A graph is not possible when ranges are selected for two discrete variables. 
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7.3. Axis scales 

7.3.1. X-axis 
The X-axis variable and scale are the same for all graphs produced by a Run. The maximum for the x-axis is 
set to be the maximum value specified for the variable on the Worksheet.  

X Axis Origin and Y Axis Origin (minimum values) can be set for each as either zero or as the variable's 
minimum value as specified on the input Worksheet. The graph origin is set to (0,0) as the default.  

For example, consider the following Run: 
 

 
 

Options to define the origin of the graph are set through the Configure 
> Appearance > Graph Size tab.  

Setting both the X Axis Origin and Y Axis Origin to zero produces the 
following graph: 
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In the Configure > Appearance > Graph Size tab select Min Value from the X-Axis Origin drop-
down list to alter the graph appearance. 
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7.3.2. Y-axis 
The Y-axis scale normally differs between graphs produced by a Run since each graph is for a different output 
variable. For example, fireline intensity and flame length have different ranges of output and require a different 
Y-axis scale. By default the Y-axis is scaled to the maximum calculated output value for the variable to make 
best use of the graph area. 

When you want to compare graphs between Runs, different Y-axis scales can obfuscate the comparison. A 
rate of spread graph for fuel model 10, for example, usually has a narrower output range than for fuel model 5 
under the same conditions. To better compare calculated rate of spread graphs for the two fuel models, you 
can set both graphs to have the same Y-axis scale. 

The following Run is for fuel model 10, which has relatively low rates of spread.  
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With the X Axis Origin and Y Axis Origin set to zero, the rate of spread graph below is produced: 

 
To compare the results for fuel model 10 with the faster spreading fuel model 5, the scale for the fuel model 
10 Run is changed to match that produced by model 5. The calculated maximums are given for each of the 
selected output variables as a reference. 

In the “Calculate Results” dialog box select the Specify graph Y axis limits check box if you wish to 
modify the Y-axis ranges of the output graphs before they are displayed. 

 
This displays the “Graph Limits” dialog box, where you can change the Y-axis maximum for the variable Rate 
of Spread (maximum) to 40: 
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The comparison with the corresponding graph for fuel model 5 is now more straightforward. 
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7.4. Graph appearance 
The appearance of the graph can be changed through the Configure > Appearance > Graph Size and 
Configure > Appearance > Graph Elements tabs. 

 
 

 

 

 

USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2003 47



Graph output                                    BehavePlus v2.0 User’s Guide 

48                         USDA Forest Service General Technical Report RMRS-GTR-106WWW. 2003 

7.4.1. Graph Size 
 

The vertical graph height on the page is set with the Graph Size(%) spin box on 
the Configure > Appearance > Graph Size tab. 
Graphs are drawn starting at the upper left corner of the page and may occupy 25% 
to 100% of the page height. The default is 50%, as shown in the following graph. 
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Changing the Graph Size to 100% changes the above to the following graph: 
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7.4.2. Graph Title 

The graph title content is controlled using the Graph Title drop-down list 
on the Configure > Appearance > Graph Size tab. 
 
Selecting Short from the Graph Title drop-down list displays just the 
contents of the Worksheet Description text box as the title. Selecting 
Long displays the Description text box and the graph variables. 
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Using the above Run a graph with a short title (the default) looks like the following. 

 
 

Selecting Long from the Graph Title drop-down list on the Configure > 
Appearance > Graph Size tab adds more information to the title. 
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7.4.3. Graph colors 

Graph colors can be changed with the Configure > Appearance > Graph Elements tab. 

 
Colors are selected from the predefined drop-down lists.  

Background is the background color of the graph. 

Rainbow Colors sets the number of colors used to display graph lines or bars when Rainbow Colors is 
selected as the curve color. With three rainbow colors, the colors are red, green, and blue. If 4 colors are 
requested, four equally spaced hues from the color spectrum are used to display each graph line or bar in 
turn.  
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Bar ColorBar Color is used to fill graph bars. Selecting Rainbow Colors fills each bar with its own color. The number 
of rainbow colors is set by the Rainbow Colors spin box discussed above.  

Curve Color is used to draw graph lines. Selecting Rainbow Colors draws each line with its own color. The 
number of rainbow colors is set by the Rainbow Colors spin box discussed above.  

Axis Color is used to draw graph axis lines, tic marks, and axis labels.  

Gridline Color is for the graph grid lines. The default is yellow. 

 

 
Changing Rainbow Colors to 10 results in the following graph 
coloring: 
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7.4.4. Line widths 

Line widths can be changed using the Curve Width, Axis Width, and Gridline Width spin boxes on the 
Configure > Appearance > Graph Elements tab 

Curve Width sets the width of graph lines. 0 is the thinnest and 9 
thickest. 

Axis Width sets the width of axis lines drawn on the graph. 1 is thinnest 
and 9 thickest. 

Gridline Width sets the width of grid lines drawn on the graph. 1 is 
thinnest and 9 thickest. To prevent the display of any grid lines set 
Gridline Width to 0.  
The following graph uses the default line and color settings. 
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7.5. Number of curve points 7.5. Number of curve points 
The resolution of the curves can be changed with the Curve Points spin 
box on the Configure > Appearance > Graph Elements tab. 
The resolution of the curves can be changed with the Curve Points spin 
box on the Configure > Appearance > Graph Elements tab. 
  
The Curve Points spin box determines the number of points calculated 
for each curve in the graph. A straight-line segment is drawn between each 
pair of points. The default of 20 is visually adequate for most graphs. 
Requesting more points usually results in a marginal improvement in the 
visual appearance and requires more computation time. In cases where 
many curves are plotted and the calculation time is slow, reducing the 
number of curve points will speed things up. 

The Curve Points spin box determines the number of points calculated 
for each curve in the graph. A straight-line segment is drawn between each 
pair of points. The default of 20 is visually adequate for most graphs. 
Requesting more points usually results in a marginal improvement in the 
visual appearance and requires more computation time. In cases where 
many curves are plotted and the calculation time is slow, reducing the 
number of curve points will speed things up. 

  

  

  
Changing Curve Points from the default of 20 to 5 results in the 
following graph:  
Changing Curve Points from the default of 20 to 5 results in the 
following graph:  
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8. Diagram output 
 

In addition to the usual table and graph output, BehavePlus produces diagrams for the following output 
variables.  

• Wind/slope/fire spread direction diagrams from the SURFACE module 
• Fire characteristics chart from the SURFACE module 
• Shape of a point source fire from the SIZE module 
• Shape of a fire after suppression action from the CONTAIN module 

The option of diagram output is given in the lists of output variables. 

8.1. Wind/slope/spread direction 
Direction diagrams can help the user avoid confusion on directions for wind, slope, and spread directions. 
Direction input options are selected on the Configure > Module selection > SURFACE > Options… > 
Directions tab. 

Direction diagrams are produced with the Configure > Module selection > SURFACE > Options… > 
Outputs tab and selecting the Wind/Slope/Spread Direction Diagram check box. 

 
The diagrams differ according to the direction Input Options selected from the Configure > Module 
selection > SURFACE > Options… > Directions tab. The following shows the Input Option selection, 
the resulting Worksheet, the outputs table and diagrams. 
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The following illustrates the effect of selecting the Wind & spread directions are option button on the 
variables that are requested on the Worksheet.  
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8.2. Fire characteristics chart 
A fire characteristics chart diagram plots the relationship of rate of spread, heat per unit area, flame length, 
and fireline intensity. This option is a simplified plot and does not offer the user any display options. Axis 
scales are set automatically and points are labeled with simple numbers. In the future, BehavePlus will provide 
a Fire Characteristics Tool so that that the user can customize it for a specific need. 

Fire characteristics charts are produced with the Configure > Module selection > SURFACE > 
Options… > Outputs tab and selecting the Fire Characteristics Chart check box. 
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It is not necessary to select the four output variables that are plotted on the chart. 

The following shows the Worksheet and resulting output table and Fire Characteristics Chart. 
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The points labeled 1, 2, and 3 correspond to the three lines of the output table. Point 1 is for fuel model 2, 
point 2 for fuel model 5, and point 3 for fuel model 10. 
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In the case of two variables with multiple entry values a two-way table is produced: 
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The numbers on the chart correspond to the table cells in left-to-right and top-to-bottom order. In this 
example, Points 1 and 2 are for the first row of the result table (3% moisture) at the two wind speeds (7 and 
10 mi/h). Points 3 and 4 are for the second row of the result table (6% moisture) at the two wind speeds. 
Points 5 and 6 are for the third row of the result table (9% moisture) at the two wind speeds. 

8.3. Shape of a point source fire 
The elliptical shape of a point source fire can be plotted on the Configure > Module selection > SIZE > 
Options … > Outputs tab by selecting the Fire Shape Diagram check box 

 

 
For example, the following shows the Worksheet, output table, and Fire Shape Diagram. 
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BehavePlus v2.0 User’s Guide                                   Diagram output 

 
In addition to the shape diagrams, values for all of the selected output variables are given on each diagram. 
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When the SIZE Module is linked to the SURFACE Module, the wind vector is also shown on the diagram. 
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8.4. Containment shape 
The Containment Diagram shows fire perimeter at time of report, at initial attack, and constructed fireline at 
the time the fire was successfully contained or when it escaped initial attack (all resources exhausted before 
containment). The Containment Diagram is displayed by selecting the Containment Diagram checkbox 
from the Configure > Module selection > Containment > Options … > Output Variables tab. 

Select the Contain Status checkbox to output whether the fire was Contained or Escaped on the 
Containment Diagram. 
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9. View, print, & capture results 

9.1. View size 
The View > xx% command changes the size of your Worksheet and Run when viewed on screen. It does 
not affect the size of printed output. 

 

9.2. Windows 
When a Worksheet is first opened, the Run it represents is assigned a default name such as “unnamed01.bpr”, 
“unnamed02.bpr”, etc. This name is displayed on the title bar at the top of the BehavePlus application window. 

 
When you save a Run with the File > saveAs > Run command you should rename the Run. The name of 
the Run is then displayed in the title bar of the BehavePlus window. The complete path name for the Run is 
shown at the bottom of the BehavePlus application window. 

BehavePlus allows you to have any number of Runs open at once. Each Run has its own display window 
containing a Worksheet and possibly containing calculation results. Only one Run window is active at a time. 
The Windows menu item allows you to switch between Runs. It also allows you to cascade or tile the Runs 
within the BehavePlus window area. By default the Run windows are stacked on top of each other, so you 
only see the active Run. If your Run windows are already cascaded or tiled, you can make a Run active by 
clicking it. 

 
The following is a “tiled” display of the two Runs, one English, one metric. The English Run (unnamed01.bpr) is 
the active Run. 
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9.3. Pages 
While each Run has its own window, the window has one or more Pages. The first page(s) contain the 
Worksheet, and subsequent pages contain results tables, graphs, and diagrams. 

You can navigate between pages using the following toolbar buttons: 

 Go to the first page 

 Go to the last page 

 Go to the previous page 

 Go to the next page 

The keyboard navigation arrows will also move you from one page to the next. The Pages > command 
allows you to jump directly to a specific page. 
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Selection can be made from the list of pages with text descriptions and an icon indicating whether it is a table, 
graph, diagram, etc. 

9.4. Print 
You can print all pages or selected pages with the File > Print command. Alternatively, select Print from the 
shortcut menu when you right click inside a page. 

Whenever an output page is printed, it is good practice to print the associated Worksheet pages to avoid 
confusion on conditions for the Run. Printed pages are numbered and the date and time of the Run are 
included on the page header. 

9.5. Capture 
The currently displayed page can be captured and saved as a file in bmp, jpg, or png format with the File > 
Capture command. In the “Save As” dialog box enter a file name in the Capture File text box and select a 
file type from the Capture Description drop-down list. 

The saved file can then be edited with an image processor or inserted into other documents.  

In addition to the File > Capture command, you can use the ALT-Print Screen key or a screen capture 
utility (e.g. FullShot) to insert results from BehavePlus in other documents. The following steps are an example 
and do not constitute endorsement of specific software. 

• Startup BehavePlus, WORD word processor, and FullShot software. 
• On BehavePlus display, select the ‘R’ (for Region) in upper right hand of the window (put there by 

FullShot). 
• Use the cursor to select the desired area 
• Upon release of the mouse, FullShot opens with the selected image 
• CTRL-C to save it in a clip board 
• Go to the WORD document 
• CTRL-V to insert the image 

This is a quick and efficient method. There is no need to save the image in a file of its own. The image can be 
resized, cropped, or moved within WORD if desired. 
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10. Error checking 
 

If you do something that causes the program to crash, it is a program bug. Please report it through 
www.fire.org. 

When you do something in error, the program will tell you what the problem is and give you a chance to fix 
it. 
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11. Custom fuel models 
 

A fuel model is a set of values that describe a fuel type for the surface fire spread model. The standard fuel 
models are numbered 1 through 13. Additional fuel models, called Custom Fuel Models, can be developed, 
tested, saved, and used in BehavePlus. 

11.1. Using previously saved fuel models 
The 13 standard fuel models are always available. In order to use previously saved custom fuel models, the 
folder in which they are stored must be attached using the Configure > Fuel model set selection 
command. 

Click on a folder's  button to view its fuel model files. Each fuel model is stored in a separate file. 

 
Fuel model files are attached by attaching the folder in which they reside. This makes the fuel models in that 
folder accessible for use. It is not possible to select and attach individual fuel models; the entire folder must be 
attached. For example, all the southern California fuel models are attached by selecting the SoCalifornia folder. 
Once a fuel model folder is attached, the fuel models appear in the Fuel Model input guide and may be entered 
as fuel model input. 

After the SoCalifornia fuel model folder is attached, the Fuel Model 
input Guide  Button gives the following valid selections for the Fuel 
Model text box. 

 
To view the parameters of a particular fuel model, right-click on its name 
and select View parameters from the shortcut menu. 
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Folders (and files) with a paper clip icon are currently attached to (i.e., accessible for use by) BehavePlus in the 
current session. Once the Ok button is pressed, only the selected folders will have their files attached. 
Unselected folders will NOT have their files attached, even if they are currently marked as attached by the 
paper clip icons.  
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11.2. Defining and saving custom fuel models 
To change the Worksheet so that individual fuel parameters are entered in place of the fuel model code use 
the Configure > Module selection > SURFACE > Options… > Fuel and moisture tab and select 
the fuel parameters. option button. 

 
Or you can load the Example Worksheet FuelModeling.bpw, which as been set up this way, using the File > 
New command or  toolbar button. 
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Fuel model parameters can be typed directly into the parameter text boxes. Or they can be initiated with an 
existing fuel model by clicking the Initialize from a Fuel Model button on the Worksheet. 

 
The process of developing a custom fuel model is more complex that just filling in these blanks. It involves a 
process of evaluation and revision.  

Once the fuel model parameters are defined, a custom fuel model can be saved for later use with the File > 
Save as > Fuel model command. In the “Save As” dialog box enter a file name in the Fuel Model File 
text box and a short description in the Fuel Model Description text box. If more than one value is 
assigned to a fuel model parameter for testing purposes, the first value in the list is the one that is saved. 

Fuel models should be grouped in folders named by some logical association of meaning to the user. See 
Section 18.4 , Save As, for more information.



 

12. Moisture scenarios 
 

A moisture scenario is a set of fuel moistures for 1-h, 10-h, and 100-h dead fuel and herbaceous and woody 
live fuel. It is analogous to the fuel model concept in that a single code represents a set of moisture values. 
Fuel moisture scenarios may be developed, for example, to represent local 90-, 95-, and 97-percentile weather 
situations. The set of moisture scenarios used in the old BEHAVE TSTMDL fuel modeling program are 
provided with the BehavePlus program. 

Fuel model scenarios are for developing and comparing fuel models. They are not designed for fire behavior 
prediction, in which case fuel moisture values should be assigned directly. 

12.1. Using previously saved moisture scenarios 
A folder of moisture scenarios is attached using the Configure > moisture Scenario set selection 
command to open the “Moisture Scenarios” dialog box. 

Click on a folder's  to view its moisture scenario files. Each moisture scenario is stored in a separate file. 

 
Moisture scenario files are made available by attaching the folder in which they reside. This makes the 
moisture scenarios in that folder accessible for use. It is not possible to select and attach individual moisture 
scenarios; the entire folder must be attached. For example, the moisture scenarios that come with the 
BehavePlus program are attached by selecting the Tstmdl folder. Once a moisture scenario folder is attached, 
its moisture scenarios appear in the Moisture Scenario input guide. 

Set up the Worksheet to enter fuel moistures with moisture scenarios using the Configure > Module 
selection > SURFACE > Options… > Fuel & Moisture tab and select the Moisture is entered by 
moisture scenario. option button. 
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After the Tstmdl moisture scenario folder is attached, the 
Moisture Scenario Guide 
After the Tstmdl moisture scenario folder is attached, the 
Moisture Scenario Guide  button on the Worksheet 
gives the following valid selections for moisture scenarios. 
To view the parameters of a particular moisture scenario, 
right-click on its name and select View parameters from 
the context menu. 

 
 
 
 
 
 
 

 
When viewing folders (and files) in the “Moisture Scenario” dialog box, those scenarios with a paper clip icon 
are currently attached to (e.g., accessible for use by) the BehavePlus application. Once the Ok button is 
pressed, only selected folders will have their files attached. Unselected folders will NOT have their files 
attached, even if they are currently marked as attached by the paper clip icons. 
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12.2. Defining and saving moisture scenarios 
To define a Moisture Scenario first set the Worksheet to require individual fuel moisture values by selecting 
individual size class in the Configure > Module selection > SURFACE > Options… > Fuel & 
Moisture tab. 

 
Enter values for each size class on the Worksheet, even if that item is shaded. Other input text boxes don’t 
matter. 

 
Save the moisture scenario with the File > Save as > Moisture scenario command. In the “Save As” 
dialog box enter a file name in the Moisture Scenario File text box and a short description in the 
Moisture Scenario Description text box. See Section 18.4 , Save As, for more information on saving 
moisture scenarios. 
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13. Map applications 
 

BehavePlus allows calculation of slope steepness from map measurements and conversion of distances to map 
distances.  

Map scale is given as map representative fraction, which is the ratio of the number of units on the map 
between two points to the distance on the ground between the same two points. For example, if the map 
representative fraction is 1:24,000, then for each inch on the map there are 24,000 inches on the ground. 

Although any value can be entered, the “Input Guide” dialog box provides common map scales, available by 
clicking the Choices button. 

 

 

13.1. Slope from map measurements 
To set up a Worksheet to calculate slope steepness from measurements on a topographic map use the 
Configure > Module selection > SURFACE > Options… > Slope tab and select Slope steepness 
is calculated from map measurements. 

 
You can add the calculated slope steepness and intermediate values to the output list with the Configure > 
Module selection > SURFACE > Options… > Outputs tab. Select any or all of the Slope 
Steepness, Slope Elevation Change, or Slope Horizontal Distance check boxes. 
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The Worksheet then includes a Map section with text boxes for data. 

 

 
The contour interval is the difference in elevation between adjacent topographic contours on a topographic 
map. 

The map distance is the distance between two points on a map generally expressed in inches or centimeters. 

Number of contour intervals is a count between two points on a map.  

If only slope values are requested as output, then only Map input variables are requested. An existing 
Worksheet, SlopeMap.bpw, showing this configuration is found in the ExampleWorksheets folder. 
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13.2. Map distances 
To specify that output calculated distances should also be given in map units use the Configure > Module 
selection command and select the Display output distances in map units check box.  
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When a distance is calculated in SURFACE, SIZE, or SPOT and the Display output distances in map 
units check box is selected, a Map Representative Fraction (1x) text box is added to the Worksheet 
and map distances are added to the list of output variables. 

For example, when the Spread Distance check box is selected in the Configure > Module selection > 
SURFACE > Options… > Outputs tab the following Worksheet results: 
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14. Units 
 

Default units for BehavePlus are English for use in the United States It is easy to change all units to metric 
using the Configure > Units > metric command. 

If a user wishes to use something other than the units we have selected for English or metric, a custom set of 
units can be defined and saved for later use.  

The Units set also defines the number of decimal places displayed for each variable.  

Note that whenever a Worksheet or Run is saved, its current units of measure and display decimals are saved 
with it. The next time you open the Worksheet or Run, the units and decimal settings are restored. 

BehavePlus also provides a quick units conversion tool accessed with the Tools > Units converter 
command. 

14.1. English or metric 
The units set can be changed using the Configure > Units > English or metric or custom commands.  

Immediately upon change, the units on the active Worksheet and all values that have been entered are 
changed. 

Because units are stored with a Worksheet or Run, if units are changed to metric and then another 
Worksheet is loaded from the ExamplesWorksheets folder, with the File > New command, the new 
Worksheet will be English units. 

14.2. Custom units set 
Develop and save a custom units set using the “Units Editor” dialog box opened with the Tools > units 
Editor command. 

The Units editor controls the selection of units of measure and decimal places for the input, display, and 
output of variables. The selected units are then applied to the current Worksheet and saved as a custom units 
set.  

The units of measure initially displayed by the dialog are those in use for the current Worksheet.  

Select the desired units for each variable set. Rather than repetitiously having to enter units for every variable, 
they are grouped by type of unit of measure. Appendix C gives these groupings and their default English and 
metric units. 

Once you have defined and saved a custom units set, you can apply it to a Worksheet or Run with the 
Configure >Units > Custom command that opens the “Select A Units Set” dialog box. 

14.3. Number of decimal places 
In addition to setting units of measure, the “Units Editor” dialog box also allows you to change the number of 
digits displayed after the decimal place of all input and output variables. 

For example, fire area has 1 decimal place as the default. You may want to round area to the nearest acre by 
changing the number of decimals to 0. 
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14.4. Units conversion tool 
For all those times when somebody gives you an observed spread rate in furlongs/fortnight or you just need 
to know what the temperature is at that Canadian RAWS station just across the border, BehavePlus has a 
utility you can reach with the Tools > Units conversion tool command.  

 

In the “Units Conversion Tool” dialog box enter your known observation into the From Amount and 
From Units text boxes (12.3 meters per second in the above example). Then enter the desired units in the 
Into Units text box and click the Convert button to get your results (27.5143 miles per hour in the above 
example). 

In the help window of the “Units Conversion Tool” dialog box there is a list of all the available units. 
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15. Language 
 

The FIRE1 program of the old BEHAVE system was translated into several languages including Spanish and 
Chinese. We have designed BehavePlus to make the translation process easier. A Portuguese translation is 
included as an example. Instructions are available for translation to other languages. This translation process 
applies to the program interface itself, not to the help files.  

15.1. English or Portuguese 
To change the language from the default English to Portuguese use the Configure > Language > 
Portuguese (Portugal) command. 

 

15.2. Custom language set 
To develop a custom language set contact Collin Bevins at cbevins@montana.com. 
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16. Fine Dead Fuel Moisture Tool 
 

The “Fine Dead Fuel Moisture Tool” dialog box can be accessed with the Tools > Fine dead fuel 
moisture command. 

 
This tool is an automation of the daytime tables from Rothermel (1983). Selections are made through drop 
down lists. As soon as a change is made, the results are displayed. Since these tables are not based on 
equations, they can’t effectively be incorporated as a module into BehavePlus. 
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17. Sun-Moon Calendar Tool 
 

The “Sun-Moon Calendar” dialog box is opened with the Tools > Sun-moon calendar command. 

 
This tool allows you to specify any month of any year at a location on the globe and generate a calendar of 
sun-rise, sun-set, civil dawn, civil dusk, moon-rise, and moon-set times in table or calendar format. It can also 
display a table of equinox, solstice, and moon phases for the year. 

The calendar tool also includes a large database of named places within the United States so you can select a 
location by name rather than by coordinates. 
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18. File management 

18.1. Workspaces 
BehavePlus has a proscribed file system structure; all files must be located in specific subdirectories. The 
parent directory of this file structure and all its subdirectories and files are collectively known as a Workspace. 

A Workspace is a complete subdirectory tree containing all required BehavePlus files plus any additional 
Worksheet, Run, Fuel Model, Moisture Scenario, Units Set, or screen capture files saved by the user. A 
Workspace corresponds to a single BehavePlus project, and each BehavePlus project should have its own 
Workspace. Workspaces are created with either the File > Workspaces > New Workspace or Clone 
current workspace commands. 

When BehavePlus is first installed it has a single Workspace called the “DefaultDataFolder”. This is the default 
current Workspace every time BehavePlus is started. 

 
We recommend you create a new Workspace using the File > Workspaces > New Workspace 
command for every BehavePlus project you’re working on. A project can be a collection of fire behavior 
projections for a wildfire or a fuels analysis for an environmental impact statement. The new, “pristine” 
Workspace is automatically populated with all example Worksheets, example Runs, and standard and 
predefined custom fuel models just like the “DefaultDataFolder” Workspace. 

Alternatively, you may clone an existing Workspace with the File > Workspaces >Clone current 
workspace command to copy all of the current Workspace into a new Workspace, including all Run, Units 
Sets, custom Fuel Models, and custom Moisture Scenarios. 

The Workspace concept provides the following benefits: 

• All files pertaining to a specific training class, fire situation, or other project are segregated into their 
own file structure. 

• Workspaces are easily backed up or copied onto removable media using either the File > 
Workspaces > Clone current workspace command or Windows Explorer. 

• BehavePlus has self-validation tests and informs you whenever it is missing required files. 

• BehavePlus knows where to find all custom Fuel Models and Moisture Scenarios and include them in 
Guide Button dialog boxes. 
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We recommend using a compression utility such as WinZip, PKZip, or gzip when emailing or moving a 
Workspace over the Internet as compression significantly reduces BehavePlus file sizes. 

A list of three letter file extensions used by BehavePlus is shown in the following table. These extensions are 
automatically attached to the files you create in BehavePlus. 

File extension File type Folder 

.bpf Custom fuel models FuelModelFolder 

.bpm Moisture scenarios MoistureScenarioFolder 

.bpw Worksheets WorksheetFolder 

.bpr Runs RunFolder 

.bpu Custom Units Sets UnitsSetFolder 

.exe Executable program file  BehavePlus 

.png Portable network graphic image format MyScreenCaptures 

.bmp Bitmap graphic image format MyScreenCaptures 

.jpg JPEG graphic image format MyScreenCaptures 

.xml Extensible Markup Language Various places 

18.2. Load a Worksheet 
A previously saved Worksheet is loaded with the File > New command, which opens the “Select a 
Worksheet” dialog box. 

The Worksheet is ‘blank’ in that none of the input variables have been assigned values. But all of the 
associated options are still part of the Worksheet (e.g., graph appearance).  

18.3. Load a Run 
A previously saved Run is loaded through File > Open Run command, which opens the “Select a Run” dialog 
box. 

A Run is a Worksheet with valid values assigned to all input variables. Calculated values, tables, graphs, and 
diagrams are not saved. These are generated with the File>Calculate command. 

18.4. Save as… 
A sub-menu of the File > saveAs command offers several choices of what to save from the active 
Worksheet: 

• Run 
• Worksheet 
• Fuel model 
• Moisture scenario 

A Run can be saved only if all valid values have been assigned to all variables on the Worksheet. The Run can 
be opened at a later time using the File > Open Run command or the  toolbar button. 

When a Worksheet is saved, it is saved without any values assigned to input variables. The Worksheet can be 
opened at a later time using the File > New command or the  toolbar button.  

Before saving a fuel model make sure the SURFACE module check box is selected and the fuel parameters 
checkbox is selected in the Fuel is entered as section of the SURFACE > Options… > Fuel & 
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Moisture tab. Valid values must be assigned to each fuel model parameter. To make custom fuel models 
available at a later time use the Configure > Fuel model set selection command. 

Before saving a moisture scenario make sure the SURFACE module is selected and the individual size 
class check box is selected in the Moisture is entered by section of the SURFACE > Options… > 
Fuel & Moisture tab. Valid values must be assigned to each size class, even those that are shaded. To make 
a moisture scenario available use the Configure > moisture Scenario set selection command. 

The following example saves a Worksheet. The process is the same for other file types. In all cases, the File > 
saveAs command requests input of folder name, file name, and file description in the “Save As” dialog box. 

 
In this case, the Worksheet Folder field is initially set to MyWorksheets. To create a new folder, simply type a 
new name into the Worksheet Folder text box: TestFolder in the above example. You are asked to enter a 
Worksheet folder description. The folder description subsequently appears in the file selection dialog box as a 
reminder of its contents. The Worksheet description is initially set to whatever is in the Description text 
box on the Worksheet. When saving a Worksheet, you should assure that it describes the blank Worksheet, 
not the specific Run. 

18.5. Deleting Files & Folders 
Files and folders in a BehavePlus Workspace are deleted using Windows Explorer. However you should only 
delete files and folders you create, not any of the files and folders BehavePlus creates for the Workspace. 
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19. Help 
 

Help features are a primary feature of BehavePlus. The Users Guide is available from the menu bar, and all 
dialogs and wizards include a help browser pane. Input fields include a Guide  button for help in entering 
range inputs or selecting one or more discrete choices.  

19.1. Browser pane help 
The right-hand pane of many BehavePlus dialog boxes is a help browser. These can be printed by right-clicking 
in the help window to display a shortcut menu and selecting the appropriate command. 

 
It includes a description of input variables when the guide button associated with the variable on the 
Worksheet is clicked. It includes a description of output variables when the cursor is held over a variable 
name on the list of possible output variables for a MODULE, reached through Configure > Module 
selection > MODULE > Options… > Outputs tab. 

For each variable, information includes 

• Short description 
• Input to modules 
• Output from modules 
• More Information 
• See also 
• Links 
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19.2. Guide button 
Help on entering a specific Worksheet variable is available by pressing the Guide  button next to each 
Worksheet entry field to activate an “Input Guide” dialog box containing a help browser pane and input 
assistance. For continuous variables, the dialog facilitates entry of a large number of inputs by specifying the 
minimum input value, maximum input value, and increment value.  

 

Additional values are sometimes displayed by clicking the Choices button where available in the “Input 
Guide” dialog box. 

 
For discrete variables the dialog contains a list of all valid inputs from which the user may select values. 

19.3. User’s Guide 
This User’s Guide can either be printed or accessed interactively using a PDF viewer such as Adobe Acrobat 
Reader. It serves as the online help for BehavePlus and can be opened with the Help > Program help 
command. When viewed with the Adobe Acrobat Reader, the contents at the left provide access to the 
section in question. 
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Appendix A: Version Comparison 

Version 1 and Version 2 

Following are significant differences between BehavePlus version 1.0 and version 2.0. Minor changes are 
not listed here. 

• Safety zone size model added as a new SAFETY module 

• Containment model added as a new CONTAIN module. This is a new model that allows multiple 

resources to make direct or parallel attack. 

• Probability of ignition by lightning model added to the IGNITE module 

• Two fuel weighting, three methods added to the SURFACE module  

• Dynamic palmetto-gallberry fuel model added to the SURFACE module 

• Size diagram output added to SIZE 

• Contain diagram output in CONTAIN 

• Direction diagram added to SURFACE 

• Fire characteristics chart diagram output added to SURFACE 

• Fine dead fuel moisture added as a new tool 

• A Run Option section is added to the worksheets for clarification 

• The contents of the Notes section on example worksheets is blank. The description of the 
worksheet that was there for version 1 is not necessary, especially with the addition of the Run 

Options section.  

• The ‘Standard’ worksheet folder that was supplied with version 1 of the program is called the 

ExampleWorksheets folder in version 2 to better reflect what it is. The worksheets in that folder 
are just some that the developers put together. The term ‘standard’ gave them significance that 

they didn’t deserve.   

• The Blank.bpw Worksheet that was in version 1 is called the 0Startup.bpw Worksheet in version 
2 to better reflect what it is—the worksheet to use as a startup in selecting calculation modules.  
The ‘0’ (zero) as a first character of the file name puts it as the first item on the list for easy 

selection. 
• The program now automatically loads the 0Startup.bpw worksheet upon initiation. This saves 

some steps if the worksheet is set up by module selection. If a previously saved worksheet is 

desired, it is selected and loaded as before with the File > New command. 

• The Fuel model guide button gives you access to the photographs and descriptions in Anderson 

(1982) “Aids to selecting fuel models” and to the selection key in Rothermel (1983) “How to 
predict the spread and intensity of forest and range fires”  

• The Program Help and the Users Guide for version 1 have been replaced by a single, new 
document—a users guide in PDF format that can be both printed and accessed online for specific 

help. 

• A Language option has been added. Portuguese is provided as an example. 

• Additional Workspace options aid in file management. 

• Graph Y-axis are now user-scalable. 

BEHAVE and BehavePlus 

 
The old BEHAVE fire behavior prediction and fuel modeling system is a set of five DOS programs, three 

of which were first available in 1984.  The whole look and feel of the BehavePlus fire modeling system is 
different, using modern user interface technology 
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Following are some specific differences that will be of interest to users of the old BEHAVE system. 

• BehavePlus is one program. The old BEHAVE was five programs (FIRE1, FIRE2, RXWINDOW, 
NEWMDL, TSTMDL). The separation was due to computer limitations at the time and an 

extended development period. 

• BehavePlus gives the user control of input options that were fixed on the old BEHAVE. For 

example, in the old BEHAVE, the DIRECT module required direct input of fuel moisture by size 
class, midflame wind speed, and direction of wind and spread with respect to upslope. The SITE 

module calculated fine fuel moisture and requested input of 20-ft wind speed, exposure to the 
wind, and direction of wind and spread. The DISPATCH module requested dead and live fuel 
moisture, 20-ft wind speed and wind adjustment factor. Calculations were for upslope spread 

with the wind.  In the TSTMDL program, fuel moisture was specified by category. In contrast, the 
BehavePlus SURFACE module allows users to specify the method of entry for fuel moisture, 
wind speed, and directions.  

• In BEHAVE only continuous variables could be assigned more than one value for a maximum of 
seven values. For example, wind speed could be assigned a range of values, but fuel model could 

not. BehavePlus allows multiple input values for every variable and there is essentially no limit to 
the number of values. Table output is carried over to multiple pages if necessary. 

• BehavePlus produces graphs and diagrams as well as tables. The primary output of the old 

BEHAVE was tables. Crude graphs were produced using characters. 

• The fuel modeling portion of the old BEHAVE consisted of the NEWMDL and TSTMDL 
programs. The features in NEWMDL are not in BehavePlus. The TSTMDL fuel model testing 

methods are in BehavePlus. 

• BehavePlus does not include the fine dead fuel moisture model in MOISTURE and SITE modules 

in the FIRE2 program of BEHAVE. A better moisture model based on hourly weather data has 
been developed and is being incorporated into the National Fire Danger Rating System (NFDRS) 
and the FireFamily Plus program. Eventually it will be available for fire behavior calculations in 

BehavePlus. BehavePlus offers the fuel moisture tables as a tool. 

• The CONTAIN module of BehavePlus is different from that used in BEHAVE. The old model had 

a mathematical problem that occasionally surfaced. BehavePlus uses a model by Fried and Fried 
(1996) that offers the application of multiple resources with various productivity rates and arrival 
times, and direct or parallel attack at either the fire head or rear. BehavePlus does not offer the 

option of reverse calculation that was in the old BEHAVE (i.e. given a final fire size, what is the 
required line production rate). 

• The RxWindow program is not and will not be part of BehavePlus. Reverse calculation becomes 
more difficult (essentially impossible) as models are added. The plan is to provide a new method 

of table shading to aid in prescribed fire planning. 

• The equations in the MORTALITY module in BehavePlus have been updated to match those of 

FOFEM. Many new tree species have been added. 

• BehavePlus lists input values by category (Fuel/Vegetation, Weather, …) rather than by module 

(DIRECT, SIZE, …) as was done in the old BEHAVE. 

• In BehavePlus users select the output variables to be displayed. In BEHAVE the output list was 

fixed. 

• Map distance calculation was a stand-alone feature in BEHAVE. It is integrated into BehavePlus. 

• BEHAVE asked users whether they were using a computer with a screen. The program could be 

run in either WORDY or TERSE mode. BehavePlus assumes it is being run on a 21st century 
personal computer. 
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Appendix B: Input and Output Variable Tables 

Each input variable in BehavePlus, version 2, is listed in the table according to category. ‘I’ (for Input) in a 

Module column indicates that it is a possible input for that module. In some cases an input variable may 
also be an output variable, indicated by ‘O’ (for Output). It depends on the selected modules, input 
options, and output variables.   

For example, note that  

• Midflame wind speed is an input to SURFACE under the input option Wind speed is entered 

as midflame height. However, it is an output variable if Wind speed is entered as 20-ft 

wind and wind adjustment factor is selected. 

• Rate is spread is an output from SURFACE and an input to SIZE.  If both SURFACE and SIZE are 

selected, the rate of spread from SURFACE is automatically used in SIZE. If only SIZE is selected, 
then the user must input values for rate of spread. 

• Temperature is used only in SCORCH and RH, it is not used for the spread rate and intensity 
calculations in SURFACE. 

• These tables also give the English and metric units and number of decimal places and the output 

variables selected for display initiated by the 0Startup.bpw worksheet. (See Appendix D.) 
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 

 

 
 

Metric 
Range/Units Notes 

 
Fuel / Vegetation 

             

Fuel model I         D N/A N/A  
First fuel model I         D N/A N/A For two fuel models 
Second fuel model I         D N/A N/A “ 
First fuel model coverage I         C 0-100% 0-100% “ 
1-h fuel load I          

C 
 

0.0-30.49 ton/ac 
 

0.0-68.35 tonne/ha 
Fuel model 
parameter 

10-h fuel load I         C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha “ 
100-h fuel load I         C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha “ 
Live herbaceous fuel load I         C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha “ 
Live woody fuel load I         C 0.0-30.49 ton/ac 0.0-68.35 tonne/ha “ 
1-h surface area / vol ratio I         C 109-4,000 ft2/ft3 358-13,123 m2/m3 “ 
Live herb surface area / vol 
ratio 

I         C 109-4,000 ft2/ft3 358-13,123 m2/m3 “ 

Live woody surface area / vol 
ratio 

I         C 109-4,000 ft2/ft3 358-13,123 m2/m3 “ 

Fuel bed depth I/O         C 0.05 to 10.0 ft 0.02-3.05 m “ 
output for P-G 

Dead fuel moisture of 
extinction 

I         C 5 – 100% 5 – 100% Fuel model 
parameter 

Dead fuel heat content I         C 6,000-12,000 BTU/lb 13,967-27,934kJ/kg “ 
Live fuel heat content I         C 6,000-12,000 BTU/lb 13,967-27,934kJ/kg “ 
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Fuel / Vegetation (cont.) 

             

Palmetto-gallberry age of 
rough 

I         C 1-25 years 1-25 years For dynamic 
palmetto-gallberry 

Height of understory I         C 1-6 ft 0 -2 m “ 
Palmetto coverage I         C 15-85 % 15-85 % “ 
Overstory basal area I         C 30-110 ft2/ac 6.8-25.3 m2/ha “ 
Mean cover height     I     C 0 –300 ft 0 –91 m  
Tree height     I  I   C 10 – 300 ft. 3 – 91 m  
Crown ratio       I   C 0.1 – 1.0 0.1 – 1.0  
Mortality tree species     I  I   D (206 species) (206 species)  
Spot tree species     I     D (14 species) (14 species)  
D.B.H.     I  I   C 5 – 40 in 13 – 102 cm  
Bark thickness       I/O   C 0.1 – 2.0 in 0.3 – 5.1 cm  
Lightning ignition fuel type        I  D PPL, PWC, PWD, 

PWS, LPD, DFD, 
ESH, PMC 

PPL, PWC, PWD, 
PWS, LPD, DFD, 
ESH, PMC 

 

Lightning duff and litter 
depth 

       I  C 0-12 in 0-30 cm  
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Fuel Moisture 

             

Moisture scenario          D N/A N/A  
1-h moisture I       I  C 1 – 60% 1 – 60% Fuel moisture 

scenario parameter 
10-h moisture I         C 1 – 60% 1 – 60% “ 
100-h moisture I       I  C 1 – 60% 1 – 60% “ 
Live herbaceous moisture I         C 30 – 300% 30 – 300% “ 

Live foliage for P-G 
Live woody moisture I         C 30 – 300% 30 – 300% “ 

Live stemwood for 
P-G 

Dead fuel moisture I       I  C 1 – 60% 1 – 60% Used for 1-h, 10-h, 
100-h 

Live fuel moisture I         C 30 – 300% 30 – 300% Used for live 
herbaceous and 
woody 
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Weather 

             

Midflame wind speed I/O    I     C 0 – 60 mi/h 0.0 – 96.6 km/h  
20-ft (or 10-m) wind 
speed 

I   I      C 0 – 99 mi/h 0.0 – 159 km/h  

Wind adjustment factor I         C 0.1 – 1.0 0.1 – 1.0  
Effective wind speed O  I       C 0 – 60 mi/h 0.0 – 96.6 km/h  
Wind direction 
  (from North) or 
  (from upslope) 

I         C 0 – 360 deg 0 – 360 deg Reference depends 
on input option 
selections 

Air temperature     I  I I  C -40 – 120 deg F -40 – 49 deg C  
Wet bulb temperature        I  C -40 – 120 deg F -40 – 49 deg C  
Dew point temperature        I/O  C -40 – 120 deg F -40 – 49 deg C  
Fuel shading from the sun       I   C 0 – 100% 0 – 100% by cloud or canopy 
Lightning strike type       I     D +,  -, or unknown +, -, or unknown  
 
Terrain 

             

Slope steepness I         C 0 – 45 deg 
0 – 100% 

0 – 45 deg 
0 – 100% 

 

Aspect I         C 0 – 360 deg 0 – 360 deg  
Site elevation        I  C -1,000-30,000 ft -305 – 9,144 m  
Ridge-to-valley elevation 
difference 

   I      C 0 – 4,000 ft 0 – 1,219 m  

Ridge-to-valley 
horizontal distance 

   I      C 0 – 4.0 mi 0 – 6.4 km  

Spotting source location    I      D RT, MW, VB, ML RT, MW, VB, ML  
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Fire 

             

Rate of spread 
(maximum) 

O  I I      C 0 – 500 ch/h 0.0-167.6 m/min Head fire 

Flame length O I   I I    C 0 – 200 ft 0 – 61 m Worst-case estimate 
of flame height for 
SAFETY 

Fireline intensity O     I    C 0 – 10,000 BTU/ft/s 0 – 34,641 kW/m  
Flame height from a 
burning pile 

    I     C 0 – 100 ft 0 – 30.5 m  

Spread direction 
  (from North) or  
  (from upslope) 

I/O         C 0 – 360 deg 0 – 360 deg Reference depends 
on input option 
selections 

Number of torching trees     I     C 0 – 30 0 - 30  
Scorch height      O I   C 0 – 200 ft 0 – 61 m  
Elapsed time I  I       C 0.5 – 8.0 h 0.5 – 8.0 h From ignition/start 
Fire size at report   O I      C 0.1-100 ac 0.0-40.5 ha ‘area’ from SIZE 
Length-to-width ratio   O I      C 1-7 1-7  
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Input Variables and Modules 

 

Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Map 

             

Map representative 
fraction (1:x) 

I  I  I     C 1,980 – 1,013,760 1,980 – 1,013,760  

Contour interval I         C 1  - 1000 ft 0.3 – 304.8 m  
Map distance I         C 0.1 – 100 in 0.3 – 254 cm  
Number of contour 
intervals 

I         C 1 – 100 1 - 100  
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Input variable 
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English 
Range/Units 
 

 
 
Metric 
Range/Units Notes 

 
Suppression 

             

Suppression tactic    I      D Head or Rear Head or Rear  
Line construction offset    I      C 0-100 ch 0-2012 m 0 = direct attack 

else parallel attack 
Resource name    I      D N/A N/A Entry for each 

resource 
Resource line production 
rate 

   I      C 1-200 ch/h 20.1-4023.4 m/h “ 

Resource arrival time    I      C 0-8 h 0-8 h “ 
Resource duration    I      C 0.0-10 h 0.0-10 h “ 
Resource base cost    I      C 0-500,000 0-500,000 “ 
Resource hourly cost    I      C 0-500,000 0-500,000 “ 
Number of personnel  I        C 1-200 1-200 Integer 
Area per person  I        C 10-100 ft2 .93-9.3 m2  
Number of heavy 
equipment 

 I        C 0-10 0-10 Integer 

Area per  heavy 
equipment 

 I        C 100-500 ft2 9.3-46.5 m2  

I = Input 
O = Output 
I/O = Input or Output depending on the selected modules and options 
 
C = Continuous variable 
D = Discrete variable 
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Output Variables and Modules 

Output variable 
 
 

Default output 
variable 

 
 

English 
Units 

 
 

Metric 
Units 

Notes 

 
SURFACE 

    

Rate of spread X ch/h m/min  
Heat per unit area X BTU/ft2 KJ/m2  
Fireline intensity X BTU/ft/s KW/m  
Flame length X ft m  
Reaction intensity  BTU/ft2/min KW/m2  
Direction of maximum spread X degrees degrees  
Spread distance  ch m Can be map distance 
Midflame wind speed  mi/h km/h  
Effective wind speed  mi/h km/h  
Maximum reliable wind speed  mi/h km/h  
Maximum wind exceeded? X Yes or No Yes or No  
Slope steepness  percent percent  
Slope elevation change  ft m  
Slope horizontal distance  ft m  
Wind/slope/fire direction diagram  N/A N/A  
Fire characteristics chart  N/A N/A  
P-G dead fine fuel load  ton/ac tonne/ha  
P-G dead medium fuel load  ton/ac tonne/ha  
P-G dead foliage fuel load  ton/ac tonne/ha  
P-G live fine fuel load  ton/ac tonne/ha  
P-G live medium fuel load  ton/ac tonne/ha  
P-G live foliage fuel load  ton/ac tonne/ha  
P-G litter fuel load  ton/ac tonne/ha  
Fuel bed depth  ft m  
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Output Variables and Modules 

Output variable 
 
 

Default output 
variable 

 
 

          English 
            Units 

 
 

Metric 
Units        Notes 

 
SAFETY 

    

Safety zone separation distance X ft m  
Safety zone size X ac ha  
Safety zone radius  ft m  
 
SIZE 

    

Area X ac ha  
Perimeter X ch m  
Length-to-width ratio  N/A N/A Real number 
Forward spread distance  ch m Can be map distance 
Backing spread distance  ch m Can be map distance 
Fire length  ch m Can be map distance 
Maximum fire width  ch m Can be map distance 
Fire shape diagram  N/A N/A  
 
CONTAIN 

    

Time from report X h h To containment or 
escape 

Contain status X Contained, Withdrawn, or 
Exhausted 

Contained, Withdrawn, 
or Exhausted 

Either withdrawn or 
exhausted is escaped 

Contained area X ac ha At containment. 
If escape, area = 0 

Fireline constructed X ch m  
Number of resources used X N/A N/A Integer 
Cost of resources used  N/A N/A  
Containment diagram  N/A N/A  
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Output Variables and Modules 

Output variable 
 
 

Default output 
variable 

 
 

         English 
          Units 

 
 

Metric 
Units 

Notes 

 
SPOT 

    

Spotting distance from torching trees X mi km  
Spotting distance from a burning pile  mi km  
Spotting distance from a wind-driven surface 
fire 

 mi km  

 
SCORCH 

    

Scorch height X ft m  
 
MORTALITY 

    

Bark thickness  in cm  
Tree crown length scorched  ft m  
Tree crown volume scorched  percent percent  
Probability of mortality X percent percent  
 
IGNITE 

    

Probability of ignition from a firebrand X percent percent  
Probability of ignition from lightning  percent percent  
 
RH 

    

Relative humidity X Percent Percent 
 

 

Dew point temperature  deg F deg C  
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Appendix C: Units Editor 
 

Variable English units No. 
Dec. 

Metric units No. 
Dec. 

 
Fuel and Vegetation Units 

    

Fuel Load  
• 1-h fuel load 
• 10-h fuel load 
• 100-h fuel load 
• Live herbaceous fuel load 
• Live woody fuel load 
• Palmetto-gallberry dead fine 

fuel load 
• Palmetto-gallberry dead 

medium fuel load 
• Palmetto-gallberry dead 

foliage fuel load 
• Palmetto-gallberry live fine 

fuel load 
• Palmetto-gallberry live 

medium fuel load 
• Palmetto-gallberry live 

foliage fuel load 
• Palmetto-gallberry litter fuel 

load 

ton/ac 2 tonne/ha 2 

Surface Area/Vol Ratio  
• 1-h surface area/volume 

ratio 
• Live herb surface 

area/volume ratio 
• Live woody surface 

area/volume ratio 

ft2/ft3 0 m2/m3 0 

Understory Fuel Depths  
• Fuel bed depth 
• Palmetto-gallberry height of 

understory 

ft 2 m 2 

Ground Fuel Depth 
• Lightning duff and litter 

depth 

in 1 cm 0 
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Variable English units No. 

Dec. 
Metric units No. 

Dec. 
Fuel Moisture & Extinction  
Moisture 

• Dead fuel moisture of 
extinction 

• 1-h moisture 
• 10-h moisture 
• 100-h moisture 
• Live herbaceous moisture 
• Live woody moisture 
• Dead fuel moisture 
• Live fuel moisture 

percent 0 percent 0 

Fuel Heat Content  
• Dead fuel heat content 
• Live fuel heat content 

Btu/lb 0 kJ/kg 0 

Tree Height & Mean Cover Height  
• Mean cover height 
• Tree height 
• Tree crown length scorched 

ft 0 m 0 

Tree D.b.h. and Bark Thickness  
• D.b.h. 
• Bark thickness 

in 0 cm 0 

Coverage  
• First fuel model coverage 
• Palmetto coverage 

percent 0 percent 0 

Basal Area  
• Palmetto-gallberry overstory 

basal area 

ft2/ac 0 m2/ha 0 

 
Weather Units 

    

Wind Speed  
• Midflame wind speed 
• 20-ft wind speed 
• 10-m wind speed 
• Effective wind speed 
• Maximum reliable wind 

speed 

mi/h 1 km/h 1 

Temperature  
• Air (dry bulb) temperature 
• Wet bulb temperature 
• Dew point temperature 

oF 0 oC 0 

Relative Humidity  
• Relative humidity 

percent 0 percent 0 

Shading from sun percent 0 percent 0 
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Variable English units No. 

Dec. 
Metric units No. 

Dec. 
 
Terrain & Spotting Units 

    

Slope Steepness  
• Slope steepness  

(Note: these units only apply when 
the SURFACE Module option Slope 
is specified as percent is selected. 
When Slope is specified as 
degrees is selected, all slope units 
are degrees.) 

percent 0 percent 0 

Site Elevation & Ridge-to-Valley 
Elevation Difference  

• Site elevation 
• Ridge-to-valley elevation 

difference 
• Elevation change (slope 

rise) 
• Horizontal distance (slope 

reach) 

ft 0 m 0 

Spotting Distance & Ridge-to-
Valley Horizontal Distance  

• Spotting distance from 
torching trees 

• Spotting distance from a 
burning pile 

• Spotting distance from a 
wind-driven surface fire 

• Ridge-to-valley horizontal 
distance 

mi 1 km 1 

 
Fire & Effects units 

    

Rate of Spread ch/h 1 m/min 1 
Fire Heat Per Unit Area Btu/ft2 0 kW/s/m2 0 
Fireline Intensity Btu/ft/s 0 kW/m 0 
Flame Length & Scorch Height  

• Flame length 
• Flame height of a burning 

pile 
• Scorch height 

ft 1 m 1 

Fire Reaction Intensity Btu/ft2/min 0 kW/m2 0 
Spread Distance  

• Spread distance 
• Forward spread distance 
• Backing spread distance 
• Fire length 
• Maximum width of fire 

ch 1 m 1 
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Variable English units No. 

Dec. 
Metric units No. 

Dec. 
Fire Area  

• Area 
• Contained area  
• Fire size at report 

ac 1 ha 1 

Fire Perimeter ch 0 m 0 
Probability of Mortality & Crown 
Volume Scorched 

• Tree crown volume 
scorched 

• Probability of mortality 

percent 0 percent 0 

Probability of Ignition  
• Probability of ignition from a 

firebrand 
• Probability of ignition from a 

lightning strike 

percent 0 percent 0 

 
Time & Map Units 

    

Time  
• Elapsed time 
• Resource Arrival Time 
• Resource Duration 
• Time from Report 

h 1 h 1 

Contour Interval  
• Map contour interval 

ft 0 m 1 

Map Distance  
• Map distance (for slope 

calculation) 
• Fire spread map distances 
• Fire length and width map 

distances 
• Spotting map distance from 

torching trees 
• Spotting map distance from 

a burning pile 
• Spotting map distance from 

a wind-driven surface fire 

in 2 cm 1 
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Variable English units No. 

Dec. 
Metric units No. 

Dec. 
 
Contain & Safety Units 

    

Rate  
• Resource Line Production 

Rate 

ch/h 1 m/h 1 

Distance, Containment  
• Fireline Constructed 
• Line Construction Offset 

ch 1 m 0 

Distance, Safety Zone 
• Safety Zone Radius 
• Safety Zone Separation 

Distance 

ft 0 m 0 

Area, Safety Zone  
• Safety Zone Size 

ac 2 ha 0 

Area, Personnel and Equipment 
• Area per person 
• Area per heavy equipment 

ft2 0 m2 0 
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Appendix D: The 0Startup.bpw worksheet, defaults 

The 0Startup.bpw worksheet is generally the starting place for selection of calculation modules. Therefore, 

upon initiation, the BehavePlus program automatically loads that worksheet. You have the option of ignoring 

or closing it and loading a previously saved worksheet loaded through the File > New command. 

The 0Startup.bpw worksheet doesn’t look like much on the screen, but it carries with it all of the ‘default’ 
selections for calculation modules and displays. Any of those selections can be changed, of course. The 

0Startup.bpw worksheet can be reloaded at any time to reset the defaults. The 0 (zero) is the first character 
in the file name to assure that it is listed first in the list of Example Worksheets for easy selection. 

If you want to use a different set of ‘defaults’, simply develop and save a similar startup worksheet in your own 

folder. For example, if you generally use metric units or if you prefer to display graphs as full screen rather 
than 50%, then you can define an alternate appropriate startup worksheet. The program will, however, 
continue to load our 0Startup.bpw worksheet when the program is initiated. You will need to load your own 

using the File > New command. 
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Following are the ‘default’ selections that come with the 0Startup.bpw worksheet. 

Module Input option 0Startup.bpw 
selection 

Other options 

SURFACE Fuel is entered as • Fuel models • Fuel parameters 

• Dynamic palmetto-gallberry 

• Two fuel models, two-

dimensional expected spread 

• Two fuel models, harmonic 

mean 

• Two fuel models, area 
weighted 

 Moisture is entered 
by 

• Individual size class • Dead and live category 

• Moisture scenario 

 Wind speed is 
entered as 

• Midflame height • 20-ft wind and wind 
adjustment factor 

• 10-m wind and wind 

adjustment factor 

 Wind direction is • Specified on the 

worksheet 

• Upslope 

 

 Rate of spread is 
calculated 

• Only in the direction 

of maximum spread 

• In directions specified on the 

worksheet 

 Wind & spread 
directions are 

• Degrees clockwise 
from upslope 

(direction the wind is 
pushing the fire) 

• Degrees clockwise from 
north (direction from which 

the wind is blowing) 

 Slope is specified as • Percent • degrees 

 Slope steepness is • Specified on the 
worksheet 

• Calculated from map 
measurements 

SCORCH Fire intensity is 
entered as 

• Flame length • Fireline intensity 

MORTALITY Bark thickness is • Specified on the 
worksheet 

• Estimated from species and 
d.b.h 

RH Relative humidity is 
derived from 

• Dew point and dry 

bulb temperature 

• Dry and wet bulb 

temperature and elevation 
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Module 0Startup.bpw  

output variable 
selection 

Other output variables 

SURFACE • Rate of spread 

• Heat per unit area 

• Fireline intensity 

• Flame length 

• Direction of maximum spread 

• Maximum wind exceeded? 

• Reaction intensity 

• Spread distance 

• Midflame wind speed 

• Effective wind speed 

• Maximum reliable wind speed 

• Slope steepness 

• Slope elevation change 

• Slope horizontal distance 

• Wind/slope/spread direction 

diagram 

• Fire characteristics chart 

• For Palmetto-gallberry dynamic 

fuel: 

• P-G dead fine fuel load 

• P-G dead medium fuel load 

• P-G dead foliage fuel load 

• P-G live fine fuel load 

• P-G live medium fuel load 

• P-G live foliage fuel load 

• P-G litter fuel load 

• Fuel bed depth 

SAFETY • Safety zone separation distance 

• Safety zone size 

• Safety zone radius 

SIZE • Area 

• Perimeter 

• Length-to-width ratio 

• Forward spread distance 

• Backing spread distance 

• Fire length 

• Maximum fire width 

• Fire shape diagram 

CONTAIN • Time from report 

• Contain status 

• Contained area 

• Fireline constructed 

• Number of resources used 

• Cost of resources used 

• Containment diagram 

SPOT • Spotting distance from torching 
trees 

• Spotting distance from a burning 
pile 

• Spotting distance from a wind-
driven surface fire 

SCORCH • Scorch height  

MORTALITY • Probability of mortality • Bark thickness 

• Tree crown length scorched 

• Tree crown volume scorched 

IGNITE • Probability of ignition from a 

firebrand 

• Probability of ignition from 

lightning 

RH • Relative humidity • Dew point temperature 
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Menu item 0Startup.bpw 
selection 

Other options 

View 100% 50, 67, 75, 83, 117, 133, 150, 167, 
200% 

None SURFACE, SAFETY, 

SIZE,CONTAIN, SPOT, 
SCORCH, MORTALITY, IGNITE, 
RH 

Configure > Module selection 

Display output distances in map 
units. Off 

On 

Configure > Units English Metric 

Custom 

Configure > Language English (US) Portuguese (Portugal) 

Configure > Fuel model set 
selection 

None No other options.   

Fuel model set selection must be 

done every time a Worksheet or 
Run is loaded 

Configure > Moisture scenario 
set selection 

None No other options 

Moisture scenario set selection 

must be done every time a 
Worksheet or Run is loaded 
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Configure > 
Appearance  

Tab 

Option 0Startup.bpw 
selection 

Other options 

Show help pane On Off 

Show picture pane On Off 

Border color Black Other colors 

Application 

Border width 1 0 = no border 

2-9= thicker border 

Graph size 50% 25-100% 

Graph title Short Long 

X axis origin Zero Min value 

Graph size 

Y axis origin Zero Min value 

Background White Other colors 

Rainbow colors 3 4-18 

Bar color Red Other colors 

Curve points 20 4-100 

Curve color Rainbow colors Single color 

Curve width 3 0-9 

Axis color Black Other colors 

Axis width 1 2-9 

Gridline color Yellow Other colors 

Graph elements 

Gridline width 1 0=no gridlines 

2-9=thicker gridlines 

Display page tab Off On 

Tabs per page 4 0 = no tabs 

1-10 

Tab position 1 0=no tabs 

1- #tabs per page 

Tab text Blank User defined 

Tab text color Black Other color 

Page tabs 

Tab font size 12 8-24 

Shade alternate table 

rows 

On Off Tables 

Shade Light grey Other colors 

Fire projection 

documentation  

Off On 

Training documentation Off On 

Show input codes for all 

discrete variables 

Off On 

Show output variables 

to be calculated 

On Off 

Show notes section On Off 

Worksheet 

Notes lines 4 1-10 
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Appendix E: Example Worksheets 
BehavePlus allows the user to define and save a worksheet for later use. A set of Example Worksheets is 
provided with the program. Those worksheets are described in this appendix. A worksheet is selected 

through File > New. Clicking on the  by the Example Worksheets folder displays the following list. A 

double click on the selection or a single click and Ok loads the worksheet. 

 
It is important to recognize that these are only examples. We expect that people will set up their own folder 
of commonly used worksheets. 

0Startup.bpw 
This worksheet is a special case. It is used as the starting place for selecting calculation modules. It shows no 

input or output variables, but it sets defaults for all run settings as described in Appendix D. The 0Startup.bpw 
worksheet was used to initialize all of the following example worksheets. 

SurfaceSimple.bpw 
This worksheet is the ultimate simplification of the setup for a surface fire spread and intensity calculation. It 

can be used to examine relationships among the basic variables (fuel, moisture, wind, and slope) on surface fire 
spread. For specific fire behavior prediction, more information would be used. 

• Fuel moisture is entered as dead and live category.  A single value is used for 1-h, 10-h, and 100-h 
moisture content and another for live herbaceous and live woody fuel moisture. 

• Calculations are for maximum spread rate, upslope spread with the wind. 

SurfaceBasic.bpw 
This worksheet is similar to the DIRECT module in the old BEHAVE. This method of specifying directions is 

used to show the relative effects of wind and slope by vectoring. Reference is to upslope, so there is no need 
to define aspect or reference directions with respect to north. 

• A fuel moisture value is required for each size class. 

• Calculations are only for the direction of maximum spread 

• Wind and spread directions are specified as degrees clockwise from upslope 

• Wind direction is specified as the direction the wind is pushing the fire 
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SurfaceBasicFrom.bpw 
This worksheet is like SurfaceBasic.bpw except the other option for specifying directions is selected. This 
method of specifying directions is suited for onsite calculations for a specific location on the landscape. The 
wind direction is that used in weather forecasts. 

• A fuel moisture value is required for each size class. 

• Calculations are only for the direction of maximum spread. 

• Wind and spread directions are specified as degrees clockwise from north. 

• Wind direction is the direction from which the wind is blowing. 

FuelModeling.bpw 
This is the SURFACE module set up to examine the effect of changing fuel parameters, part of the process of 
developing a custom fuel model. 

• Fuel is entered as fuel parameter. 

• Fuel moisture is entered as moisture scenario. 

• Wind is blowing upslope. 

• Calculations are only for the direction of maximum spread. 

• Only rate of spread (maximum) and flame length are selected as output. 

SurfaceMap.bpw 
This worksheet might be used when using maps in projecting fire growth. 

• The header includes those for ‘fire projection documentation’. 

• Output distances are displayed as map units. 

• Calculations are only for the direction of maximum spread. 

• Wind and spread directions are degrees clockwise from north. 

• Wind direction is the direction from which the wind is blowing. 

• Direction of maximum spread and spread distance are selected as additional output variables. 

• Slope steepness is calculated from map measurements. 

SlopeMap.bpw 
This simple worksheet is used to calculate slope steepness from map measurements.  It is available from the 
SURFACE module. 

• Slope steepness is specified to be calculated from map measurements. 

• Only the slope output variables are selected. 

SurfaceScorchMortality.bpw 
This worksheet enables the three modules SURFACE, SCORCH, and MORTALITY. 

• Calculations are for specified spread directions (rather than for the direction of maximum spread). 

• Wind and spread directions are degrees clockwise from upslope. 

• Wind direction is the direction the wind is pushing the fire. 

SurfaceSpotIgnite.bpw 
This worksheet enables the three modules; SURFACE, SPOT, and IGNITE 

• Spotting distance is calculated from a wind-driven surface fire, which is the only spotting distance 

output option that makes sense for a link to SURFACE. 

• Wind is entered as 20-ft wind speed and wind adjustment factor (rather than as midflame wind 

speed). 

• Wind direction is upslope. 

• Calculations are only for the direction of maximum spread (the only option that is valid for this 

spotting option). 



ROCKY  MOUNTAIN  RESEARCH  STATION
RMRS

 
 
 
  The Rocky Mountain Research Station develops scientific 
information and technology to improve management, protection, and 
use of the forests and rangelands. Research is designed to meet the 
needs of National Forest managers, Federal and State agencies, 
public and private organizations, academic institutions, industry, and 
individuals.  
 Studies accelerate solutions to problems involving ecosystems, 
range, forests, water, recreation, fire, resource inventory, land 
reclamation, community sustainability, forest engineering technology, 
multiple use economics, wildlife and fish habitat, and forest insects 
and diseases. Studies are conducted cooperatively, and applications 
may be found worldwide. 
 
Research Locations 
 
Flagstaff, Arizona Reno, Nevada  
Fort Collins, Colorado* Albuquerque, New Mexico 
Boise, Idaho Rapid City, South Dakota 
Moscow, Idaho Logan, Utah   
Bozeman, Montana Ogden, Utah  
Missoula, Montana Provo, Utah   
Lincoln, Nebraska Laramie, Wyoming 
 
*Station Headquarters, Natural Resources Research Center, 
2150 Centre Avenue, Building A, Fort Collins, CO 80526 
 
 The U.S. Department of Agriculture (USDA) prohibits discrimination 
in all its programs and activities on the basis of race, color, national 
origin, sex, religion, age, disability, political beliefs, sexual orientation, 
or marital or family status. (Not all prohibited bases apply to all 
programs.) Persons with disabilities who require alternative means for 
communication of program information (Braille, large print, audiotape, 
etc.) should contact USDA’s TARGET Center at (202) 720-2600 
(voice and TDD). 
 To file a complaint of discrimination, write USDA, Director, Office of 
Civil Rights, Room 326-W, Whitten Building, 1400 Independence 
Avenue, SW, Washington, DC 20250-9410 or call (202) 720-5964 
(voice or TDD). USDA is an equal opportunity provider and employer. 
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