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Export to Spreadsheet Lesson 

Introduction 
BehavePlus offers the option of exporting table output as an HTML file, which can 
viewed with a browser.  The HTML file can also be opened with spreadsheet software 
where additional analysis can be done and graphs can be formatted in ways not available 
in BehavePlus. 
 

Objectives 
1. Export results as an HTML file. 
2. Open the HTML file as a spreadsheet for further analysis. 
3. Save the file as a spreadsheet. 

 

Where This Lesson Fits In 
This is an optional lesson in the Operation Unit. The prerequisites are the four lessons in 
the Introduction Unit.   
 
It is assumed that you know how to use spreadsheets, although we do take you through 
most of the steps.  A classroom instructor for this lesson should be proficient with 
spreadsheets.  A person doing it as self-study might want to have a helper on standby. 
 
We use Microsoft Excel® as an example in this lesson. 
 
Lesson Changes: V4.0 to V5.0 
Changes to the BehavePlus program did not require changes to this lesson. We updated 
the headers and footers, but did not redo the screen captures labeled BehavePlus 4.0.0.

BehavePlus fire modeling system, version 5.0 

Operation Unit Export to Spreadsheet Lesson 
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Using Excel to Reformat a BehavePlus Plot 
We will produce a graph with BehavePlus that corresponds to one from Scott and 
Burgan’s (2005) “Standard Fire Behavior Fuel Models…” paper.  The BehavePlus plot is 
a bit different. We will export results to a spreadsheet and label the lines in a different 
way. 
 
Following is a plot for Fuel Model GR2, p.27 in Scott and Burgan (2005). The moisture 
values used in the publication are described on p. 8. 
 

 
 
We will first use BehavePlus to produce a similar plot. 
 
 Open a new BasicStart.bpw worksheet.  

 Open the Module Selection window (  ). 
 Open SURFACE Options…. 
 Open the Fuel & Moisture tab and change the input option to Moisture is 

entered by moisture scenario. 
 Open the Basic Outputs tab.  
 Remove Surface Rate of Spread from the input selections, leaving only Flame 

Length. 
 Click Ok twice. 
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 Enter values on the worksheet as follows, entering Moisture Scenario values by 
clicking on the Guide button (  ): 

 
 

 

 

 
 Calculate the run. 
 Check the box to Specify graph Y axis limits. 

 

 
 
 Change the maximum Flame Length from 12 to 10 feet. 
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 Click Ok. 
 
The resulting table has calculated values for only the 0 and 20 mi/h Wind Speed specified 
in the Worksheet. 
 

 

 

 

 
The plot is produced by 100 calculations from Wind Speeds ranging from 0 to 20 mi/h. 
(You can verify this by going to Configure > Appearance preferences > Graph 
Elements > Curve Points, which is set to 100.) 
 

 

 

 

 
In BehavePlus you can delete the grid lines and change the curve colors and weight.  But 
the labeling of the curves is automatic.  If you want to change the curve labels, you have 
to use separate graphing software such as Microsoft Excel®. 
 

Export Results 
The export function only applies to the values in the tables produced by BehavePlus.  We 
certainly need more than the flame length associated with 0 and 20 mi/h wind speed. 
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Therefore, we will change the input to include intermediate values between 0 and 20. In 
this example, we will calculate 21 values. 
 

 Click on the First Page button (  ) to return to the worksheet. 
 Change the Midflame Wind Speed to 0 to 20 in steps of 1 by clicking on the 

Guide button. 
 

 
 
 Click Ok. 
 Calculate the run. 
 Display only the table results; there is no need to produce a graph. 
 Change the table row variable to Midflame Wind Speed to better format the table. 
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The outputs appear on a single page. If Moisture Scenario were chosen as the Table Row, 
the table would appear on more than one page. 
 

 

 

 

 
 Click on File > Export results. 
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The window opens to the default Export folder. You can save the results in MyExports 
or any other folder. You can also save it elsewhere on your computer. It is not necessary 
to keep it with your BehavePlus files. 
 
 Double-click on MyExports. 

 Create a new folder by clicking on the . 
 

 
 
 Name the folder ‘Export Lesson’. 
 Double-click on the new ExportLesson folder in the window. 
 Enter the file name ‘Example1’ in the File name field in the lower part of the 

window. 
 

 
 
There is only one File type option (Html). 
 
 Save the file. 
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The message in the FYI Window reminds you that you can open an HTML file with 
Microsoft Excel® spreadsheet software. 
 

 
 
 Click Ok. 

 

View the HTML File with a Browser 
 
 Find the file you just saved using Microsoft Windows Explorer®. 
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 Double-click on the file name. Because it is an HTML file, wt will open by default 
in a web browser. 

 
We will first open the file with a browser and then with a spreadsheet, so don’t close 
Windows Explorer®. 
 

 
 
The HTML file is nicely formatted with the information found in the BehavePlus 
Worksheet and the table. You can save this file in a documentation folder. It is a small 
file suitable for attaching to an e-mail. The HTML file will only include tables; it will not 
include graphs, even if they are created in the BehavePlus Run. 
 

Set Browser Settings to Print Shading 
The HTML file is formatted to include shading. In order for the shading to be visible 
when the file is printed, you may need to change your web browser settings. These 
settings are different for the various web browsers, two of which are described here. 
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In Internet Explorer: 
• Select Tools > Internet Options. 
• Select the Advanced tab. 
• Scroll down to the Printing 

header. 
• Enable the check box titled Print 

background colors and images. 
 

In Mozilla Firefox: 
• Select File > Page Setup. 
• Select the Format & Options 

tab. 
• Enable the check box titled Print 

Background (colors and 
images)

Open the HTML File as a Spreadsheet 
You can open the HTML file with spreadsheet software to do additional analysis and 
create plots in ways not possible in the BehavePlus program. 
 
 Right-click on the file name in Microsoft Windows Explorer®. 
 Choose to Open With Microsoft Excel®. 
 The first time you do this, you will need to select Choose Program…, highlight 

Microsoft Excel, 
 Make sure there is no check by Always use this program to open these files! 
 Click Ok.  
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 After this, Microsoft Excel® should show up as an option. 
 

 
 
Because of the column widths, it does not look as good in the spreadsheet as it did in the 
browser. However, once you have the values in the spreadsheet, you can work with them 
in any way you see fit. 
 
*** Note: It is important to save the document as a spreadsheet with the .xls 
extension. You should do this as soon as you open the worksheet. *** 
 
 Click on File > Save As…. 
 Change Save as type: to Microsoft Excel Workbook (*.xls). 
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You can save it in the same folder or elsewhere on your computer.  
 

 
 

Move Output to Another Worksheet 
 
 Highlight the output lines 28-51 (or whichever lines are the output in your file). 
 Click on CTRL-C to copy (or click on Edit > Copy). 
 Click on Insert > Worksheet. 
 Click in the upper left-hand cell. 
 Click on CTRL-V to paste (or click on Edit > Paste). 

 
Don’t change the original page! You will work with the output page, which is currently 
labeled ‘Sheet1’. You can change the name if you would like by double-clicking on the 
name and typing the new name. 
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Produce a Plot and Reformat 
Now that the data are in the correct format, you can produce and format the graph. 
 
 Highlight Columns B-F and Rows 3-24. 

 Click on the Chart Wizard icon: . 
 Choose XY (Scatter). 
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 Click on the Chart sub-type Scatter with data points connected by lines 
without markers (i.e., the line only; no points). This is the graph type in the 
bottom left-hand side of the Chart sub-type list. 

 

 
 
 Click Finish to produce the plot. 
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 Right-click in the white area of the plot. 
 Click on Chart Options. 
 Click on the Titles tab. 
 Fill out the Chart title, Value (X) axis, and Value (Y) axis as follows: 

 

 
 
 Click on the Legend tab. Remove the check by Show legend. 
 Click on the Gridlines tab. Remove the check by Major gridlines. 
 Click OK. 
 Right-click on the x-axis (on the line itself). A pop-up window should appear. 
 Select Format Axis. 
 Click on the Scale tab. Change the Maximum from 25 to 20. Change the Major 

unit from 5 to 2. 
 

 
 
 Click on the Font tab. Change the Font style to Bold. 
 Click OK. 
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 On the graph, right-click on the y-axis (on the line itself). A pop-up window 
should appear. 

 Select Format Axis. 
 Click on the Scale tab. Change the Maximum from 12 to 10. Ensure that the 

Major unit equals 2 and the box is not checked. 
 

 
 
 Click on the Font tab. Change the Font style to Bold. 
 Click OK. 
 Right-click in the grey area of the graph. Click on Format Plot Area…. 
 On the Patterns tab, click on None for Area. 

 

 
 
 Click OK. 
 Hover over a curve and right-click on it. A pop-up window will appear. 
 Click on Format Data Series…. 
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We want to make our graph look similar to this one for Fuel Model GR2 (Scott and 
Burgan 2005, p. 27). 
 

 
 
On the Patterns tab, there are two sections: Line and Marker.  
 
 Because of the Chart sub-type we chose, the Marker should initially be set to 

None. If the Marker is set to something else, change it to None.  
 In the Line section, change the Line Color and Weight. The Weight should be 

the thickest possible line. In this example, we are working with the top line. 
 

 
 
 Click OK. 
 Repeat for each curve. 

 
 Click on the chart. Grab the corner and resize the chart so that it is about 50-75% 

larger. You want to be able to see what you are doing in the next steps. 
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 Make sure the Drawing toolbar is showing. If not, click on View > Toolbars > 
Drawing. 

 On the Drawing toolbar, click on the Text box button (  ). 
 Left-click on the chart near where you want the label to appear. 
 Begin typing the label. As you type, the text box will appear. 
 Highlight the word and change the Font to size 11 and bold. 

 
 Repeat for each label. Or, click on the outside of the Text box, duplicate with via 

Copy and Paste, move it, and edit the text for the next label. 
 

 
 
In this case, we had 21 points on the table. 100 points would have produced a smoother 
plot. In some cases, this will be important. It is no more difficult to include more points. 
 
 Assuming you have already created an Excel spreadsheet, click on File > Save or 

the Save toolbar button to save the spreadsheet, which contains two worksheets. 
If you have not created an Excel spreadsheet, you must select File > Save As or 
you will have difficulty retrieving and sharing your files even if the files look OK! 

 
*** Note: Having made this mistake many times ourselves, we want to 
stress again that it is important to save the document as a spreadsheet 
with the .xls extension. You should do this as soon as you open the 
worksheet. *** 
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Using Excel to Calculate and Plot Another Variable 
We will use Microsoft Excel® to look at the ratio of Surface Rate of Spread to Flame 
Length. 
 
As stated by Burgan and Rothermel (1984, p. 47): “A common fuel modeling problem is 
having the spread rate about right, but the flame length too low, or vice versa.”  Their 
TSTMDL program (part of the old BEHAVE system) provided the opportunity to 
determine whether changing a particular Fuel Model parameter such as 1-h Fuel Load has 
a greater effect on the Surface Rate of Spread or the Flame Length.  A plot of the ratio of 
Surface Rate of Spread to Flame Length for the range of a given Fuel Model parameter 
will show whether Surface Rate of Spread will increase faster than Flame Length (rising 
curve) or slower (decreasing curve) as the value of the selected parameter changes. 
 
 Close the BehavePlus Worksheet that you were working with. 
 Open BasicStart.bpw and set up the following worksheet. 
 Go to Module Options > SURFACE Options… > Fuel & Moisture and select 

Fuel is entered by Fuel parameters (for custom fuel modeling). 
 In the same tab, change the moisture to Moisture is entered by dead and live 

category. 
 Select only Surface Rate of Spread and Flame Length as output variables. 
 Click Ok twice. 
 Click on Initialize from a Fuel Model and select Fuel Model 2. 
 Enter other input values as shown below. 
 Change the 1-h Fuel Load to a range of values from 0.5 to 5.0 in steps of 0.5. 
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 Calculate the run to get the following table and graphs. 
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 Export the results as in the previous section. 
 Save the results in the folder created earlier: ‘ExportLesson’. 
 Name the file ‘ROS-FL-ratio2’. 

 
 Open the file in Microsoft Excel®. 
 Save the file as an .xls file called ‘ROS-FL-ratio2.xls’. 
 Copy the results to a new worksheet. 
 Add a column with the heading ‘ROS / FL’. 

 
Now, we will add calculated values for this variable. 
 Click on the cell associated with 1-h Fuel Load = 0.5 ton/ac that is in the column 

called ROS / FL. 
 Type ‘=’. 
 Click on the ROS value for that row. 
 Type ‘/’. 
 Click on the FL value for that row. 

 

 
 
 Click Enter. 
 Click on the resulting value. If you get an error window or a result such as 

#NAME?, you may need to modify your equation. 
 Double-click on the Dot in the lower right-hand corner of the cell. 
 Values will be automatically calculated for the entire column. 
 Plot the ratio and label the graph as follows. 
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 You can select two non-contiguous columns by selecting the values in the first 
column (x-axis), holding the CTRL key, and highlighting the values in the second 
column (y-axis). 

 

 
 
The plot shows the relative effect of 1-h fuel load on rate of spread vs. flame length for 
these fuel parameters.  For 1-h load less than 1.5 tons/acre, rate of spread increases faster 
than flame length.  Above that value, flame length increases faster than rate of spread. 
This relationship is hard to see by looking at the separate rate of spread and flame plots 
from BehavePlus. 
 

Using Excel to Plot Two Variables on the Same Graph 
Continue with this example to plot Rate of Spread and Flame Length on the same graph. 
 
 Highlight the 1-h Fuel Load, ROS, and FL values as shown below. 
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 Click on the Chart Wizard icon (  ) and select a Scatter Plot. 
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 Click Finish to create the following plot. 
 

 
 
In Exercise 1, you will make changes to this graph to make it more informative. 
 

Summary 
In this lesson, you explored the option of exporting table output as an HTML file, which 
can viewed with a browser or opened with spreadsheet software where additional analysis 
can be done and graphs can be formatted in ways not available in BehavePlus.. 
 
Specifically, you should have learned how to: 

• Export BehavePlus table output as an HTML file. 
• Include the number of values in a table necessary to produce suitable plots. 
• View the output with a web browser. 
• Open the output file with a spreadsheet. 
• Save that output file as an .xls file for further analysis. 
• Copy the output from the main data page to a new worksheet for analysis. 
• Create graphs and additional computations. 

 
Microsoft Excel® is not the only spreadsheet software that you can use. SigmaPlot® is 
powerful graphing software that produces plots suitable for scientific publications. If you 
do not have access to purchased software, freeware such as Calc, which is included in 
OpenOffice.org, can be used. 
 



BehavePlus Version 5.0  Export to Spreadsheet Lesson 

Oct. 23, 2009  Page 25 of 25 

Exercises 
1. Continuing with the example at the end of this lesson, change the graph of Surface 

Rate of Spread and Flame Length to look like the following graph. 
 

 
 
2. Confirm that the Heat Source / Heat Sink = Surface Fire Rate of Spread. Use the 

following inputs: 
 

 

 

 

 
Question: Why are the results not equal to the Surface Rate of Spread calculated by 
BehavePlus? 
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