BehavePlus fire modeling syste

Advanced Worksheets Lesson Operation Unit

Introduction

The Worksheet, a form on which you enter input, is a core part of the BehavePlus fire
modeling system design. When the program starts in initially opens the BasicStart.bpw
Worksheet. You can define a different startup Worksheet that better meets your needs. It
may be useful to redefine your startup Worksheet for the project you are currently
working on.

Objectives

1. Develop and save worksheets with changes in modules, options, units, decimal
display, and appearance options.

2. Define a worksheet as the startup worksheet.

3. Open example worksheets that come with the program.

Where This Lesson Fits In

One of the required four lessons in the Introduction Unit is devoted to Worksheets. We
assume that you are familiar with that lesson and with all of the operating features
covered in the Introduction lessons.

1. Basic Start — simple entry of input to get answers in the form of tables and graphs

2. Worksheets — how the worksheet is developed from user selections

3. Input methods — various ways of entering input values

4. Calculations — table and graph output options

Lesson Changes: V4.0 to V5.0

Changes to the BehavePlus program required some minor changes to this lesson. You can
now see the location of the startup worksheet under Help > Installation Info. We updated

the headers and footers, but did not redo many of the screen captures labeled BehavePlus

4.0.0.
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Introduction

When you first start the BehavePlus program, the BasicStart.bpw Worksheet is loaded
automatically. Several other Worksheets are packaged with the program in the folder
ExampleWorksheets. You can also develop and save your own Worksheets.
Furthermore, you can define any Worksheet as your startup Worksheet, and you can
change it at any time. You might use one startup Worksheet when you are working on a
wildfire and another when you are doing prescribed fire planning.

Changing the Startup Worksheet
» Start BehavePlus.

The BasicStart.bpw Worksheet opens and looks like this:

@ EehavePlus 4.0.0 Page 1
a A
Inputs: SURFACE
Description a |‘
Fuel'Vegetation. Swrface/Understory
Fuel Model B
Fuel Moisture
1-h Moisture %% a |
10-h Moisture % B
100-h Moisture % B
Live Herbaceous Moisture %% a |
Live Woody Moisture %% a |
Weather
Midflamne Wind Speed (upslope) tmith a |
Tetrain
Slope Steepness % a |

We will change the startup Worksheet to one of the others that come with the program.
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» Click on File > Set startup worksheet.

» Choose SurfaceSimple.bpw from the ExampleWorksheet folder.

File Calculate “iew Configure Pages
0 Open worksheet
& Openrin

Save ag a wotlcsheet
SEVE &% & rmn
Save ag a fuel model 3

SavE as a motsture scenano

ﬁ Save as an itnage

Export results

& Print

Close

& Quit

Zet startup worksheet

Wotlspaces b

E:Behaveplus 4.0.0 Select A Worksheet

'i-- (5 Wi il cheeta

=10 |

Worlsheet | Files |Description Last Mod=
-- [ DirectionLesson 2 Direction Lesson Worksheets Mlon Aug
EI &) Example Worksheets 5 Ezamples that can't be changed in this folder Fri fug 3

- % D3tartup. bpw Elank wotlcsheet, defanlt mutiahization, English Wed Mar

- % BasicStart bpw Surface fire spread upslope with wind Wed Mar

- %3 FuelModeling bow Surface fire, fiuel modeling Wed Mar

- % SurfaceCrown bpw Wlax surface spread, upslope wind, input WAF Wed Mar

& imple bpw Surface fire s imple case, upsl
- () MetricEsample Worksheets 1 Metric version of Example Wotksheets Wed Mar—

5 Tiefanlt neer wrnrleeheet filder

Fri Ana_RlLI
»

I

Picture

Cancel |

A confirmation window notes the change.

» Click on File > Quit to close the program.
> Restart the program.
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Now the SurfaceSimple.bpw Worksheet opens.

}ﬁg BehavePlus 4.0.0 Page 1
o a
Inputs: SURFACE
Description a ||
Fuel/Vegetation, Surface/Understory
Fuel Model B
Fuel Moisture
Dead Fuel Moisture % a |
Live Fuel Moisture % a |
Weather
Iidflame Wind Speed (upslope) mith a |
Terrain
Slope Steepness % a [

You can check on the file location of the startup worksheet.

» Click on Help > Installation Info.

Directories

Executable  CifsappsfprodfamBehavePlus5/BehavePlus5 exe
L File Cfsapps\fsprodfamBEHAVE~4\BehavePlus3 zml
Installation  Cifzappseprodifam\BEHAVE-4

Wotlspace Clfsapps'fsprodifam\BEHAVE-~ 4 DefaultDataF older!

Startup (5
Worlcsheet ) \rapps\fepro dfam\BEHAVE-NDefaultDatal oldet’ "W otk sheetF older/Example W orkcsheeteBasic Start bpw

Define a Startup Worksheet with Metric Units
We will develop a metric version of the BasicStart Worksheet.

» Click on File > Open worksheet.
» Select BasicStart.bpw.

» Click on Configure > Units set selection > Metric.
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Configure  Pages “Windows Toolz: Help

:“__u‘— Module selection

Fuel model set selection

Meoisture scenano set selection

Uit set selection English

Custom umts preferences

Appearance preferences Custom
—_— = s ey

» Save as BasicStartMetric.bpw in a WorksheetLesson folder. (Alternatively save
it in MyWorksheets if you expect to use it in the future.)

» Enter a description such as “BasicStart Worksheet with Metric Units”.

» Define this Worksheet as the startup Worksheet.

» Quit the program.
» Restart BehavePlus.

The Worksheet that opens at startup now looks like this.

!’g BehaveFPlus 4.0.0 Page 1
. N
Inputs: SURFACE
Description a ||
Fuel'Vegetation, Smtace/Understory
Fuel Model B
Fuel Moisture
1-h Meisture % B
10-h Moeisture % B
100-h Woisture % B
Live Herbaceous Moisture Y a |
Live Woody Moisture % a |
Weather
Midflame Wind Speed {upslope) lernth a |
Terrain
Slope Steepness % a |

Recall that the information stored with the Worksheet is much more than what shows on
the screen. The units for every variable are metric.
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» Change the module selection from SURFACE to CROWN.

Oct. 23, 2009

Advanced Worksheets Lesson

[ Surface Fire Spread (STEFACE)
W Crown Fire (CROTWI)

[ Safety Zone (SAFETT)

cize of a Pt Source Fire

- (SIZE)

Fire Containment

= (CONTATT)

[T Spothng Distance (SPOT)
I Crown Scorch (SCORCH)

Tree Mortality
(MORTATLITY)

[ Probabiity of Igtion (IGNITE)

-

Options...
COptions.

Diptions.

Options..

Dptions.

Options..

COptions..
Options...

COptions.
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The Worksheet looks like this... with metric units.

Advanced Worksheets Lesson

_!"g BehavePlus 4.0.0

Page 1

/‘

Inputs: CROWN

Deescription a ||
Fuel/Vegetation, Overstory

Canopy Base Height m a |
Canopy Bulk Density kg/m3 a |
Fuel Moisture
1-h Moisture ¥ a |
10-h Moisture ¥ a |
100-h Moisture ¥ a |
Live Woody Moisture %% a |
Foliar Moisture ¥ a |
Weather

20-ft Wind Speed (upslope) ~ kmh [ |
Fire

Flame Length m a |

Run Ophion Notes
Mone

Output Variables
Critical Surface Intensity (&Wim) [CROWI]
Transition Ratie  [CROWIT]
Transition to Crown Fire 7 [CROWI]
Crown ROS (mfmin) [CROWI]
Critical Crown ROS (m/min) [CROWI]
Active Ratio  [CROWIT]
Active Crown Fire? [CROWI]

Define a Startup worksheet that produces black and white plots
A Worksheet also includes the settings that you select under Appearance preferences.

» Open the BasicStart Worksheet again.

» Click on Configure > Appearances preferences > Graph elements.
» Change Curve Color to Black.
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» Change Gridline Color to Grey.

B BehavePlus 4.0.0 Appearance Options - IEllil

Application | Graph Size | Graph Elements

Page Tabs |Tables |Worksheet |

Background I White - I
Ramnbow Colors |3 3:

& Eacl | mp Ervd | 1iHome &> Index

Graph Element

Bar Color Red - Options
Curve Points  [100 s

Curve Color I Elack 'I

— Thiz page controls the color and width of BehavePlus

e el |B x> output graph elements.
Axis Color IBlack 'I )
Appearance Controls
bxis Width |1 g
# Background Color
Gridline Color Controls the graph's background color. Select one

o _ — of the predefined colers from the drop-down list,
Gridline Width |1 -

# Rambow Colors
Controls the number of colors used to display |

Ol | Cancel |

¥ Picture v Help

> Enter values on the Worksheet as follows.

E EBehavePlus 4.0.0 Mlen, Aug 25, 2008 at 17:23.27 Page 1
- ~
Inputs: SURFACE
Description a |‘
Fuel'Vegetation, Swface/Understory
Fuel Model a |2
Fuel Moisture
1-h Moistre ¥ a a8 12
10-h Moisture w B[s
100-h Moisture w B[s
Live Herbaceous Moisture Y a |75
Live Woody Moisture %% ﬂ |
Weather
Midflame Wind Speed (upslope) tmifh ﬂ ID 36 9
Tetrain
Slope Steepness % a |D
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» Calculate the Run to see the following plot without color.

m BehavePlus 4.0.0

Mon, Aug 25, 2008 at 17:23:27

Page 4

/f

140

120—

100—

[ole]
=

=)
=

&
\

Surface Rate of Spread (mazimum (chih)

2]
=

Midflame Wind Speed (upslope)
(mih)

=]
=]
r —|

1-h Meisture (%4)

MyWorksheets)

>
>

Quit the program
Restart BehavePlus.

Save the Worksheet as BasicStartBlack in WorksheetLesson (or in
Enter the Description as “Graph has black curves and grey gridlines”.

Select this new Worksheet as the startup Worksheet.

This looks like the previous BasicStart.opw Worksheet, but the Appearance

preferences have been changed.

» Change the Module Selection from SURFACE to SIZE.
» Enter values on the Worksheet as follows.

m BehavePlus 4.0.0

Idon, Aug 25, 2008 at 17:28:07

Page 1

/

Inputs: SIZE

Deescription a ||
Weather
Effective Wind Speed
Fire
Surface Rate of Spread (masximum)
Elapzed Tune

mih B [0 &8

ch BY [10 z0

- I
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» Calculate the Run and see the black and white plot.

P-g; EBehavePlus 4.0.0 Mon, Aug 25, 2008 at 172807 Page 4
. =

140

Surface Rate of Spread (mamimum)

120— (ch)

100 —

80—

Areaac)
|

60—

40—

Effective Wind Speed (mifh)

Define a Startup worksheet with metric for CBD
Metric units are often used for Crown Bulk Density even when the rest of the units are
English. If this is your preference, you may want to develop a modified BasicStart
Worksheet and define it as your startup Worksheet.

» Open BasicStart.bpw from the ExampleWorksheets folder.

Note: Remember that you can’t change Worksheets in the ExampleWorksheets folder.
You must save your modified Worksheet elsewhere.

» Click on the Configure > Custom Units preferences > Fuel & Vegetation
Units tab.
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» Change Canopy Bulk Density units from Ib/ft3 to kg/m3.

-
A BehavePlus 5.0.0 Units Editor

Fuel & Vegetation Units | Weather Units | Terrain & Spotting Units | Fire & Bffects Units | Time & Map Units | Contain & Safety Units |

Wariable Ututs Decimals  Back | ) B | tar Home | Index
Fuel Load ‘ tonfac j |3 il [ Wt
Surface Areafol Ratio azms [0 3 Fuel & Vegetation

v

Surface Fuel Depth ft [z ;_ 2 Units
e

Ground Fuel Depth i M

Fuel & Eztinction Moisture ’m 0

Fuel Heat Content Bhylh - This page controls the selection of umts of measure for all

’—_| ,—:l Fuel and Vegetation vanables. The number of decimnal
o el Dty o/f3 places displayed for output variables can be changed. The

Packing Fatio ratio < EI number of decimal places displayed for input variables is
Tree & Canopy Height f - determined by the precision of user input, not by this page (a

change made in version 5.0).
Tree Dbh & Bark Thickness | in El
The units of measure initially displayed by the dialog are

these in use for the current worksheet. The selected units
Coverage and decitmals are applied to the current worksheet and can

Basal frea A ac - also be saved as a custom Units Set.
Load & Crown Fill Portion | %4 -0 = To apply a previcusly saved custom Uhits Set to any

- EBehavellus wotlcsheet, choose Configure -> Units set
Crown Eatio fraction - El. !

selection-= Custom from the menu and select the desired

file

RILARRILAREILS

R L

Canopy Bulk Density -

¥ Picture W Help

=l

Oic F— |

» Click Ok to close the Units Editor.
» Click No, because you don’t have to save a Custom Units set to apply it to the
open Worksheet.

» Save the modified Worksheet in MyWorksheets as BasicStartCBD with a
Description that indicates that Canopy Bulk Density is in kg/m3.

> Define this as your startup Worksheet (if you wish) and leave it that way after you
finish this lesson.

Summary

Several Example Worksheets come with the program. One of these, BasicStart.bpw, is
automatically opened when the program starts. You can always open a different
Worksheet once the program is opened. But for convenience, you can also define a
different startup Worksheet.
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Exercises

1. Assume that you want to use English units, but prefer not to use “chains’.

Start with the BasicStart.bpw Worksheet from the ExampleWorksheets folder.
Change every use of chains to feet.

Save the Worksheet as BasicStartNoChains.

Define it as your startup Worksheet.

2. Define a map application Worksheet that you might use as a startup Worksheet while
you are doing a fire behavior prediction job.
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