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Worksheets Lesson 
 
Introduction 
The Worksheet, the form used to create a fire behavior analysis, is a core part of the BehavePlus fire 
modeling system design. A BehavePlus Worksheet includes a wealth of information, including the 
modules that have been selected, output values that are being calculated, input values required for 
calculation, notes on selected Run options, and space for user documentation of the Run. The 
measurement units of each value are provided as well.  
 
The program will only request input values for the modules and outputs that you have selected. In 
addition, BehavePlus allows you to design a Worksheet to meet specific needs. A Worksheet can be 
developed on the fly, or it can be saved for repeated use. 
 
Objectives 
By the end of this lesson, you will be able to do the following. 

1. Explore the various options for changing a Worksheet. 
2. Save a Worksheet. 
3. Open a saved Worksheet. 
4. Develop a new Worksheet. 

 
Where This Lesson Fits In 
This is a lesson in the Introduction Unit, which teaches you basic program operation. These lessons 
should be completed in order.  
 
This is the second of four lessons that introduce you to the BehavePlus fire modeling system. 

1. Basic Start – simple entry of input to get answers in the form of tables and graphs  
2. Worksheets – how the Worksheet is developed from user selections  
3. Input Methods – various ways of entering input values  
4. Calculations – table and graph output options 

 
Lessons in other units cover the many features and fire modeling capabilities offered by BehavePlus. 
Those lessons can be done in any order unless otherwise specified in the lesson. 
 
Note: There are questions (in blue) located throughout this lesson. The answers can be found at the end of 
the lesson starting on page 12. 
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Worksheet Development 
A Worksheet contains fields for entering input values. It is created based on selections that you make in 
the program. Only required inputs are requested. Selections that affect the Worksheet are described 
briefly below. You will examine each one in more detail later in this lesson. 

• Module Selection: More than 40 different models are included in the BehavePlus fire modeling 
system. You will very likely only need to use a few of them. The models are grouped by module 
to assist you in finding the model(s) you plan to use. For example, the SURFACE module is used 
to calculate surface fire spread and intensity, while the SPOT module calculates spotting distance 
for several different types of fire. 

• Output Variable Selection: A number of output variables are available for each module. For 
example, the SIZE module can be used to calculate point source fire area, perimeter, length-to-
width ratio, maximum fire width, etc. The IGNITE module, on the other hand, is used to calculate 
only probability of ignition. 

• Input Option Selection: Some of the modules allow you to specify the inputs. For example, the 
SURFACE module offers the option of entering wind speed as either midflame wind speed or 20-
ft wind speed and a wind adjustment factor. The CROWN module allows you to select between 
the Rothermel (1991) and the Scott and Reinhardt (2005) crown fire models. 

• Worksheet Appearance: If desired, you can alter many aspects of the Worksheet’s appearance. 
For example, extra lines can be added to the Description, and you can change the border’s 
appearance. 

 
Worksheets 
When you open BehavePlus, the BasicStart.bpw Worksheet loads automatically. All BehavePlus 
Worksheets have a .bpw extension. You have the option of defining your own startup Worksheet, which 
is covered in the Operation Unit Advanced Worksheets Lesson. 
 
Let’s examine the options found in the BasicStart.bpw Worksheet (shown below). As we examine the 
components of the Worksheet, you can either view the Worksheet in BehavePlus or print out a copy, 
which can be found in the document entitled Worksheets_Handout.pdf. In the following discussion, 
Refer to the Handout refers to this document. 
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There are four general sections in a Worksheet: Inputs, Run Option Notes, and Output Variables, and 
Notes. Inputs and outputs are selected in the Module Selection window. The Run Option Notes tell you 
the assumptions and limitations associated with the current analysis. 
 

1. What are the four main categories of inputs (shown in blue) on this Worksheet? 
 
Module selection 
Once you have decided what analysis is needed, select the appropriate modules. 
 

 Click on the Module selection ( ) button, or go to Configure > Module selection. 
 

 
 
For the BasicStart.bpw Worksheet, only the SURFACE module is selected. 
 
 Refer to the Handout as we examine this selection. 

o The word SURFACE appears on the first line of the Worksheet beside the word Inputs. 
Therefore, the calculations in this Worksheet relate only to surface fire behavior. All modules 
selected on a given Worksheet will be shown in this line. 

o The module associated with every Run Option Note and Output Variable is, therefore, 
SURFACE. 

 
Module options 
The SURFACE module is by far the most complex module in BehavePlus. Inputs and outputs are divided 
into two tabs: Input Options and Output Variables. 
  
 Click on the Options… button associated with the SURFACE module. 
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The Module Options window opens. 
 

 
 
The program defaults to the Output Variables > Basic tab. These outputs are the most commonly used in 
the SURFACE module. Since outputs determine which inputs are needed, select the desired outputs first. 
 
 In the center pane, move the cursor over the variable Surface Fire Flame Length. A description 

of the variable appears in the right-hand Help pane. Scroll through the help file to see the 
complete description. 

 
2. When is Surface Fire Flame Length an input to the SCORCH module? 
3. At what flame length is hand line unreliable for holding a fire? 

 
The SURFACE module offers a number of output variables. 

 Click on each of the tabs to the right of the Basic tab to see the additional outputs.  
 

4. Which tab is most useful for exploring variables from Rothermel’s (1972) fire spread model? 
 
Input option selection 
Input options for a Worksheet are on the Input Options tab. Let’s briefly explore each tab to see what 
options are available. Answers to the questions can be found in the Input Options window, the Help 
system or on the BasicStart.bpw Worksheet. 
 

 
 
 Click on the Fuel tab. 

 
5. What are the special case fuel models? Next, refer to the Handout. Which fuel model option is 

selected on the BasicStart.bpw Worksheet? 
 
 Click on the Moisture tab. 
 Uncheck the Picture option at the bottom of the window to close the left-hand picture window, 

allowing more space for the Help window. Clicking this option only affects the current tab. 
 Scroll down in the Help window for an explanation of options. 
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6. What is a moisture scenario? Next, refer to the Handout. Which fuel moisture option is selected 
on the BasicStart.bpw Worksheet? 

 
 Click on the Wind Speed tab. 

 
7. What options are available as ways to enter wind speed? Next, refer to the Handout. Which wind 

speed option is selected on the BasicStart.bpw Worksheet? 
 

On the Wind Speed tab, there is an option to specify wind direction on the Worksheet (Wind is 
in specified directions). Use this option whenever wind and slope are not aligned to allow the 
program to properly calculate the combined effects of wind and slope on fire behavior. 

 
 Click on the Slope tab. 

 
8. What inputs are needed if slope is calculated from map measurements? Next, refer to the 

Handout. Is slope entered directly or calculated from map measurements on the BasicStart.bpw 
Worksheet? 

 
 Click on the Directions tab.  

 
There are five options for calculating surface fire spread. For more information about these options, refer 
to the lesson titled Surface Fire Spread Directions: Options and Definitions in the Modeling Unit. 
 

9. In what two ways can you define wind and spread directions? Next, refer to the Handout. Which 
option is selected on the BasicStart.bpw Worksheet? 

 
 Finally, click on the Chaparral tab, which is only used if the chaparral special case fuel model is 

selected. This tab allows you to specify or calculate the total fuel load. 
 
 Click Ok or Cancel twice to close the Module Options window and then the Module Selection 

window. 
 
Worksheet Appearance 
In addition to selecting the fire behavior analyses that you want to create, you can also change the 
Worksheet appearance if desired. 
 
 Select Configure > Appearance preferences from the main menu. 
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The Application tab opens by default. On this tab, you can change the border color and width. You can 
also choose to hide both the Help pane and picture pane by unchecking the boxes next to each option. 
These options only apply to the current Worksheet. However, we strongly suggest that you leave the Help 
pane open. 
 
Two other tabs affect Worksheet appearance: Page Tabs and Worksheet. Page Tabs allow you to enter 
additional information on the right-hand edge of the Worksheet, which you can use to enter additional 
information about a Run if desired. 
 
 Click on the Worksheet tab. 

 
The BasicStart.bpw Worksheet only contains a Description line. You can add additional description 
information if desired for prescribed fire, fire behavior projections, or training. 
 

10. Which additional input fields appear when the Training worksheet header is selected? 
 
Additional Worksheet tab options include: 

• Show descriptions for all discrete variable codes: If this option is selected, all available 
discrete variable selections will be printed, including all 53 fuel models. This option is seldom 
selected. 

• Show descriptions only for entered discrete variable codes: More typically, you want to only 
show descriptions for the discrete variables that are used in a Run. These appear on the very last 
page of the Run. They are helpful if you are sharing the results with someone who is less familiar 
with modeling fire behavior. 

• Show output variables to be calculated: This option is typically selected as it shows the 
currently selected output variables on the Worksheet before you create a Run. 

• Show notes section: The Notes section appears at the bottom of the Worksheet. It is helpful to 
provide additional documentation that will not show up on the output pages, but that will be 
saved with a Run. 

 
 Close the Appearance Options window. 

 
Module Selection 
There are eight different modules that can be selected, each with a different purpose. Let’s examine 
another one. 
 

 Click on the Module selection ( ) button, or go to Configure > Module selection. 
 Uncheck the box next to SURFACE, and check the box next to SIZE. 

 

 
 
 Click Ok. 
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Your Worksheet should look like the following. 
 

 
 
 Return to the Module Selection window and check the box next to SURFACE as well. 
 Click Ok. 

 
The Worksheet now looks like the following. 
 

 
 
Notice that module names are listed at the top of the Worksheet and are associated with each output 
variable. This lets you know which module produces the output variable. 
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There is a blue Guide button ( ) next to each input variable. This opens an Input Guide window 
containing information related to the variable. The right-hand pane includes a help file similar to those 
that we examined earlier for output variables. We will examine the center pane in the next lesson. 
 
 Click on the Guide button associated with Midflame Wind Speed. 
 Scroll to the bottom of the Help window. There are a number of related variables listed. 
 Click on Effective Wind Speed. 

 
11. How are Effective Wind Speed and Midflame Wind Speed related to each other? 

 
Modify the Worksheet 
So far, we have done little to modify a Worksheet. Let’s start doing that now. 
 
 In the Module Selection window, uncheck SIZE, leaving SURFACE checked. 
 Click on the SURFACE Options… button. 
 Uncheck the boxes next to Surface Fire Rate of Spread and Surface Fire Flame Length. 
 Select Surface Reaction Intensity. There should be only one output selected. 

 
12. What is Surface Reaction Intensity? 

 
 Click Ok twice to return to the Worksheet. 

 
The Worksheet has changed since only the inputs required to calculate the selected outputs are included. 
 

 
 

13. Refer to the Handout. What inputs are required for Surface Fire Rate of Spread and Surface Fire 
Flame Length that are NOT required for Reaction Intensity? 

 
Let’s make a few more changes to the Worksheet. 
 In Module Selection > SURFACE Options… > Output Variables, change the selected outputs 

back to Surface Fire Rate of Spread and Surface Fire Flame Length. 
 Go to Input Options > Moisture. 
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 Change the selection to Moisture is entered by dead and live categories. 
 

 
 
 Click on the Wind Speed tab and  
 Change the selection to Wind speed is entered as 20-ft wind and Calculated wind adj factor. 

 

 
 
The Inputs portion of the Worksheet has changed. 
 

 
 

14. What new category is added to the Worksheet? 
 
Saving a Worksheet 
If you find that you are repeatedly making the same changes to a Worksheet, you should consider saving 
a customized Worksheet for future use. 
 
 Click on File > Save as a worksheet. 
 The Save As dialog box opens. By default, the Worksheet files are filed in the MyWorksheets 

folder. 
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It is easy to create a folder for your Worksheets by simply typing in a new name for the Worksheet 
Folder if desired. More information is available in the File Management Lesson in the Operation Unit. 
 
 In the Worksheet Folder field, the MyWorksheets folder will be selected. You can change it at 

any time. For now, we will accept the default folder. 
o Note: You cannot save any files to the ExampleWorksheets folder. 
o Double-click on another folder to use it; its name will replace the one in the Worksheet 

Folder field. 
o Create a new folder by simply typing in a new name and following the prompts after you 

click Ok. (Don’t click it yet!) 
 In the Worksheet File field, type WorksheetLesson.  

o Note: There can be no spaces in the Worksheet file name. 
 In the Worksheet Description field, type Example saved worksheet. 

o Note: This description is also added to the Worksheet. Delete or type over it to replace it. 
 Click Ok to save the Worksheet. 

 
An FYI dialog box is displayed. Any problems or questions related to saving your file are displayed here. 
The .bpw extension, indicating a BehavePlus Worksheet, is added automatically to the file name. 
 

• Click Ok to finish saving the Worksheet. 
 
Opening a Worksheet 
Once you have saved a Worksheet, you will want to open it again later. The BasicStart.bpw Worksheet 
opens whenever you open BehavePlus. You can open another Worksheet at any time, and you can open 
as many Worksheets at a time as you would like. 
 
 Close the current Worksheet by going to File > Close, or clicking the black “X” in the upper 

right-hand corner of the Worksheet. 
 Open a new Worksheet by going to File > Open worksheet. 
 Navigate to the Worksheet you want to open. In this case, find your WorksheetLesson.bpw file. 
 Click Ok to open the Worksheet. 

 
Sample Worksheets are stored in the ExampleWorksheets folder. They can be opened and used but 
cannot be resaved to that folder. Explore the ExampleWorksheets on your own. Let’s review one of 
them now. 
 
Defaults and the 0Default.bpw Worksheet 
Sometimes you may want to return to the default settings in BehavePlus, particularly if you have made a 
number of changes. Since there is no Undo or Clear All button in the program, you have to either make 
changes to the current Worksheet or close the Worksheet and start over. Sometimes, it is just easier to 
start over. 
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 Open the 0Default.bpw Worksheet, located in the ExampleWorksheets folder. 
 

 
 
It appears that this is a simple, blank Worksheet, but there is a lot of information attached to it. This 
Worksheet contains default settings, allowing a common starting point for creating new Worksheets. The 
fact that so much information is part of the Worksheet is a key part of the BehavePlus design. As you 
have seen in this lesson, a Worksheet is much more than what is shown on the computer screen. 
 

15. What is the difference between the 0Default.bpw and the BasicStart.bpw Worksheet?  
(Hint: Look at the top of the Inputs; making one change to the configuration will create a 
BasicStart.bpw Worksheet from the 0Default.bpw Worksheet). 

 
Summary 
In this lesson you have seen some of the many, sometimes overwhelming, options that are available in 
BehavePlus. The goal of this lesson is to help you understand the Worksheets in BehavePlus. The best 
advice we can give to new users is to take your time. Make one change at a time and see what happens. 
Start by selecting the modules that you want to use. Then, select outputs in each of those modules. Then, 
and only then, should you determine which inputs are available to use. Finally, check the Run Option 
Notes to make sure the assumptions and limitations are correct for your analysis. And, create different fire 
behavior analyses, maybe for fires you have worked in the past. The more you use the program, the more 
comfortable you will become. 
 
Of course, there is a lot more to using this program than pushing buttons. You should have both an 
understanding of fire modeling concepts and fire experience to effectively use the program. We will 
reinforce information about basic fire modeling concepts in following lessons. However, BehavePlus 
training is meant to supplement, not replace, other fire behavior training. 
 
Exercises associated with this lesson start on page 14, after the answers to the questions in the lesson. 
 
You have completed the first two lessons in the Introduction Unit.  

1. Basic Start – simple entry of input to get answers in the form of tables and graphs  
2. Worksheets – how the Worksheet is developed from user selections 

 Continue in order with the next two lessons to gain a basic understanding of program operation.   
3. Input Methods – various ways of entering input values  
4. Calculations – table and graph output options  
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Answers to Questions in the Lesson 
1. What are the four main categories of inputs (shown in blue) on this Worksheet? 

The four main categories include: 
• Fuel/Vegetation, Surface/Understory: a description of the understory fuels that are carrying the 

fire, as identified by fuel model(s). 
• Fuel Moisture: live and dead fuel moisture values needed to calculate surface fire behavior. 
• Weather: in this Worksheet, the wind speed affecting fire behavior. 
• Terrain: in this Worksheet, the steepness of the slope on which the fire is burning. 

 
2. When is Surface Fire Flame Length an input to the SCORCH module? 

According to the help file, flame length is an input to the SCORCH module if the SURFACE module 
is not selected and if Fire intensity is entered as flame length is selected as an input option. 
Otherwise, the Surface Fire Flame Length from SURFACE is used to calculate Scorch Height in the 
SCORCH module. 
 

3. At what flame length is hand line unreliable for holding a fire? 
According to the chart at the bottom of the help file, this occurs at flame lengths ranging from 4-8 ft. 

 
4. Which tab is most useful for exploring variables from Rothermel’s (1972) fire spread model? 

The Intermediates tab contains variables that are part of the Rothermel fire spread model, and 
therefore, are most useful for exploring the model in detail. 

 
5. What are the special case fuel models? Next, refer to the Handout. Which fuel model option is 

selected on the BasicStart.bpw Worksheet? 
Special case fuel models have been developed for palmetto-gallberry, western aspen, and chaparral. 
These fuel models were developed to better describe the characteristics of these three fuel types for 
use with Rothermel’s (1972) surface fire spread model. The fuel model option on the BasicStart.bpw 
Worksheet is simply Fuel Model, a defined standard or custom fuel model. 

 
6. What is a moisture scenario? Next, refer to the Handout. Which fuel moisture option is selected on 

the BasicStart.bpw Worksheet? 
A Moisture Scenario is a pre-defined set of fuel moisture values for 1-h, 10-h, and 100-h dead fuel 
moisture as well as for live herbaceous and woody fuel moisture. It is analogous to the fuel model 
concept in that a single code represents a set of values. Moisture scenarios give you more flexibility 
to examine multiple variables at a time. Fuel moisture values on the BasicStart.bpw Worksheet are 
entered by individual size class.  

 
7. What options are available as ways to enter wind speed? Next, refer to the Handout. Which wind 

speed option is selected on the BasicStart.bpw Worksheet? 
Wind speed can be entered as:  

• midflame height, 
• 20-ft wind and input wind adjustment factor, 
• 20-ft wind and calculated wind adjustment factor, 
• 10-m wind and input wind adjustment factor, or 

https://www.fs.usda.gov/treesearch/pubs/32533
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• 10-m wind and calculated wind adjustment factor. 
 
The BasicStart.bpw Worksheet asks for Midflame Wind Speed. 

 
8. What inputs are needed if slope is calculated from map measurements? Next, refer to the Handout. Is 

slope entered directly or calculated from map measurements on the BasicStart.bpw Worksheet? 
From the help file, the inputs necessary to calculate slope from map measurements include: map 
representative fraction, contour interval, map distance, and number of contours crossed. Since these 
inputs are not requested on the Worksheet, Slope Steepness must be entered directly. 
 

9. In what two ways can you define wind and spread directions? Next, refer to the Handout. Which 
option is selected on the BasicStart.bpw Worksheet? 
The two ways are degrees clockwise from upslope and degrees clockwise from north. If degrees 
clockwise from upslope is selected, the direction specified is the direction the wind is pushing the fire. 
However, if degrees clockwise from north is selected, the direction specified is the direction from 
which the wind is blowing since that is how wind direction is reported. In the Worksheet, the direction 
is upslope, which can be found both in the input for Midflame Wind Speed (upslope) and the Run 
Option Note “Wind is blowing upslope.” 

 
10. Which additional input fields appear when the Training worksheet header is selected? 

If the Training worksheet header is checked, the additional fields include: Training Course, 
Training Exercise, Trainee Name and Date. 

 
11. How are Effective Wind Speed and Midflame Wind Speed related to each other? 

Effective Wind Speed is the combined effect of both Midflame Wind Speed and Slope Steepness. 
Therefore, Midflame Wind Speed is needed to calculate Effective Wind Speed. 

 
12. What is Surface Reaction Intensity? 

Surface Reaction Intensity is the rate of energy release per area within the flaming front of a fire. 
Surface Reaction Intensity is not affected by wind, slope, or direction of spread. 
 

13. Refer to the Handout. What inputs are required for Surface Fire Rate of Spread and Surface Fire 
Flame Length that are NOT required for Reaction Intensity? 
The additional inputs required to calculate Surface Fire Rate of Spread and Surface Fire Flame 
Length are Midflame Wind Speed, Slope Steepness, and direction of wind or spread if needed. 

 
14. What new category is added to the Worksheet? 

The calculated wind adjustment factor requires information about the canopy. Therefore, the category 
Fuel/Vegetation, Overstory has been added to the Worksheet. 
 

15. What is the difference between the 0Default.bpw and the BasicStart.bpw Worksheet?  
(Hint: Look at the top of the Inputs; making one change to the configuration will create a 
BasicStart.bpw Worksheet from the 0Default.bpw Worksheet). 
No modules are selected in the 0Default.bpw Worksheet. The only difference is the selection of the 
SURFACE module. If you select the SURFACE module in the Module Configuration window, the 
two Worksheets will be the same.  
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Exercises 
 
Remember the suggested order of changes: 

• Make one change at a time and see what is adjustments are needed next (Click Ok to look at the 
Worksheet between steps if you need to).  

• Select the modules that you want to use.  
• Then, select outputs in each of those modules.  
• Change the inputs to match the data you have available to you. 
• Finally, check the Run Option Notes to make sure the assumptions and limitations are correct for 

your analysis. If not, examine the inputs again to make sure they are correct. 
 

1. Open a new BasicStart.bpw Worksheet. Develop a Worksheet that looks like the following. 
Hint: Look at the top of page 5 for a suggestion on how to change the wind options. The Run 
Option Notes also provide information about the wind option to select. 

Question: If Wind Direction (from north) is 90°, which way is the wind blowing? 
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2. Develop a Worksheet that looks like this one. 
Question: How does this Worksheet compare to the related tool (Tools > Slope from map 
measurements)? 

 

 
 
 

3. Create this Worksheet. 
Question: How many Spot Tree Species are there? 
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4. Finally, open the 0Default.bpw Worksheet and change it to look like the following. 
Question: How does the variable Downwind Canopy Height differ from Canopy Height? 

 

.  

 
 
Answers to these exercises can be found in the accompanying PDF file. 
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